MIDI für Könner... (FCB1010, gt-pro)

von fubbe, 20.09.05.

  1. fubbe

    fubbe Registrierter Benutzer

    Im Board seit:
    27.02.05
    Zuletzt hier:
    26.03.12
    Beiträge:
    253
    Zustimmungen:
    0
    Kekse:
    77
    Erstellt: 20.09.05   #1
    Gude.

    Habe samstag 'nen kleinen gig und hatte folgende Idee:
    Ich will ALLE preset-wechsel (der gesammten playlist) mit nur EINEM taster tätigen.
    Da ich ca. 50 verschieden patches benutze und die playlist fest steht, wäre dies eine für mich optimale lösung um auf der bühne möglichst "frei" zu sein. :cool:

    Dazu habe ich alle presets in der richtigen reihenfolge hintereinander abgespeichert.
    Das gt-pro hat die MIDI option "patch: inc", welche bei betätigung zum nächsten patch in der liste springt.

    Ich weiß durchaus wie man mit dem FCB das gt-pro steuert (tempo eintappen, wahwah bediehnen usw...) aber das patchswichen auf diesem weg ist irgendwie buggy! :confused:

    wenn der "patch: inc" befehl des gt-pros nur 127en erhält geschieht nichts.
    wenn 0en empfangen werden ebenso wenig.
    wenn eine 127 UND eine 0 empfangen wird geschieht auch nichts.
    wenn eine 127 und DANACH eine 0 empfangen wird, wird der patch gewechselt.
    aber dazu benötige ich 2 "tritte" auf den schalter!
    wegen meinen übrigen MIDI-einstellungen MUSS ich diese funktion mit nur einem druck schaffen!!

    Kann jemand helfen? (wenns verständlich war)
    Thanx, Fubbe.
     
  2. collazo

    collazo Registrierter Benutzer

    Im Board seit:
    18.08.03
    Zuletzt hier:
    11.04.10
    Beiträge:
    305
    Ort:
    Miltenberg
    Zustimmungen:
    0
    Kekse:
    54
    Erstellt: 20.09.05   #2
    Warscheinlich hast du ein Fehler bei der Programmierung gemacht. Ich hatte zeitlang Probleme meine WahWah einstellung zu speichern. Habe immer diesen einen Fehler gemacht dann ist er mir aufgefallen und es ging. Ich war mir aber nie bewusst das ich einen Fehler machte.
     
  3. fubbe

    fubbe Threadersteller Registrierter Benutzer

    Im Board seit:
    27.02.05
    Zuletzt hier:
    26.03.12
    Beiträge:
    253
    Zustimmungen:
    0
    Kekse:
    77
    Erstellt: 20.09.05   #3
    klar, an so einem fehler könnte es immer liegen...
    ...aber ich kann ihn halt nicht finden!!

    habe schon 1000 mal alles neu eingestellt. (mal gleich, mal anders, mal auf nem andern patch, mal ganz von vorne, ...)

    darum schreib ich ja in dieses forum, damit mir evtl. jemand helfen kann. ;)

    Ich weiß nicht wie ich die assigns beim gt-pro und die MIDI einstellungen beim FCB1010 machen muss, damit das patch-hochschalten klappt.

    logisch wäre meiner meinung nach mit dem FCB ne 127 zu senden und dass das gt-pro alleine mit dieser 127 den "patch: inc" befehl aktiviert.

    aber irgendwie will das gt-pro noch ne 0 hinterher!? :confused: (aber nicht zusammen mit der 127, sondern mit dem nächsten drücken des buttons)
    und danach schaltet es bei jedem schalter-drücken hoch, solange kein anderer schalter zwischengedrückt wird... (dann muss man wieder 2 mal drücken)

    naja, weiß nicht ob ich das jetzt als leser raffen würde... :screwy:

    trotzdem danke, fubbe.
     
  4. pano

    pano Registrierter Benutzer

    Im Board seit:
    25.01.05
    Zuletzt hier:
    18.09.12
    Beiträge:
    225
    Ort:
    Biel/Schweiz
    Zustimmungen:
    2
    Kekse:
    79
    Erstellt: 20.09.05   #4
    Du kannst doch beim FCB1010 zwei CC Commands schicken. Wenn du beide auf den gleichen CC programmierst und beim einen einfach ne 127 schickst und beim andern ne 0 sollte das doch dem entsprechen oder?

    oder hast du damit schon das gemeint was ich vorgeschlagen habe?
     
  5. fubbe

    fubbe Threadersteller Registrierter Benutzer

    Im Board seit:
    27.02.05
    Zuletzt hier:
    26.03.12
    Beiträge:
    253
    Zustimmungen:
    0
    Kekse:
    77
    Erstellt: 20.09.05   #5
    wenn man beim FCB zwei commands schickt, die die gleiche cc# haben, wird bei jedem drücken des buttons zwischen der 127 und der 0 abgewechselt!
    die beiden werte werden nicht gleichzeitig gesendet!

    also kommt zuerst 127, beim nächsten drücken 0, dann wieder 127 usw...

    ich habe aber auch versucht, gleichzeitig die 127 auf z.b. cc# 80 und die 0 auf z.b. cc# 81 zu senden. beim gt-pro hab ich dann "patch: inc" sowohl cc# 80 als auch cc# 81 zugewiesen.

    aber dann geschah auch nichts.. :confused:

    nur wenn ich abwechselnd 127 und danach 0 schicke, wechseln die patches.
    Problem: wenn ich nun einen anderen button (z.b. "solo on" oder "wah on") drücke und dann weiter die patches hochschalten möchte, muss ich MANCHMAL 2 mal drücken!
    (wohl je nach dem, ob dann 0 oder 127 gesendet wird...)
     
  6. pano

    pano Registrierter Benutzer

    Im Board seit:
    25.01.05
    Zuletzt hier:
    18.09.12
    Beiträge:
    225
    Ort:
    Biel/Schweiz
    Zustimmungen:
    2
    Kekse:
    79
    Erstellt: 20.09.05   #6
    Hmmm, im Manual vom gt-pro steht das vom Patch Num. inc/dec im zusammenhang mit dem Boss FC-200 Footcontroller (im Manual-Mode).

    Vielleicht geht das Behringer Teil irgendwie anders damit um.....
     
  7. fubbe

    fubbe Threadersteller Registrierter Benutzer

    Im Board seit:
    27.02.05
    Zuletzt hier:
    26.03.12
    Beiträge:
    253
    Zustimmungen:
    0
    Kekse:
    77
    Erstellt: 20.09.05   #7
    hmm aber dass es mit dem FCB nicht geht glaub ich nicht, ist nur die frage WIE es damit geht... :confused:

    Ich schau mal nach, wie die funktion mit dem FC-200 angesteuert wird.
    Evtl. kann man daraus was erkennen.

    Mfg.
     
  8. Zven Bernstein

    Zven Bernstein Registrierter Benutzer

    Im Board seit:
    20.09.05
    Zuletzt hier:
    10.12.06
    Beiträge:
    39
    Ort:
    New York
    Zustimmungen:
    0
    Kekse:
    14
    Erstellt: 20.09.05   #8
    da kann ich dir nur von abraten. Diese Methode habe ich früher genutzt. Wenn du es so machst, programmier auf alle Fälle einen Zurück Knopf, sonst stehst du später da, einen Patch zu weit und kommst nicht zurück auf deinen Sound.
     
  9. fubbe

    fubbe Threadersteller Registrierter Benutzer

    Im Board seit:
    27.02.05
    Zuletzt hier:
    26.03.12
    Beiträge:
    253
    Zustimmungen:
    0
    Kekse:
    77
    Erstellt: 20.09.05   #9
    jepp!

    Sachen wie: zurück, lauter, leiser, tap-tempo, wah, solo und evtl. alternative patches werden auf den anderen tastern abgespeichert... :)

    nur das "patch inc" sifft irgendwie..
     
Die Seite wird geladen...

mapping