MIDI IN geht nicht

von Tastendilettant, 13.03.06.

  1. Tastendilettant

    Tastendilettant Registrierter Benutzer

    Im Board seit:
    24.02.06
    Zuletzt hier:
    14.10.12
    Beiträge:
    1.042
    Zustimmungen:
    25
    Kekse:
    1.031
    Erstellt: 13.03.06   #1
    Hallo,

    ich habe ein blödes Problem mit meiner MIDI-Schnittstelle. Ich möchte mein Digital-Piano an den Rechner anschliessen und habe mir für diesen Zweck ein Standard Joystick/MIDI Interfacekabel besorgt. Wähle ich am Rechner ein MIDI-File, so wird das einwandfrei auf meinem Piano gespielt, nur anders herum geht es einfach nicht. Ich habe es mit mehreren Programmen versucht, das letzte lauscht auf allen MIDI Kanälen, aber es kommt nichts am Rechner an. Auch am Piano hab ich inzwischen alle Kanäle getestet, MIDI OUT ist dort aktiviert, und die Kontroll-LED im Display zeigt auch an, daß etwas rausgeschickt wird. Nachdem ich sogar die Soundkarte getauscht habe, bin ich nun etwas ratlos. Das Kabel ist neu, jedoch glaube ich, gelesen zu haben, daß die preiswerten Kabel Probleme machen könnten. Kann das ein Grund sein?

    Gruß,
    Andreas
     
  2. Tastendilettant

    Tastendilettant Threadersteller Registrierter Benutzer

    Im Board seit:
    24.02.06
    Zuletzt hier:
    14.10.12
    Beiträge:
    1.042
    Zustimmungen:
    25
    Kekse:
    1.031
    Erstellt: 13.03.06   #2
    So, jetzt habe ich den Fehler gefunden. Es ist das Kabel, denn wenn ich das Ding, im Port steckend, mit ein wenig Druck nach unten bewege, dann geht's. Nur dummerweise lässt sich so nicht besonders gut spielen. ;) Sind eigentlich alle MIDI-Interfaces für die Tonne? Vor langer Zeit hatte ich mit 'nem Synthesizer ein ähnliches Problem.
     
  3. osterchrisi

    osterchrisi Registrierter Benutzer

    Im Board seit:
    04.11.03
    Zuletzt hier:
    6.04.08
    Beiträge:
    317
    Zustimmungen:
    0
    Kekse:
    25
    Erstellt: 14.03.06   #3
    Nein, es sind definitiv nicht alle MIDI Interfaces "für die tonne", aber mir fällt auch auf, dass MIDI Kabel leichter brechen als diverse Audiokabel, zumindest is das nicht nur bei mir zu beobachten...
    Vielleicht kriegst du's ja mit ein bisschen gaffa hin :great:
     
  4. Jay

    Jay HCA Piano/Spieltechnik Ex-Moderator HCA

    Im Board seit:
    29.10.03
    Zuletzt hier:
    6.12.16
    Beiträge:
    4.667
    Ort:
    München
    Zustimmungen:
    181
    Kekse:
    7.137
    Erstellt: 15.03.06   #4
    Das liegt vielleicht daran, dass Instrumentenkabel i.d.R. als "trittfest" verkauft werden (Gitarristen, etc.). Bei MIDI-Kabeln hab ich das noch nicht gesehen, das ist bestimmt nur leihwendiges Zeugs.
     
  5. Tastendilettant

    Tastendilettant Threadersteller Registrierter Benutzer

    Im Board seit:
    24.02.06
    Zuletzt hier:
    14.10.12
    Beiträge:
    1.042
    Zustimmungen:
    25
    Kekse:
    1.031
    Erstellt: 15.03.06   #5
    Hallo,

    also das Problem ist jetzt genau lokalisiert. Merkwürdigerweise hatte Pin 15 (= MIDI IN von der Soundkarte aus gesehen) keinen Kontakt zur Buchse der Soundkarte. Das ging mir dermaßen auf den Keks (wie kommt sowas?), daß ich diesen Pin mit 'nem feinen Seitenschneider bearbeitet haben. Also nicht gekürtzt ;), sondern ich habe ein paar Kerben "eingearbeitet" und so den Querschnitt vergrössert. Seit dem geht es, aber auf Dauer kann ich das Ding wohl weg werfen. Wie zuverlässig laufen eigentlich diese MIDI/USB Adapter? Und funktionieren die auch unter Linux?
     
  6. fubar

    fubar Registrierter Benutzer

    Im Board seit:
    05.01.04
    Zuletzt hier:
    10.08.15
    Beiträge:
    103
    Ort:
    Dortmund
    Zustimmungen:
    0
    Kekse:
    59
    Erstellt: 18.03.06   #6
    Also die gängigen Midi-Interfaces sollten ohne Probleme auch unter Linux laufen. Über die M-Audio Midisport Interfaces habe ich bisher eigentlich nur gutes gehört, was die Linux-Unterstützung angeht. Aber im Zweifelsfall schadet es halt nie, vor dem Kauf mal auf den ALSA-Seiten nachzugucken oder einfach Google zu fragen.
     
  7. bollich

    bollich Registrierter Benutzer

    Im Board seit:
    27.11.03
    Zuletzt hier:
    3.05.11
    Beiträge:
    693
    Ort:
    40764
    Zustimmungen:
    6
    Kekse:
    413
    Erstellt: 18.03.06   #7
    Einen Gameport betrachte ich nicht als "Midi-Interface". Auch wenn er's in einge PCs kann.
     
  8. Tastendilettant

    Tastendilettant Threadersteller Registrierter Benutzer

    Im Board seit:
    24.02.06
    Zuletzt hier:
    14.10.12
    Beiträge:
    1.042
    Zustimmungen:
    25
    Kekse:
    1.031
    Erstellt: 19.03.06   #8
    Bisher dachte ich immer, ein MIDI Interface ist ein MIDI-Interface. Egal, eigentlich wollte ich nur ein wenig herum experimentieren. Werde mir wohl ein USB/MIDI Interface kaufen. Kosten ja nicht die Welt.

    Danke soweit,
    Andreas
     
  9. fubar

    fubar Registrierter Benutzer

    Im Board seit:
    05.01.04
    Zuletzt hier:
    10.08.15
    Beiträge:
    103
    Ort:
    Dortmund
    Zustimmungen:
    0
    Kekse:
    59
    Erstellt: 19.03.06   #9
    Ich wüßte jetzt auch nicht, warum das kein "richtiges" MIDI Interface sein sollte. Man braucht halt ein extra Kabel dafür (und das auch schon allein deswegen, weil MIDI Stecker nicht durch die Slots am Rechner passen).
    Der "Gameport-MIDI-Anschluß" meiner SBlive funktioniert jedenfalls seit Jahren tadellos, auch und gerade unter Linux. Und billiger als ein USB-Adapter ist's allemal...
     
  10. Distance

    Distance Mod Emeritus Ex-Moderator

    Im Board seit:
    22.07.05
    Zuletzt hier:
    13.03.15
    Beiträge:
    9.007
    Zustimmungen:
    836
    Kekse:
    20.854
    Erstellt: 19.03.06   #10
    same here!
    hatte auch jahrelang ne sblive, die hats prima getan... und mit dem neuen pc kam dann ne audigy 2, läuft genauso super, alles über gameport...

    darüber spiel ich sachen ein und ab und mache sysex-dumps auf meine keys (os-updates und so) - alles völlig problemlos...
    ich seh da keinen grund für nen usb-interface...
     
  11. Tastendilettant

    Tastendilettant Threadersteller Registrierter Benutzer

    Im Board seit:
    24.02.06
    Zuletzt hier:
    14.10.12
    Beiträge:
    1.042
    Zustimmungen:
    25
    Kekse:
    1.031
    Erstellt: 19.03.06   #11
    So sollte es ja auch sein. Komischerweise wird bei mir der Kontakt nicht richtig hergestellt. Ich muß heftig am Stecker wackeln oder das Teil mehr oder weniger mit Gewalt hinein und nach unten drücken, dann geht es manchmal. Vielleicht ist auch dieser Adapter einfach nur von schlechter Qualität. Wie gesagt, ich habe zwei Soundkarten damit getestet, eine davon ist auch auch SB Live.
     
  12. Distance

    Distance Mod Emeritus Ex-Moderator

    Im Board seit:
    22.07.05
    Zuletzt hier:
    13.03.15
    Beiträge:
    9.007
    Zustimmungen:
    836
    Kekse:
    20.854
    Erstellt: 20.03.06   #12
    klingt für mich arg nach einem stinknormalen wackelkontakt!
     
  13. toeti

    toeti Keys Moderator

    Im Board seit:
    19.08.03
    Zuletzt hier:
    7.12.16
    Beiträge:
    13.678
    Ort:
    Herdecke
    Zustimmungen:
    802
    Kekse:
    19.759
    Erstellt: 20.03.06   #13
  14. Distance

    Distance Mod Emeritus Ex-Moderator

    Im Board seit:
    22.07.05
    Zuletzt hier:
    13.03.15
    Beiträge:
    9.007
    Zustimmungen:
    836
    Kekse:
    20.854
    Erstellt: 20.03.06   #14
    stimmt, war nicht ganz korrekt... ich wollte es eigentlich aufsplitten, hab mich dann aber während des schreibens doch umentschieden, daher das fullquote
     
  15. snake73

    snake73 Registrierter Benutzer

    Im Board seit:
    13.01.06
    Zuletzt hier:
    19.11.06
    Beiträge:
    14
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 23.03.06   #15
    Da ist ja meine Frage auch fast beantwortet :)

    Seh ich das richtig das ich dann nur ein Kabel bräuchte mit dem Anschluß an den Gameport (als MIDI anschluß ?!) und halt auf den andere seite den MIDI-Stecker für mein V-Amp !?
     
  16. bollich

    bollich Registrierter Benutzer

    Im Board seit:
    27.11.03
    Zuletzt hier:
    3.05.11
    Beiträge:
    693
    Ort:
    40764
    Zustimmungen:
    6
    Kekse:
    413
    Erstellt: 23.03.06   #16
    Das geht prinzipiell - aber was willst du dann mit dem V-Amp am PC?
     
  17. snake73

    snake73 Registrierter Benutzer

    Im Board seit:
    13.01.06
    Zuletzt hier:
    19.11.06
    Beiträge:
    14
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 24.03.06   #17
    Um die Software benutzen zu können muss das teil wohl darüber am PC angeschlossen sein.

    Dann kann ich mir vorprogrammierte einstellungen in den v-amp einspielen und auch firmware updates :)
     
Die Seite wird geladen...

mapping