Seltsame Latenz mit Midikeyboard in Logic

von Sabian, 13.04.04.

  1. Sabian

    Sabian Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 13.04.04   #1
    Hi,

    ich hab n relativ altes midikeyboard über ne audiophile 2496 PCI Karte angeschlossen. Auf meinem Rechner hab ich Logic und Reason drauf.
    Jetzt das Problem:
    Wenn ich in Logic den ESX oder Sonstwas mit dem Midikeyboard anspreche *Tastendrück* dann hab ich
    1. ne gewisse Verzögerung (vielleicht 0,2 sec) drin, auf jeden Fall eine gut bemerkbare Verzögerung.
    2. kann ich höchstens 2, manchmal auch 3 Töne gleichzeitig spielen. Alle anderen werden "gefressen"
    3. hab ich ne höchstgeschwindigkeit beim spielen, ca 4-5 Tasten pro Sekunde

    Alles in allem ziemlich nervig :mad:

    Am Anfang dachte ich es wäre das keyboard, doch habe ich dann zufällig mein Keyboard mit Reason getestet! Da war alles hervorragend. Keine spürbare Latenz, keine Tonfresser, mehr als 5 Tasten pro Sek spielbar, ich konnte ganz normal spielen.
    Also hab ich mich an Logic gemacht. Nach zigmal Logicneustarten alle mir möglichen Einstellungen rumfummel, weiß ich nicht mehr weiter...


    Ich habe grad frisch den neuesten Treiber für meine Karte installiert.
    Trotzdem kein Unterschied!

    MfG
    Sabian
     
  2. Sabian

    Sabian Threadersteller Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 13.04.04   #2
    Mir ist grad noch was neues aufgefallen:

    Ich habe gerade einen Akkord übers Midikeyboard aufgenommen. Diesen habe ich mehrmals hintereinander gespielt und habe jedesmal nur einen einzigen Ton gehört.
    ABER als ich auf die Midi Daten geklickt habe, sind alle Töne vorhanden und in der richtigen (von mir gespielten) Geschwindigkeit aufgenommen.

    Mein Fazit (als Newbie):
    Intern kommen in Logic die Mididaten einwandfrei an, jedoch ist der Output irgendwie... äh schrott? Oder vielleicht nur falsch eingestellt ?

    Auf jeden Fall muss da doch irgendne Verzögerung entstehen von der Aufnahme zur Ausgabe an den ESX?


    Sabian
     
  3. StompBoxLover

    StompBoxLover Registrierter Benutzer

    Im Board seit:
    09.02.04
    Zuletzt hier:
    11.05.04
    Beiträge:
    383
    Zustimmungen:
    3
    Kekse:
    11
    Erstellt: 13.04.04   #3
    hi,

    bist du sicher das du in Logic auf die ASIO Treiber aktiviert hast?

    danach must du Logic nochmal starten.

    darüberhinaus könnte es auch sein das die polyphonie des EXS einfach eingeschränkt ist (vom preset her)
    oder dein Rechner hat nicht genug power.
    oder die Festplatte ist zu lahm.

    genaugenommen ist der EXS der einzige wirklich professionelle VSTi sampler, an dem liegts also ganz bestimmt nicht.
    das ding arbeitet sample-akkurat.

    cheers,

    SBL
     
  4. Sabian

    Sabian Threadersteller Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 13.04.04   #4

    Asio aktiviert, 16 polyphonie eingeschaltet.
    Performance:
    2600 (2083Mhz) AthlonXP, 1 GB ram 2-2-2-5 im Dual Channel Modus, 120 GB 7200 upm Barracuda. Ist doch hoffentlich ausreichend dafür ?!
     
  5. StompBoxLover

    StompBoxLover Registrierter Benutzer

    Im Board seit:
    09.02.04
    Zuletzt hier:
    11.05.04
    Beiträge:
    383
    Zustimmungen:
    3
    Kekse:
    11
    Erstellt: 14.04.04   #5
    jau,

    dat sollte reichen :D

    welche logic version hast du denn?

    da fällt mir noch ein:

    unter XP sollte man unter

    systemeigenschafter->erweitert->leistungsoptionen->erweitert

    Prozessorzeitplanung auf Hintergrunddienste setzen, da ASIO ein solcher ist.

    cheers,

    SBL
     
  6. Sabian

    Sabian Threadersteller Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 14.04.04   #6
    Hab Logic 5.5.
    Hatte 5.2 und hab dann upgedated. Kein Unterschied.
    Prozessor ist so eingestellt, kein Unterschied.

    *Snief*
     
  7. whitealbum

    whitealbum HCA Mikrofone HCA

    Im Board seit:
    28.10.03
    Beiträge:
    1.889
    Zustimmungen:
    970
    Kekse:
    9.467
    Erstellt: 15.04.04   #7
    liste doch mal auf, was Du bei den ASIO-Einstellungen eingestellt hast.
    Da vermute ich das Problem!

    Grüße
    Andreas
     
  8. Sabian

    Sabian Threadersteller Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 17.04.04   #8
    So korrigierte Version... Die Asio Einstellungen:
     

    Anhänge:

  9. whitealbum

    whitealbum HCA Mikrofone HCA

    Im Board seit:
    28.10.03
    Beiträge:
    1.889
    Zustimmungen:
    970
    Kekse:
    9.467
    Erstellt: 18.04.04   #9
    Hi Sabian,
    zuerst ändere Process Buffer Range mind. auf medium, bei deinen Rechner sollte auch small drin sein. Das Häkchen von Larger Disk Buffer rausnehmen.
    Deine Einstellungen gelten nur für "lahme" Rechner.

    Gehe dann in Control Panel rechts neben Driver M-Audio Delta ASIO.
    Jetzt bist Du im M-Audio-Delta Control Panel.
    Gehe auf den Reiter Hardware Settings zum Punkt DMA Buffer Size (linke untere Hälfte), hier sollte Latency auf 256 stehen entspricht ca. 5ms Latenz bei 44.1 Khz.
    Wenn ein wesentl. höherer Wert angezeigt wird, liegt hier der Hund begraben.

    Melde Dich, ob Du ein Schritt weiter gekommen bist.
    Grüße
    Andreas
     
  10. Sabian

    Sabian Threadersteller Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 19.04.04   #10
    Habe jetzt alles so eingestellt. Samples auf 256, standen vorher auf 512. Aber ich höre keinen Unterschied.

    Jetzt noch was neues:
    Ich habe im Enviroment Fenster ein VST Plugin (ePiano) aktiv. Jetzt drück ich Links auf Audio und ein Pop Up Menu hüpft auf. Dort geh ich auf "Klick & Port". Jetzt seh ich die "physikalische Verkabelung".
    Verbunden vom Physikalischen Eingang -> Eingangsnoten (dem Klavier) -> Eingangsanzeige -> zur Aufnahme & MIDI Thru.
    Wenn ich jetzt die Verbindung ändere:
    Physikalischen Eingang -> Eingangsnoten (dem Klavier) -> Eingangsanzeige -> MIDI Out 3
    dann passiert folgendes:
    Das Epiano höre ich nicht mehr und stattdessen höre ich ein normales Klavier bei Tastenanschlag. Das "tolle" ist, das es dann praktisch funktioniert. Diese höchstgeschwindigkeitbegrenzung fehlt, ich kann soviele Tasten drücken wie ich will und höre sie auch alle. Das einzige was nur ein wenig weniger wird, ist die Latenz.
    Sie ist immernoch vorhanden, aber kaum störend. Vielleicht ist das die Standartlatenz von MIDI.
    Was blöd ist, das VST Plugin ist nicht mehr aktiv und ich seh in meiner MIDI anzeige auch nur noch Ausgangssignale.

    hm... keine Ahnung ob euch diese Info was bringt.

    Ich teste jetzt mal, ob ich die Latenz überhaupt erhöhen/erniedrigen kann.
     
  11. Sabian

    Sabian Threadersteller Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 19.04.04   #11
    Also ich höre bei höchster Sample Rate (96000) und Buffer Size von 64 nicht wirklich einen Unterschied. Ich und mein Mitbewohner haben eher das Gefühl, dass es mit diesen Einstellungen langsamer ist als mit 44100 und 2048 Buffer Size. Aber trotzdem haben beide eine Gewisse Latenz. Mein Mitbewohner meinte, dass das locker 100 ms wenn nicht noch mehr sind.

    Ich habe das Gefühl, dass da irgendwas faul ist, da die Einstellungen nicht wirklich was ändern. Gibt es nicht die Möglichkeit die Latenz auf eine Sekunde zu heben ? Dann könnte ich nämlich viel leichter hören ob es dann einen Unterschied macht.

    Ansonsten noch ein Bild meiner momentanen M-Audio Delta Einstellungen:
     

    Anhänge:

  12. whitealbum

    whitealbum HCA Mikrofone HCA

    Im Board seit:
    28.10.03
    Beiträge:
    1.889
    Zustimmungen:
    970
    Kekse:
    9.467
    Erstellt: 19.04.04   #12
    hi sabian,
    ich habe da ein Verdacht.
    Wenn Du bei der Audiophile die Buffer Size wesentlich änderst, und da tut sich nichts beim Einspielen, dann habe ich den Verdacht, dass der ASIO-Treiber in Logic gar nicht angesprochen wird.
    Zunächst mal, mache unter Klick&Port alles wieder rückgängig (die midi Outs sind vorbelegt u.a. auch mit SW Synth von Onboard Soundkarten etc., dass kann man alles anpassen, aber da liegt das Problem nicht.).
    Geh' mal auf die Audio-Sicht im Environment zurück, dann müsstest Du Audiokanäle und Audioinstkanäle sehen können. Klicke direkt auf einen Audioinstkanal und wähle ein Logicinstrument wie ES P zum Test aus.
    Links müßte ein kleines Menü AudioInst 1 oder ähnl. stehen, darunter kommt ein Eintrag zu Dev. Hier muss ASIO stehen. Du solltest alle Kanäle, wenn noch nicht gemacht, auf ASIO umstellen (in diesem besagten Feld).

    Vielleicht hast Du unter ASIO-Einstellungen im ersten Audio-Treiber-Reiter unter PC AV auch diesen aktiviert, und der ist dann bei den Audioinst wie Audiokanälen voreingestellt. Ich vermute daran liegts.
     
  13. Sabian

    Sabian Threadersteller Registrierter Benutzer

    Im Board seit:
    04.03.04
    Zuletzt hier:
    10.10.04
    Beiträge:
    20
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 21.04.04   #13
    Ich verlier mein Grinsen nicht mehr. *TränenindieAugensteig*

    Ich kann dir nicht sagen wie lang, wie lang das jetzt gedauert hat. Aber das waren WOCHEN. DANKE DANKE DANKE DANKE DANKE

    *michtiefverneigvorsovielklugheit*

    Hammersache das. Endlich. Endlich kann ich Musik machen ohne diese Bremse.

    Dankeschön whitealbum.

    Achso, vor lauter lauter:
    Du hattest recht mit der Einstellung im Audio Reiter 1. PC AV war/ist aktiviert und durch das Einstellen des Instrumentes auf ASIO hats geklappt.
    Soll ich jetzt des PC AV einfach wegklicken/ausmachen oder brauch ich das für irgendwas ?

    Liebe Grüße und vielen Dank,
    Sabian
     
  14. whitealbum

    whitealbum HCA Mikrofone HCA

    Im Board seit:
    28.10.03
    Beiträge:
    1.889
    Zustimmungen:
    970
    Kekse:
    9.467
    Erstellt: 21.04.04   #14
    :) , SUPER, das freut mich wirklich, dass ich Dir in der Entfernung helfen konnte :)
    Als ich mit LOGIC anfing, hatte ich auch immer mal solche Probleme, und die bleiben einem einfach im Gedächtnis ;)
    In LOGIC hat man die Möglichkeit alles individuell einzustellen, so dass auch mal solche Dinge passieren. Aber wenn man sich in LOGIC eingearbeitet hat, wird man es nicht bereuen.

    PC/AV solltest Du wegklicken, damit steuerst Du den MME-Driver an, und der hat eben bestenfalls eine Latenz von 200 ms, was man beim VSTi einspielen vergessen kann.
    Wenn Du neue Audiokanäle oder Instrumente definierst, könntest Du nochmal über dieses Problem stolpern, klicke das lieber weg, ändere aber vorher auch alle Audiokanäle, Audioinstr, Busse und Co. unter Audio im Environment auf ASIO ab.


    Und jetzt, viel, viel Spaß beim Musik machen!

    Liebe Grüße
    Andreas
     
Die Seite wird geladen...

mapping