Synth. über Gameport/Midi anschliessen

von seal, 07.08.04.

  1. seal

    seal Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #1
    Das leidige Thema... :(

    Hallo...,

    ich weiss, sicher tausendmal gefragt.Bin aber langsam am verzweifeln, hab den ganzen Tag schon gegoogelt u. mich durch sämtliche Foren geackert, aber ich bekomm es nicht hin.

    Besitze einen Yamaha DX 27, den ich über den Gameport an meinen PC anschliessen möchte, da ich eine Onboardsoundkarte habe.
    Den Synth. möchte ich als Masterkeyboard verwenden.
    Als Software benutze ich Reason 2.5.
    Ich habe ein Midikabel mit den zwei fünfpoligen Steckern für In u. Out an der einen und dem Adapterstecker für den Gameport auf der anderen Seite.
    Gesteckt habe ich jetzt den Midi-In-Stecker beim Synth auf Out u. den Midi-Out-Stecker auf In also entgegengesetzt...während die andere Seite im Gameport steckt.

    Beim Synth. ist die Midifunktion auf On gestellt u. beide Channels (Midi R u. Midi T) auf 1.
    Bei Reason habe ich bei Preferance den Midiport auf MPU 401 gewählt, auch dass Midizeichen erscheint im Sequencer vor der angewählten Spur...nur nichts tut sich kein Mucks...die Soundkarte ist auf jeden Fall konfiguriert, habe auch die Treiber für die Audio-u. Gameportfunktionen aktualisiert.

    Ich krieg bald die Krise, hab echt alles probiert u. weiss nich weiter (habe auch das Midikabel mehrmals umgesteckt...nix!)

    :confused:

    Könnte mir jemand bitte helfen...?!
     
  2. .Jens

    .Jens Mod Emeritus Ex-Moderator HCA

    Im Board seit:
    18.08.03
    Zuletzt hier:
    3.12.16
    Beiträge:
    10.615
    Ort:
    Hamburg
    Zustimmungen:
    1.928
    Kekse:
    23.787
    Erstellt: 07.08.04   #2
    Moin...

    vielleicht hast du es ja schon gelesen, wenn nicht, dann such mal hier im Forum (Suchfunktion) nach "Gameport Midi" - da dürftest du noch einiges finden.

    Als wichtigste Info für dich vorweg: Der "midiox" (Freeware, einfach mal googlen) zeigt zuverlässig an, ob am Midi-Eingang was ankommt.

    Zweite Frage: Welche Soundkarte benutzt du? Hat die wirklich den MPU-Chip? Meist liegt es daran...

    Jens
     
  3. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #3
    Hallo...,

    danke für Deine Antwort. Onboardsoundkarte:"DX C-Media Wave Device".
    Der Rechner ist knapp zwei Jahre...

    Hab hier schon etwas rumgelesen. Das Tera-Demo funzt überhaupt nicht bei mir, lässt sich zwar installieren aber dann nicht öffnen, habe es mehrmals installiert u. wieder deinstalliert.
     
  4. engineer

    engineer HCA Recording HCA

    Im Board seit:
    13.07.04
    Zuletzt hier:
    11.02.15
    Beiträge:
    1.319
    Ort:
    Bundesweit
    Zustimmungen:
    26
    Kekse:
    268
    Erstellt: 07.08.04   #4
    Mir ist nicht bekannt, daß man mit onboad-Soundkarte MIDI verarbeiten könnte- es sei denn das wird emuliert. Dann braucht es aber noch irgendwo einen Anschluss oder ? MIDI kommen ja als 5polige DIN-Stecker und wo soll bei onboard ein MIDI-Signal rauskommen ? :o :confused:
     
  5. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #5
    Gute Frage, aber warum besteht die Möglichkeit, Midi über den Gameport anzuschliessen, dies ist doch nur bei Onboardsoundkarten der Fall...oder :confused:

    @Jens...habe MidiOx ausprobiert...rechts ganz unten steht: "No Input Device"
     
  6. Reyman

    Reyman Registrierter Benutzer

    Im Board seit:
    24.01.04
    Zuletzt hier:
    28.07.09
    Beiträge:
    127
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #6
    Also, bist du dir ganz sicher, dass du alles richtig eingestellt hast?

    -->Systemsteuerung--> Sounds und Audiogeräte

    Dort müsste irgendwo was von Midi, Synthesizer o.ä. stehen.
    Irgendwo steht da was von: MIDI-Musikwiedergabe.
    Schau dir das nochmal an, wenn du das schon hast, sorry

    Das mit dem Gameport funktioniert, hatte ich früher, bevor ich mir meine Terratec DMX 6 Fire 24/96 gekauft habe, auch so gemacht.

    Du hast nur eine Soundkarte oder?
     
  7. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #7
    Okay, habe nachgeschaut...unter Midimusikwiedergabe steht Standartgerät, unter diesem Unterpunkt: MPU 401 ; Microsoft GS Wavetable SW Synth ; Creative Soundblaster MPU 401...

    Unter Soundwiedergabe habe ich noch Creative Soundblaster PCI als zweites stehen, neben der von mir oben genannten Soundkarte...
     
  8. Reyman

    Reyman Registrierter Benutzer

    Im Board seit:
    24.01.04
    Zuletzt hier:
    28.07.09
    Beiträge:
    127
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #8
    also, du solltest dort GS Wavetable SW Synth auswählen, sofern deine 2. SOundkarte nichts weiteres anbietet


    EDIT:
    Falsch, von mir...

    nehm das mit Creative bei Midi Wiedergabe
     
  9. Reyman

    Reyman Registrierter Benutzer

    Im Board seit:
    24.01.04
    Zuletzt hier:
    28.07.09
    Beiträge:
    127
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #9
    andere Frage:

    Über welche Soundkarte soll es denn nun laufen?
     
  10. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #10
    ...also, die Soundkarte ist mir eigentlich egal.
    Angegeben habe ich bei Reason "DX C-Media Wave Device".

    Wenn die Soundkarten nicht Midifähig wären, würde doch sicher nichts von Midimusikwiedergabe dort stehen... :confused:
     
  11. Reyman

    Reyman Registrierter Benutzer

    Im Board seit:
    24.01.04
    Zuletzt hier:
    28.07.09
    Beiträge:
    127
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #11
    was kann man denn dort alles angeben?

    Btw.
    Media Wave ...
    Das kann nicht das richtige sein, da eine Wave Datei ein Impulse bzw. ein Schall ist (Welle).
    Midi ist aber kein Ton oder Klang , also Schalkl - Welle, sondern einfach eine Information.
     
  12. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #12
    Ich kann bei beiden Soundkarten, der "DX C-Media Wave Device", als auch der " Creative Soundblaster PCI" in der Systemsteuerung bei Audio unter Midimusikwiedergabe folgende drei Punkte anklicken:

    - MPU 401
    - Microsoft GS Wavetable SW Synth
    - Creative Soundblaster MPU 401

    ...wobei ich bei Reason diese Karte angegeben habe : "DX C-Media Wave Device"... :)
     
  13. engineer

    engineer HCA Recording HCA

    Im Board seit:
    13.07.04
    Zuletzt hier:
    11.02.15
    Beiträge:
    1.319
    Ort:
    Bundesweit
    Zustimmungen:
    26
    Kekse:
    268
    Erstellt: 07.08.04   #13
    seal, was du dort beschreibts ist eine Agnabe für Windows, wohin MIDI-Daten geschickt werden. Wenn nicht das MPU-Emulationsdevice auf irgendeine Hardware pointed, dann geht nix. Die anderen beiden sind die Software/Hardwarerenderer, die das MIDI in ein WAV verwandeln (was eigentlich Dein Keyboard machen soll). Das zuletzt genannte device "DX C-Media Wave Device" ist nichts anderes als die vrituelle wave mixer adresse zu der die wav-Daten wandern.

    Du brauchst einen MIDI-Treiber mit einer MIDI-Hardware. Hast Du denn einen echten game-port (15poligen Stecker) an Deinem Rechner / Soundkarte ?
     
  14. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #14
    *kopfkratz*...mönsch ist ja ganz schön kompliziert... :eek:

    [​IMG]

    dieses kabel hab ich, wie gesagt midi-in beim synth. auf midi-out u. umgekehrt...das andere ende, das 15 polige kabel ist im gameport eingesteckt, erkenntlich an dem joysticksymbol...
     
  15. engineer

    engineer HCA Recording HCA

    Im Board seit:
    13.07.04
    Zuletzt hier:
    11.02.15
    Beiträge:
    1.319
    Ort:
    Bundesweit
    Zustimmungen:
    26
    Kekse:
    268
    Erstellt: 07.08.04   #15
    Das sieht gut aus. Der 15polige Stecker ist deshalb doppelt, weil es male/female ist und der 5polige, weil In+OUT. Du must aber aufpassem: Manchmal sind die etwas seltsam bezeichnet. Bei mir sind die Pfeile auf den MIDI-Steckern falsch. "In" muss meist an den MIDI-IN des Keyboards und ist damit nicht der Input der Soundkarte. Ich würde erst versuchen , mit einem MIDI-Player etwas abzuspielen und das dem KeyBoard zuzuleiten. So können niemals unbeabsichtigt die Ausgänge gegeneinander arbeiten.

    Du must nun versuchen, alle Treiber des C-Media-Chips zu installieren. Dann mit dem Windows-Mediaplayer ein midi file laden und abspielen. Vorher in den Systemmanager/Geräteeinstellungen "Multimedia" das Standard Midi-Gerät wählen. Ich würde das MPU401 nehmen, wenn es kein anderes gibt, das nach hardware ausgang aussieht. Bei mir (AWE) heisst es im Übrigen : MIDI-out (330).
     
  16. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.08.04   #16
    okay,ich habe jetzt mal die stecker getauscht, also in auf in und out auf out am synth...

    ist es denn richtig, das der zweite stecker, der 15-poligen buchse am rechner ungenutzt bleibt u. einfach nur daneben hängt??

    wie lade ich denn ein midifile...*peinlich*
     
  17. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 08.08.04   #17
    Guten Morgen...

    habe mir jetzt einen Miditest runtergeladen. Wenn ich dort im Optionsfenster "Microsoft GS Wavetable SW Synth" eingebe, kann ich über die Maus die virtuellen Tasten bedienen u. höre tatsächlich Klaviergeklimper (bei anderen Optionen nicht)...ist doch schonmal ein gutes Zeichen oder!!??

    Wie soll ich jetzt am besten weiter verfahren??
     
  18. Reyman

    Reyman Registrierter Benutzer

    Im Board seit:
    24.01.04
    Zuletzt hier:
    28.07.09
    Beiträge:
    127
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 08.08.04   #18
    ja, das ist schonmal in Ordnung :D

    naja, du möchtest ja jetzt die Midi Noten an deine Soundkarte (on board, wie das aussieht) senden.

    Ich denke du solltest einmal probieren einfach mal mit deinem Masterkeyboard versuchen dieses
    "Klaviergeklimper "
    zu spielen, vielleicht kommt ja schonmal was.

    Als nächstes solltest du die Midikanäle überprüfen (auf welchen Midikanal das Masterkeyboard sendet und auf welchem Kanal empfangen wird..).

    Probier das alles mal aus.

    Sag bescheid, was sich getan hat
     
  19. .Jens

    .Jens Mod Emeritus Ex-Moderator HCA

    Im Board seit:
    18.08.03
    Zuletzt hier:
    3.12.16
    Beiträge:
    10.615
    Ort:
    Hamburg
    Zustimmungen:
    1.928
    Kekse:
    23.787
    Erstellt: 08.08.04   #19
    Moin zusammen...

    es ist, wie so oft: hier gehen wieder viele Dinge durcheinander. Dazu bitte nochmal auch die anderen Threads aufmerksam lesen.

    Ich versuch's nochmal in Kürze:
    Die MIDI-Hardwareschnittstelle (zum Keyboard und zurück) hat mit einer evtl. (General-)Midi Tonerzeugung (ob Hard- oder Software) erstmal nix zu tun.
    Die meisten Soundkarten (auch onboard) haben einen GM-Synth (der heisst dann irgendwas mit "Midi-Tonerzeugung" oder "Wavetable-Device" o.ä.). Da geht es aber nur darum, bereits im Rechner befindliche Mididaten im Rechner zum Klingen zu bringen.
    Für die Datenübertragung von und nach extern ist ausschließlich der MPU-Chip (oder in seltenen Fällen der 330er) zuständig. Der muss (so vorhanden, aber das scheint hier der Fall zu sein) aktiviert sein und in allen betreffenden Anwendungen als Port ausgewählt sein. Nur so geht's.
    Die Verwirrung fängt meistens bei Soundkarten an, die zwar einen GM-Synth haben, aber keinen MPU-Chip. Da taucht dann in der Hardwaresteuerung was von "midi" auf, und jeder denkt, es kann losgehen. Bei den üblichen Onboard-Chipsätzen ist aber der MPU nicht dabei.
    Da hier von "Creative Soundblaster" die Rede war und der MPU in der Hardwaresteuerung auftaucht, dürfen wir allerdings annehmen, dass der Chip auch da ist.

    Das "DX C-Media Wave Device" ist unter Garantie nicht der Hardware-Port, sondern ein Synthesizer... (DX=Direct-X != Midi - ausserdem spricht das "wave" im Namen eine deutliche Sprache)...

    Der doppelte Stecker ist dazu da, um parallel auch einen Joystick anschließen zu könenn, ohne dauernd umstecken zu müssen. Das sollte man aber lassen, denn das führt bei vielen Joysticks zu Datenproblemen.
    Die Midi-Stecker zu vertauschen, führt dagegen nicht zu Problemen - anders als bei Audioverbindungen ist es hier mal egal, wenn "Ausgänge gegeneinanderarbeiten". Das ist IMHO schon Pinbelegungsmäßig halbwegs getrennt, und selbst wenn nicht, dann sind hier TTL-Pegel involviert, die das ganz gut verkraften, wenn sie mal Out on Out liegen. Also keine Angst.

    Jens
     
  20. seal

    seal Threadersteller Registrierter Benutzer

    Im Board seit:
    07.08.04
    Zuletzt hier:
    9.03.11
    Beiträge:
    46
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 08.08.04   #20
    Gut,werd nochmal rumprobieren...muss erstmal die Kanäle rausfinden...morgen. Meld mich...

    Danke erstmal!! :o
     
Die Seite wird geladen...

mapping