Midi-Gerät wird nicht im Musikprogramm angezeigt. Was tun?

von bhschwede, 17.10.11.

  1. bhschwede

    bhschwede Registrierter Benutzer

    Im Board seit:
    17.10.11
    Beiträge:
    6
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 17.10.11   #1
    Hallo, ich komm einfach nicht dahinter woran es liegt. Ich habe schon gesucht und es gibt massenhaft Internetuser die das selbe Problem schildern, aber nie habe ich eine sinnvolle Antwort gefunden, oder die Antwort war viel zu kompliziert oder hat in meinem Fall nichts genützt. Deshalb habe ich beschloßen mich in diesem Musiker-Forum anzumelden und hoffe ihr könnt mir helfen. Folgendes Problem:
    Ich habe ein Keyboard [ YAMAHA YPT-210 ] über ein Midi-Kabel [ http://www.amazon.de/LOGILINK-USB-M...I3CC/ref=sr_1_1?ie=UTF8&qid=1318875041&sr=8-1 ] an mein Laptop [ Lenovo ] angeschlossen. Ich benutze das Musik-programm:
    "Sony acid music studio 7.0". Wenn ich da jetzt auf "Insert Soft Synth" klicke wird mir nur das virtuelle Keyboard des Programms angezeigt aber nicht mein YAMAHA-Keyboard. Ich habe schon vieles versucht, aber nichts hat geklappt. Ich hoffe irgendjemand hier weiß vielleicht woran es liegen könnte.
    Das kann doch eigentlich nicht so schwer sein :confused:

    LG bhschwede
     
  2. microbug

    microbug Helpful & Friendly User

    Im Board seit:
    19.05.11
    Beiträge:
    2.519
    Zustimmungen:
    429
    Kekse:
    5.238
    Erstellt: 18.10.11   #2
    Erstmal willkommen hier.

    So kann das nicht funktionieren.

    Warum willst Du etwas falsches hinzufügen? ein Softsynth ist ein Software-Instrument, Du aber willst ein echtes Instrument, also Hardware, behandeln.

    Ein über MIDI angeschlossenes Gerät wird in keinem Programm einfach so angezeigt, sondern nur der Anschluß, an dem es hängt, in diesem Falle Dein MIDI-Interface, welches Du als "Kabel" bezeichnest. Wird es in Windows (Gerätemanager) angezeigt? Hast Du zu Deiner Software kein Handbuch? Dir fehlen vor allem Grundlagen über das, was Du da vorhast, zB was MIDI ist, da gibts Tutorials im Netz. Das wird auch der Grund sein, warum Dir die Antworten im Netz zu kompliziert waren.

    Dein "MIDI-Kabel" ist wahrscheinlich die nächste Problemquelle, weil ein absolutes Billigding von einem Hersteller, der Computerzubehör baut, mit Musik und MIDI aber sonst nichts zu tun hat. Für die ersten Schritte mag das angehen, aber ich fürchte, Du wirst nicht umhinkommen, Dir was anständiges zuzulegen.

    Ich kenne das verwendete Programm nicht, aber generell ist es so, daß wenn Du vom Keyboard was in die Software spielen willst, mußt Du eine Spur erzeugen und auf dieser sowohl die MIDI-Schnittstelle (also hier das Logilink) und den Kanal einstellen, auf dem das Keyboard sendet. Sollte aber auch in der Anleitung zum Programm stehen, es lohnt sich, diese zu lesen.

    Damit hast Du aber nur die Steuersignale verbunden und kein Audio.

    Schwer ist das nicht, aber ohne Grundlagenwissen geht rein garnichts. Daher: Handbuch lesen (Software, Keyboard), MIDI-Tutorials im Netz, Recording-Tutorials hier im Forum. Fehlende Grundlagen sind keine Schande, die kann man sich ja aneignen, aber einfach so planlos drauflosrumprobieren wird selten zum gewünschten Ergebnis führen.
     
  3. bhschwede

    bhschwede Registrierter Benutzer

    Im Board seit:
    17.10.11
    Beiträge:
    6
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 18.10.11   #3
    Okay, ich habe mir nun ein paar Tutorials angesehen und mir einiges auf der Internetseite von YAMAHA durchgelesen.
    Jetzt habe ich folgendes Problem:
    Im Geräte-Manager wird mein Keyboard unter folgendem Namen angegeben: "Nicht unterstützter Gameport für YAMAHA"
    Dann habe ich mal unter Treiberdetails nachgesehen und dort stand: "Es sind keine Treiberdateien für diesen Dienst erforderlich oder es wurden keine Treiberdateien geladen."
    Aber wenn ich jetzt auf "Treiber aktualisieren" dann steht da der Treiber ist auf dem neusten Stand. Wenn der Treiber nun wirklich nicht vorhanden ist, wie komm ich dann an den? Ich habe für das Keyboard keine Cd oder ähnliches.
     
  4. dkdoemk43

    dkdoemk43 Registrierter Benutzer

    Im Board seit:
    03.10.11
    Beiträge:
    135
    Zustimmungen:
    4
    Kekse:
    10
    Erstellt: 18.10.11   #4
    Falls du das Ding über einen standard-Midi-USB Adapter laufen lässt, solltest du für das Keyboard i.d.R. keine Treiber benötigen. Das ist ja das tolle an Midi: Es ist alles genormt, also keine Treiber. Für das Interface benötigst du aber schon einen, wenn du dein Keyboard aber benutzen kannst, dann sollte der aber schon installiert sein.
    "Gameport" steht im Normalfall für den Midianschluss in der Soundkarte, der normalerweise auch als Anschluss für Gamecontroller verwendet wird. Insofern stelle ich die Vermutung waage einmal auf, dass das der Treiber des Interfaces das Interface als "Virtuellen Midianschluss" darstellt. Bei meinem Keyboard ist es zumindest so, dass ich es über USB an den PC anstecke und mit dem Treiber läuft das ganze selbst mit 18 Jahren alten Midiprogrammen.

    Installiere vielleicht mal den Treiber des Interfaces neu.
     
  5. microbug

    microbug Helpful & Friendly User

    Im Board seit:
    19.05.11
    Beiträge:
    2.519
    Zustimmungen:
    429
    Kekse:
    5.238
    Erstellt: 18.10.11   #5
    Ich versuchs nochmal, und jetzt bitte richtig lesen: Dein Keyboard wird da nicht angezeigt werden, da es über MIDI und nicht über USB angeschlossen wird. Was angezeigt wird, ist Dein MIDI-Interface von Logilink. Offenbar braucht das keine Treiber. Was der "nicht unterstützte Gameport für Yamaha" sein soll, weiß ich nicht, da ich Deinen Rechner nicht kenne. Das Interface müßte sich als USB-Audiogerät oder ähnliches anmelden. In den Rezensionen bei Amazon wird empfohlen, den ASIO4all-Treiber zu installieren. Würde ich mal machen.
     
  6. Böhmorgler

    Böhmorgler Gesperrter Benutzer

    Im Board seit:
    31.03.06
    Beiträge:
    3.727
    Zustimmungen:
    80
    Kekse:
    5.928
    Erstellt: 20.10.11   #6
    Ich habe just gestern das gleiche Kabel gekauft. (Unter Linux hatte ich zwar einen kleinen Kampf, bis es lief, aber das Problem lag an meinem Rechner. An einem anderen Linuxrechner lief es sofort problemlos.)
    Ich habe mich bewußt für so ein Billigteil entschieden, da ich es nur zum Testen von Programmen u.ä. gebrauchen will. Ob es für einen ernsthaften Einsatz auch ausreichend wäre, weiß ich nicht.

    Bezüglich des Treibers (für Windows) steht auf der Verpackung:
    Unter Windows müßte es also direkt nach dem Einstecken funktionieren.
     

Diese Seite empfehlen