[Workshop] DIY WiFi ArtNetNode


chris_kah
chris_kah
HCA PA- und E-Technik
HCA
Zuletzt hier
28.06.22
Registriert
18.06.07
Beiträge
6.785
Kekse
83.574
Ort
Tübingen
Hallo zusammen,
da ich das heute recht zügig zum Laufen gebracht habe, hier eine kleine Bastelanleitung.

Ich habe einen WLAN Art Net Node mit dem ESP32 Modul erstellt.

Das Prozessorboard ist das hier: https://www.conrad.de/de/p/joy-it-entwickler-platine-node-mcu-esp32-modul-1656367.html (gibt es auch von anderen Lieferanten)

Programmiert wird das über die Arduino Entwicklungsumgebung. Eine schöne Anleitung zum Setup gibt es hier. Wichtig: alle Schritte beachten.

Das Board habe ich auf einer Lochrasterplatine per Steckleiste aufgelötet:
IMG_20220310_144859.jpg
IMG_20220310_144939.jpg

Auf der Rückseite befindet sich ein Max485 der etwas unter der schwarzen Masseverbindung verschwindet. Versorgt wir er aus dem VIN Pin, der die 5V vom USB weiter gibt. Auf der anderen Seite ist zwischen Pin 5 und 8 ein 100nF Kondensator zum Blocken der Versorgungsspannung (VCC an Pin 8 und GND an Pin 5).
Angeschlossen ist der Pin D4 für Enable (Pins 2 und 3 des MAX485) und TX2 an DOUT (Pin 4 am MAX485)

Verwendet habe ich diese Vorlage aus Github. Und daraus das Projekt: ArtnetnodeWifiSendDmx.ino

Das funktioniert fast ganz gut. Allerdings muss man Serial.begin() und Serial.write() bei meiner Belegung auf Serial2.begin() und Serial2.write() bei allen DMX Ausgaben umbenennen, die Debug Ausgabe bleibt unverändert.
Dann hat Serial2.begin() die unschöne Eigenschaft, ein kurzes "Low" Signal zu erzeugen, wo es auf "High" bleiben sollte.
Da kam D4 und Enable des Max485 ins Spiel und eine Sichere Terminierung, die bei offenem Ausgang des MAX485 einen gültigen High Pegel erzeugt (Terminierung mib BIAs im 2. Bild).
Offensichtlich gibt es immer einen Reset bei Serial2.Begin() weswegen ich da die Ausgabe über Data Pin 4 abschalte und danach wieder ein.

Die Programmdatei mit allen Änderungen habe ich angehängt. Sie basiert aber weitgehend auf dem verlinkten Beispiel. Sie muss von .txt auf .ino umbenannt werden.
Außerdem müssen SSID und Passwort auf die eigenen des Netzwerks umeditiert werden.

Es funktioniert prinzipiell.

Die Updaterate ist mir etwas zu langsam, 3-4 mal pro Sekunde, wodurch fließende Übergänge ruckeln. Ohne regelmäßige Updates gehen die Lichter wieder aus.
Da ist der Radig ArtNetNode per LAN besser. da geht es fließender und ohne neue Signal wird das letzte Pattern zyklisch ausgegeben bis das nächste neue kommt.

Hier zeigt sich der Nachtiel der ARDUINO Umgebung. Es geht mal schnell etwas Quick & Dirty, aber wenn man in den Feinheiten etwas ändern will, ist es unmöglcih bzw unendlich mühsam.

Für statische Beleuchtung, die weit verstreut mobil verteilt ist, sicher interessant, für dynamische Wechsel etwas zu träge.

Ich hoffe das ist genügend Anleitung zum Nachbau.
 
Eigenschaft
 

Anhänge

  • ArtnetnodeWifiSendDmx.txt
    2,3 KB · Aufrufe: 35
  • Gefällt mir
Reaktionen: 3 Benutzer
SB
SB
Licht | Ton | Strom
Moderator
HFU
Zuletzt hier
28.06.22
Registriert
04.04.07
Beiträge
3.958
Kekse
29.238
Ort
Bavarian Outback (AÖ)
Ich könnt mich ja jetzt schon wieder in den Allerwertesten beißen. Vor Jahren hab ich mal was vergleichbares basierend auf dem NodeMCU entwickelt, das ArtNet und sACN frisst und DMX ausgibt. Als das endlich lief, ist mir genau das passiert, weswegen ich sonst die Kollegen immer ein wenig aufgezogen habe: Ich hab prompt den Sourcecode verschmissen...vielleicht vor lauter 1000 Fenstern den letzten Stand nicht gespeichert als es dann eeeeendlich lief, ich weiß es nicht. Jedenfalls finde ich das Projekt nicht mehr.

"Daten rein" war eigentlich überhaupt kein Problem, die ganzen Channels kommen ja in definierten Bytes daher und den ganzen Overhead wie die Auswertung von E1.31 Root Layer etc. hab ich bis auf rudimentärste Überprüfungen einfach weggelassen, reicht ja für die Anwendung. Da hab ich also ohne Bibliotheken gearbeitet. Woran es wirklich gescheitert ist, war erstmal das raussuchen einer vernünftigen DMX-Out-Lib die auf dem ESP läuft und dann war noch irgendwas mit der seriellen Schnittstelle. Ich glaub mit dem UART 0 lief es nicht und ich musste auf einen anderen gehen, irgendwas war...hab damals fast alles in die Ecke geschmissen, bis ich das dann durch Zufall rausgefunden habe.

Wenn ich die Tage mal dazu komm, setz ich mich da nochmal dran und bau das wohl oder übel nochmal "from scratch". Den funktionierenden will ich eigentlich nicht zerlegen, aber einen zweiten NodeMCU + Hühnerfutter müsst ich eigentlich noch in der Wühlkiste haben.

Bei mir war es eher so, dass das Ganze gerne mal die Verbindung zum Handy verloren hat (bzw. umgekehrt) und ich nicht wusste warum...aber wenn es ging war auch die Refreshrate kein Problem, der hat flüssig gefühlt >30Hz ausgegeben (mittlerweile hätte ich ne DMXcat zur Verfügung und könnte das sogar mal messen).
 

Neue Themen

Unser weiteres Online-Angebot:
Bassic.de · Deejayforum.de · Sequencer.de · Clavio.de · Guitarworld.de · Recording.de

Musiker-Board Logo
Oben