Logic: Komisches Verhalten bei Meta Event 52 oder Songende

von since1984, 08.06.16.

  1. since1984

    since1984 Registrierter Benutzer

    Im Board seit:
    02.02.14
    Zuletzt hier:
    22.08.16
    Beiträge:
    47
    Zustimmungen:
    3
    Kekse:
    20
    Erstellt: 08.06.16   #1
    Hallo Allerseits,

    ich hatte mir das "on stage" so schön ausgemalt: Ein Song läuft aus Logic Pro X heraus, und auf einer zusätzlichen Steuerspur (externes MIDI) sagt Logic meinem TC Helicon VoiceLive 3 Extreme, was es zu tun und zu lassen hat.

    Das funktioniert auch insgesamt ganz prima, nur eine Sache nicht, und die wäre soooo wichtig ... ;-)

    Bei Songbeginn rufe ich in Logic mit einem MIDI Event in meinem VL3X innerhalb eines Presets der Step 1 ( = optimiert für Gesang ) auf. Funktioniert prima. Am Ende des Songs schalte ich per MIDI Event auf Step 2 ( = optimiert für Sprache / Ansage ) um. Funktioniert auch prima ... bis (Trommelwirbel) ich entweder das META Event 52 (Wiedergabe stoppen) sende oder in Logic diese schwarze Todeszone erreicht habe, wo der Song dann auch ohne "52" stoppt.

    In beiden Fällen schaltet mein VL3X ohne irgend ein Event wieder zurück auf Step 1, und das ist das letzte, was ich in diesem Moment will!!! *verzweifelt*

    Apple schreibt dazu im Logic Manual: "Meta-Regler erzeugen spezielle Meta-Events, die zur Steuerung von bestimmten Logic Pro-Funktionen dienen, jedoch keine MIDI-Bedeutung haben und niemals auf einen MIDI-Ausgang geleitet werden."

    VERY VERY STRANGE - jedenfalls für mich. Hat irgendjemand eine Idee oder sogar eine Lösung?

    Viiiiiielen Dank im Voraus
    since1984
     
  2. since1984

    since1984 Threadersteller Registrierter Benutzer

    Im Board seit:
    02.02.14
    Zuletzt hier:
    22.08.16
    Beiträge:
    47
    Zustimmungen:
    3
    Kekse:
    20
    Erstellt: 09.06.16   #2
    Hallo Allerseits,

    Entwarnung - das Problem wurde in einem anderen(!) Forum gelöst ... :D

    Logic ist manchmal auch ZU intelligent: Es macht sich Gedanken, ob es nicht unaufgefordert zusätzliche Events schicken muss, um einen "konsistenten" Zustand zu erhalten oder wieder herzustellen. Diese an sich löbliche Bemühung war hier von Übel. ;)
    Die Lösung: Unter Projekteinstellungen auf MIDI und Folgen gehen, dann das Häkchen bei Programmwechsel rausnehmen - schon hat's funktioniert! :great::great::great:

    Dank an Etienne aus der schönen Schweiz
    since1984
     
    gefällt mir nicht mehr 1 Person(en) gefällt das
Die Seite wird geladen...

mapping