Serato DJ Midi XML Mapping

von Ezio95, 02.01.16.

  1. Ezio95

    Ezio95 Registrierter Benutzer

    Im Board seit:
    18.03.15
    Zuletzt hier:
    17.11.16
    Beiträge:
    19
    Zustimmungen:
    2
    Kekse:
    0
    Erstellt: 02.01.16   #1
    Hallo an alle!

    Ich stehe momentan am rande der Verzweiflung, ich bin aktuell dabei für meine zwei Gemini CDJ-700 ein Midi Mapping für Serato DJ (1.8.1) zu erstellen.
    Das Problem ist, dass ich es nicht schaffe das Deck 1 und 2 funktionieren, es geht immer nur eins.

    Code:
    <midi app=" 1.8.1.8994">
        <control channel="1" event_type="Control Change" data_type="Relative Binary Offset" control="32">
            <userio event="click">
                <platter_move deck_set="Default" deck_id="1" slot_id="0">
                    <translation action_on="any"/>
                </platter_move>
            </userio>
        </control>
        <control channel="1" event_type="Note On" control="24">
            <userio event="click">
                <platter_touch deck_set="Default" deck_id="1" slot_id="0">
                    <translation action_on="any" behaviour="explicit"/>
                </platter_touch>
            </userio>
        </control>
        <control channel="1" event_type="Note On" control="2">
            <userio event="click">
                <play deck_set="Default" deck_id="0" slot_id="0">
                    <translation action_on="press" behaviour="toggle"/>
                </play>
            </userio>
            <userio event="output">
                <play deck_set="Default" deck_id="0" slot_id="0">
                    <translation action_on="any">
                        <alias name="on" value="127"/>
                        <alias name="off" value="0"/>
                    </translation>
                </play>
            </userio>
        </control>
        <control channel="1" event_type="Control Change" data_type="Relative Binary Offset" control="32">
            <userio event="click">
                <platter_move deck_set="Default" deck_id="1" slot_id="0">
                    <translation action_on="any"/>
                </platter_move>
            </userio>
        </control>
        <control channel="1" event_type="Note On" control="24">
            <userio event="click">
                <platter_touch deck_set="Default" deck_id="1" slot_id="0">
                    <translation action_on="any" behaviour="explicit"/>
                </platter_touch>
            </userio>
        </control>
        <control channel="1" event_type="Note On" control="2">
            <userio event="click">
                <play deck_set="Default" deck_id="1" slot_id="0">
                    <translation action_on="press" behaviour="toggle"/>
                </play>
            </userio>
            <userio event="output">
                <play deck_set="Default" deck_id="1" slot_id="0">
                    <translation action_on="any">
                        <alias name="on" value="127"/>
                        <alias name="off" value="0"/>
                    </translation>
                </play>
            </userio>
        </control>
    </midi>
    
    So sieht das ganze momentan aus, wie oben bereits gesagt habe funktioniert immer nur deck 1 oder 2, es lässt sich also Deck 1 mit CDJ 1 & 2 steueren oder Deck 2 mit CDJ 1 & 2.
    Ich finde den Fehler nicht um hoffe das mir jemand helfen kann :)
     
  2. Elektro Borg

    Elektro Borg Registrierter Benutzer

    Im Board seit:
    18.07.13
    Zuletzt hier:
    11.05.16
    Beiträge:
    244
    Ort:
    Dresden
    Zustimmungen:
    236
    Kekse:
    643
    Erstellt: 13.01.16   #2
  3. Ezio95

    Ezio95 Threadersteller Registrierter Benutzer

    Im Board seit:
    18.03.15
    Zuletzt hier:
    17.11.16
    Beiträge:
    19
    Zustimmungen:
    2
    Kekse:
    0
    Erstellt: 13.01.16   #3
    Danke für die Antwort!

    Das Problem hat sich schon erledigt, lag am Midi Kanal ... Da beide auf Kanal 1 laufen musste ich das mit einem Virtuellen Midi Controller machen, läuft (bis auf die beleuchtung) wunderbar :)

    Mfg
     
  4. Elektro Borg

    Elektro Borg Registrierter Benutzer

    Im Board seit:
    18.07.13
    Zuletzt hier:
    11.05.16
    Beiträge:
    244
    Ort:
    Dresden
    Zustimmungen:
    236
    Kekse:
    643
    Erstellt: 14.01.16   #4
    Dann stelle doch das XML im Web zur Verfügung. Lt. Suche gibt es ja einige, die mit der Kombination Ihre Probleme haben.
     
  5. Ezio95

    Ezio95 Threadersteller Registrierter Benutzer

    Im Board seit:
    18.03.15
    Zuletzt hier:
    17.11.16
    Beiträge:
    19
    Zustimmungen:
    2
    Kekse:
    0
    Erstellt: 20.01.16   #5
    Ja, hatte ich auch schon vor, allerings wollte ich erst noch ein paar "Kinderkrankheiten" fixen und weil ich momentan ziemlich wenig Zeit habe, komme ich einfach nicht dazu :D
     
  6. Elektro Borg

    Elektro Borg Registrierter Benutzer

    Im Board seit:
    18.07.13
    Zuletzt hier:
    11.05.16
    Beiträge:
    244
    Ort:
    Dresden
    Zustimmungen:
    236
    Kekse:
    643
    Erstellt: 20.01.16   #6
    Komm, mach das möglich.
     
Die Seite wird geladen...

mapping