Nach Offline-Pitchen Gitarrendateien unbrauchbar (Samplitude Pro X)

  • Ersteller Drummy274
  • Erstellt am

D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Moin allerseits,

gerade ist ein Problem bei einem Samplitude Pro X-Projekt aufgetaucht, dass mich enorm annervt.

Habe die Gitarren für ein zwanzigminütiges Lied aufgenommen, dummerweise davor aber vergessen zu prüfen, ob die Gitarre sauber einen Ganzton tiefer gestimmt ist. Leider fiel mir beim Einbinden von MIDI-Spuren und den dadurch verbundenen Synthesizern auf, dass die Gitarre ärgerlicherweise marginal von einem sauberen D abwich, genauer gesagt, einen Pitch von 0,09 zu hoch gestimmt war. Da das Lied mit 20 Minuten eben enorm lang ist, habe ich probehalber geschaut, ob ich die Dateien nicht einfach entsprechend runterpitchen könnte. Klang alles in Ordnung, aufgrund der Masse an Spuren im Projekt und Dateien wollte ich jedoch lieber auf den Pitch als Offline-Effekt zurückgreifen, um meine arme CPU etwas zu schonen. Für alle Fälle natürlich vorher ein Backup angelegt, nicht, dass etwas schiefgeht (ha... ha...).

Nach der ein oder anderen Minute des Aktualisierens all der Gitarren-Schnipsel hörte ich rein, glich das Eingespielte mit der jetzt sauber gestimmten Gitarre, den MIDI-Samples usw. ab, alles in Ordnung. Bis auf einmal die Phasen verrückt spielen und tun, was sie wollen. Ich habe jede Gitarrenspur mit zwei Mikros zugleich aufgenommen, sprich jede einzelne Rhythmusgitarren-Aufnahme läuft auf jeweils zwei Spuren, jede Leadgitarren-Aufnahme und so weiter, sprich das jeweilige Signal existiert immer doppelt. Einzeln gehört merkt man den Aufnahmen natürlich nichts an, im Zusammenspiel der gleichen simultanen Aufnahmen spielt jedoch nach ein paar Sekunden alles verrückt, wie man in den hochgeladenen Beispielen erkennen kann. Effekte usw. außer EQ habe ich rausgenommen.

Natürlich wollte ich gleich das Backup aufrufen, dieses wurde großartigerweise aber überschrieben. Sprich mehrere Fälle grober Unachtsam- und Nachlässigkeit haben sich gehäuft und klingen nun so:





(Wollte die Dateien hier hochladen, wurden aber nicht akzeptiert, sorry!)

Was ich seltsam finde ist, dass diese bizarr klingenden Verschiebungen erst nach einem festen Zeitraum stattfinden. Wenn da eine halbe Minute gefüllt ist mit einigen, vor dem Pitch bereits wenige Sekunden kurzen Aufnahmen, läuft alles einwandfrei durch. Sind die Aufnahmen jedoch davor bereits länger gewesen, wird's stumpf gesagt völlig banane. Ich glaube, dass das Problem sicher irgendwie leicht zu beheben wäre, aber ich komme auf keine Lösung. Manuelles Verschieben einzelner Aufnahmen nach der Trennung von der anderen ab dem Moment der akustischen Verschiebungen, sowie zurückpitchen haben natürlich nichts gebracht.

Könnt ihr mir helfen, ohne, dass ich das ganze Lied wieder eintröten muss? Vielen Dank im Voraus für jeden Ratschlag, auch wenn es bloß ein gerechtfertigter Tadel für mein leider enorm nachlässiges Handeln ist.
 
Eigenschaft
 
Vinterland
Vinterland
Registrierter Benutzer
Zuletzt hier
08.04.22
Registriert
06.04.12
Beiträge
4.875
Kekse
17.939
Ort
Köln
Hallo Drummy274

Also mit Offline-Effekten habe ich noch nie gearbeitet, da dies bei meinen Projekten nie nötig ist/war.

Könntest du vielleicht mal genauer beschreiben, wie du vorgegangen bist ?.

Hast du im Kontextmenü „Audiodatei bearbeiten“ ausgewählt wirken Offline- Effekte immer auf alle Objekte, die sich auf das selbe Audiomaterial beziehen.
Willst du das nicht, rufst du vor der Offline-Bearbeitung den Befehl "Kopie der Audio Datei bearbeiten" auf.
Samplitude erstellt dann eine Kopie des Audiomaterials und legt diese dann, soweit ich weiß im gleichen Projektordner ab.
Das Objekt bezieht sich dann auf die erstellte Kopie. Offline-Effekte, kannst du dann auf dieses Objekt anwenden, ohne dass andere Objekte beeinflusst werden.

Das ist alles, was ich darüber weiß. Vielleicht ist ja der ein oder andere Hinweis dabei.
Wie gesagt, ich habe selber noch nie mit Offline-Effekten gearbeitet. Haste mal ins Handbuch reingeschaut ?.
 
D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Moin, danke für die Antwort!

Mir kam leider nicht die Idee mit dem Befehl "Kopie der Audio-Datei bearbeiten"... Gute Idee für die Zukunft. Ich habe so bisher halt auch noch nie wirklich mit Offline-Effekten gearbeitet, da mir immer bange davor war, dass so etwas wie jetzt passieren könnte.
Wie genau ich vorgegangen bin - ich habe alle Objekte ausgewählt, einfach rechtsgeklickt, Offline-Effekte ausgewählt, bin zur Pitch-Funktion gegangen, habe den neuen Pitch auf -0,09 eingestellt, es beim Standard-Algorithmus belassen, den Haken beim HQ-Resampling unten links gesetzt und anschließend die Dateien aktualisieren lassen. BPM-Werte und dergleichen habe ich unangetastet gelassen. Habe jetzt mal mit entsprechenden Wave-Kopien über die "Kopie der Audio-Datei bearbeiten"-Funktion probiert, einen eventuellen DC-Offset zu korrigieren um das zu beheben, hat auch nicht geholfen.
--- Beiträge wurden zusammengefasst ---
Mir ist gerade schon einmal aufgefallen, dass die Länge der Objekte anscheinend auch dennoch minimal verändert wurde, genauer gesagt von 1 auf 0,99481, genauer gesagt um 0,646 BPM angehoben wurde. Das könnte doch vielleicht erklären, wieso das Problem "erst"/schon nach ein paar Sekunden auftritt?
 
D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Mir ist noch etwas aufgefallen, das vielleicht das Problem irgendwie lösen könnte! Ein längeres Leadgitarren-Objekt angewählt und geschaut, welche Datei dafür zuständig ist. Hierbei festgestellt, dass hier doch eine Kopie der ursprünglichen Datei V_07_M24_T1119.wav erstellt wurde, nämlich V_07_M24_T1119_FX.wav. Hier kommt auch hin, was ich bezüglich der BPM-Anhebung schrieb, nämlich dass die Datei insgesamt knapp eine Sekunde kürzer ist. Könnte es Sinn machen, ein neues Projekt zu öffnen, all die ursprünglichen .wav-Dateien in jenes Projekt zu ziehen, an ihre entsprechenden Punkte in der Zeitlinie zu ziehen und einfach die Projekteinstellungen rüberzukopieren?
 
Telefunky
Telefunky
Registrierter Benutzer
Zuletzt hier
19.08.22
Registriert
25.08.11
Beiträge
16.663
Kekse
51.280
was ich bezüglich der BPM-Anhebung schrieb, nämlich dass die Datei insgesamt knapp eine Sekunde kürzer ist
in dem Fall wurde tatsächlich nur die Tonhöhe verändert, was automatisch eine Verkürzung beinhaltet
wenn du den umgekehrten Vorgang auf die verarbeitete Datein anwendest, bekommst du wieder die original-Verhältnisse
imho ausreichend genau, da Gitarrenaufnahmen (üblicherweise) von Haus aus (mindestens) leichte Verzerrung enthalten
danach kannst du mit der neu erzeugten Datei die pitch + bpm Korrektur (=Anpassung auf der Zeitachse) vornehmen

cheers, Tom
 
D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Habe das als zweites probiert, gerade wieder. Mit Erhöhung des Pitches um 0,09 und entsprechender Erhöhung der Zeit um 0,00519 (wurde ja auf 0,99481 abgesenkt zuvor), das Problem bleibt aber vorhanden. Oder meinst du, ich soll erst erneut den Offline-Effekt anwenden um den entsprechenden Pitch, also die Dateien erst an sich abändern?
 
Telefunky
Telefunky
Registrierter Benutzer
Zuletzt hier
19.08.22
Registriert
25.08.11
Beiträge
16.663
Kekse
51.280
ja, ich meinte den gleichen Prozess, der zu der verkürzten Datei geführt hat
nur eben mit anderem Vorzeichen - danach sollte die Datei (durch den 2. offline Prozess) wieder ihre ursprüngliche Länge haben
im nächsten Schritt dann diese Datei korrekt mit Zeit und Pitch korrigieren

cheers, Tom
 
D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Ich versteh' das nicht. Ich strecke die Datei um den angegebenen Zeitraum, dann fällt die allerdings noch mehr aus dem Rahmen. Bei den jetzigen Dateien kommt das Tempo mit Click ja perfekt hin, Tempo ist also anscheinend gleich, obwohl die Dateien minimal kürzer sind. Einfach um 0,09 offline hochpitchen hat nichts gebracht. Auch, wenn ich das bspw. stumpf um 0,18 höherpitche und wieder -0,09 runterrechne, bleibt das Ergebnis gleicher Mist.
Wieso bekomme ich denn die Ursprungsdateien nicht zurück, wenn ich die einfach um 0,09 wieder hochpitche, obwohl ich ursprünglich nichts anderes getan habe, als die um die selbe Höhe herunterzudrehen?
 
Telefunky
Telefunky
Registrierter Benutzer
Zuletzt hier
19.08.22
Registriert
25.08.11
Beiträge
16.663
Kekse
51.280
die Ursprungsdaten bekommst du in keinem Fall zurück, weil die Verarbeitung verlustbehaftet ist
je nach Berechnungsmethode weicht das Ergebnis (effektiv) mehr oder weniger stark ab
(war halt einen Versuch wert ...)

cheers, Tom
 
D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Ach Mist... Dennoch vielen Dank für den Tipp!

Mittlerweile hab' ich mich für den wohl zweitsimpelsten, aber aufwändigen Weg entschieden, einfach die ursprünglichen Dateien (glücklicherweise habe ich anscheinend mal eingestellt, dass bei Offline-Effekten eine FX-Kopie der Datei erstellt wird...) nach Vorlage des Projektes mit den fehlerhaften Objekten in einem neuen Projekt neu zusammenzusetzen und die Projekteinstellungen einfach rüberzukopieren. Sitze zwar nun schon seit gut zwei Stunden dran, bin aber wenigstens mit den Rhythmusgitarren schon so gut wie fertig, deren Zusammensetzen sicher vier Fünftel der Arbeit ausmacht. Vorhin noch mit ein paar Schnipseln herumprobiert, was das Pitchen betrifft...

Habe nun testweise mal eine einminütige Gitarren-Aufnahme exportiert und wieder in das Projekt eingefügt, um die Tonspuren der beiden Mikrofone in einer einzelnen, statt zwei aufgespaltenen Dateien zu haben, und heruntergepitcht. Funktioniert so einwandfrei. Ist zwar auch nicht die feine englische Art, aber solange etwas gut klingt, funktioniert und man damit das angestrebte Ziel erreicht, tut es seinen Zweck, finde ich... Außerdem erspare ich es mir, heute den ganzen lieben langen Tag lang aufzunehmen, hehe. Diesmal werd' ich aber 'nen Teufel tun und das nochmal offline probieren... Danke für alle Antworten bisher!
 
Zelo01
Zelo01
Helpful & Friendly User
HFU
Zuletzt hier
18.08.22
Registriert
13.01.15
Beiträge
2.491
Kekse
11.400
Ich habe jede Gitarrenspur mit zwei Mikros zugleich aufgenommen, sprich jede einzelne Rhythmusgitarren-Aufnahme läuft auf jeweils zwei Spuren,

Versuch mal bevor du pitchst, die beiden Gitarrenspuren in eine Spur zu summieren, und erst danach zu pitchen. Ich kann mir gut vorstellen, dass wenn beide Mikrofone einzeln gepitcht werden, das nicht absolut identisch passiert. Daher die Phasenprobleme.

Wie klingt es denn, wenn du eines der beiden Mikrofone stumm schaltest? Sind dann immer noch Phasenprobleme vorhanden?

Nachtrag:
Sorry, ich hab dein letzten Eintrag nicht genau gelesen, offenbar hast das ja jetzt so gemacht:)
 
Zuletzt bearbeitet:
D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Phasenprobleme bei einer einzelnen Spur gibt es nicht. Daher meinte ich im letzten Beitrag, dass ich die zuvor lieber summiere und anschließend pitchen werde, da dies problemlos funktionierte. Mittlerweile habe ich nun beinahe alle einzelnen .wav-Dateien in einem neuen Projekt zusammengesetzt. Dauert zwar wohl noch 'n Stündchen, dann ist's aber wenigstens wieder wie vorher...
 
Vinterland
Vinterland
Registrierter Benutzer
Zuletzt hier
08.04.22
Registriert
06.04.12
Beiträge
4.875
Kekse
17.939
Ort
Köln
Hallo Drummy274
Mittlerweile habe ich nun beinahe alle einzelnen .wav-Dateien in einem neuen Projekt zusammengesetzt. Dauert zwar wohl noch 'n Stündchen, dann ist's aber wenigstens wieder wie vorher...
Mittlerweile hab' ich mich für den wohl zweitsimpelsten, aber aufwändigen Weg entschieden, einfach die ursprünglichen Dateien (glücklicherweise habe ich anscheinend mal eingestellt, dass bei Offline-Effekten eine FX-Kopie der Datei erstellt wird...) nach Vorlage des Projektes mit den fehlerhaften Objekten in einem neuen Projekt neu zusammenzusetzen und die Projekteinstellungen einfach rüberzukopieren.
Lass dir Zeit damit. Hauptsache es sind Kopien von den wav-Datein vorhanden (zum Glück).
Ist dein PC denn so "Schwach" das dass notwendig ist ?.
Ich meine, mein PC ist auch nicht gerade ein Monster (3 x 3,4 Ghz mit 4 GB Ram) aber Probleme
habe ich bis heute nie gehabt.

Solltest du selber aber wirklich Probleme festgestellt haben, solltest du eventuell mal die ganzen
Tipps zur Audio Optimierung durchgehen.

https://www.musiker-board.de/thread...indows7-windows8-für-recording-zwecke.337359/

http://focusrite.de/answerbase/windows-7-für-die-arbeit-mit-audio-optimieren

http://www.marcoscherer.de/upload/L_PC-Optimierung.pdf

Solltest du mit Win7 arbeiten, lade dir diesen Patch aus meiner Box mal herunter.
Der Hotfix Patch für USB Audiointerfaces, behebt viele Probleme . Den solltest du dir auch installieren.
https://app.box.com/s/gv0rkso6139uy6g9nigdiqlhdeo5c5k2

Dann viel Glück beim wiederherstellen.

PS : Vielen, vielen Dank für die Kekse :great:
 
D
Drummy274
Registrierter Benutzer
Zuletzt hier
03.12.21
Registriert
27.06.08
Beiträge
11
Kekse
167
Habe insgesamt sechs Stunden lang die ganzen verwendeten Dateien aus den knapp 1300 Takes rausgesucht, eingebaut, alles an seine Position gebracht und so weiter, jetzt ist alles wieder im Lot. Einfach die Summe der jeweils zwei Gitarrenspuren pro Aufnahme pitchen, wie es bereits erwähnt wurde, funktioniert so. Mache das nun einfach über Echtzeit-Effekt und lasse die Finger vom ursprünglich verwendeten Weg. Klingt nun alles so, wie es soll.

@Vinterland :
Ich habe auch normalerweise kein Hardware-Problem, bei dem Projekt nun auch nicht, da ich hier keine x Drum-Spuren wie zu Zeiten der Wohnung mit Platz für mein Schlagzeug habe, sondern früher eingespielte Drum-Samples in SuperdrumFX einspeise.
Meine Mühle ist da vielleicht sogar etwas potenter als deine mit 'nem AMD Phenom II X4 955 BE und 8 GB Ram, versuche aber bloß immer, so wenig Belastung wie nötig im Projekt drinne zu haben. Sind oft genug mal fix 20 bis 35 Spuren mit einem Haufen Effekten drauf, dann eventuell noch auf einigen Einzel-Objekten und so weiter, da kommt auch der Arbeitsspeicher manchmal an seine Grenzen nach ein paar Stunden, sodass ich Samplitude schon mal neu starten muss.

An alle: Falls irgendwem für die Zukunft vielleicht ein großartiger Trick bei dem Problem einfiele, kann er ihn ja hier rein schreiben, mittlerweile klingt hier jedenfalls alles nun so, wie es soll:



Danke für alle Ratschläge und Denkanregungen!
 
Vinterland
Vinterland
Registrierter Benutzer
Zuletzt hier
08.04.22
Registriert
06.04.12
Beiträge
4.875
Kekse
17.939
Ort
Köln
jetzt ist alles wieder im Lot.
Na, super, dann kann´s ja weiter gehen :D

Meine Mühle ist da vielleicht sogar etwas potenter als deine mit 'nem AMD Phenom II X4 955 BE und 8 GB Ram,
Das habe ich mir schon gedacht :D.

Sind oft genug mal fix 20 bis 35 Spuren mit einem Haufen Effekten drauf, dann eventuell noch auf einigen Einzel-Objekten und so weiter
Wobei mir meiner vollkommen ausreicht zumal bei mir mal höchstens 20 Spuren zusammenkommen, da ich mich mittlerweile
mehr oder weniger auf Singer/Songwriter spezialisiert habe und da kommen ja eh nie sooo viele Spuren zusammen. Zur Zeit arbeite ich an einem Projekt, das im Moment 14 Spuren beinhaltet.
Effekte werden es bei mir mit Sicherheit auch ne ganze Ecke weniger sein als bei dir. Das einzige, was ich an Effekten (PlugIns) benutze ist Reverb, mal ein Delay, Kompressor, EQ, eventuell
auch mal einen Chorus. Den Reverb lege ich logischerweise sowieso in einem AUX-Bus an und route den dann auf die entsprechenden Kanäle.

da kommt auch der Arbeitsspeicher manchmal an seine Grenzen nach ein paar Stunden, sodass ich Samplitude schon mal neu starten muss.
Naja, dann hast in deinen Projekten ja schon einiges drin :D. Also das meiner in die Knie geht, hab ich bis heute so noch nicht beobachtet.
Es hat auch nicht IMMER was mit der Hardware zu tun. Auch wenn du einen flotten PC hast, wäre es nicht verkehrt, die Audio Optimierungen (Post#13) bei Gelegenheit mal durchzugehen.
 
Elektro Borg
Elektro Borg
Registrierter Benutzer
Zuletzt hier
11.05.16
Registriert
18.07.13
Beiträge
241
Kekse
633
Ort
Dresden
Idee: Freezen, freezen, freezen ;)
 
B
BBenson
Registrierter Benutzer
Zuletzt hier
18.08.22
Registriert
01.04.13
Beiträge
36
Kekse
104
Habe insgesamt sechs Stunden lang die ganzen verwendeten Dateien aus den knapp 1300 Takes rausgesucht, eingebaut, alles an seine Position gebracht und so weiter, jetzt ist alles wieder im Lot. Einfach die Summe der jeweils zwei Gitarrenspuren pro Aufnahme pitchen, wie es bereits erwähnt wurde, funktioniert so. Mache das nun einfach über Echtzeit-Effekt und lasse die Finger vom ursprünglich verwendeten Weg. Klingt nun alles so, wie es soll.

Auch wenn dieser Tipp etwas spät kommt:
Wenn man oflline-Effekte verwendet, kann ich zu mindest bei meiner Samplitude-Version, mittels der rechten Maustaste unter "Takes" die ursprüngliche Version einfach wieder holen. Das sollte immer funktionieren, solange man die Option "Kopie erzeugen" im Oflline-Dialog angewählt hat.
 

Ähnliche Themen


Neue Themen

Unser weiteres Online-Angebot:
Bassic.de · Deejayforum.de · Sequencer.de · Clavio.de · Guitarworld.de · Recording.de

Musiker-Board Logo
Oben