Suche kostengünstige ARTNET media player lösung

von andy8990, 14.04.12.

Sponsored by
QSC
  1. andy8990

    andy8990 Registrierter Benutzer

    Im Board seit:
    29.03.06
    Zuletzt hier:
    16.05.12
    Beiträge:
    13
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 14.04.12   #1
    Hi!

    Suche wie im thema schon geschrieben, eine MEdia Player Software lösung, die über ARTNET steuerbar ist.

    weis da wer was für mich?

    cheers, andy
     
  2. Hell_Dunkel

    Hell_Dunkel HCA Lichttechnik HCA

    Im Board seit:
    24.02.10
    Zuletzt hier:
    23.06.18
    Beiträge:
    300
    Ort:
    München
    Zustimmungen:
    119
    Kekse:
    5.462
    Erstellt: 14.04.12   #2
    Hi,
    eine ganz simple (aber funktionierende Lösung):

    Mit dem chamsys MediaCenter kann man Winamp ansteuern. Einfach auf dem Winamp Rechner Chamsys installieren und den Rechner ins Artnet Netzwerk einbinden. Ich betreibe das so z.B. um bei Einspielern Musik und Licht synchron zu starten.

    Edit: Die Lösung ist kostenlos, aber natürlich nicht mit dem Funktionsumfang komerzieller Lösungen vergleichbar...

    Edit2: Das ganze wird folgendermaßen angesprochen:

    ch1: Volume (0 aus - 255 volle Lautstärke)
    ch2: Pan (0 links - 255 rechts)
    ch3: Control (0-15 stop, 16-31 pause, 32-47 play, 48-63 continue)
    ch4: Position (fine)
    ch5: Position (coarse)
    ch6: Track (in der Winamp Playlist)

    Leider weiß ich nicht, was du damit vor hast. Daher nur mal aus dem Bauch heraus dieser Ansatz. Keine Ahnung, ob du damit den Ansprüchen deines Einsatzgebiets gerecht werden kannst.
     
    gefällt mir nicht mehr 2 Person(en) gefällt das
  3. andy8990

    andy8990 Threadersteller Registrierter Benutzer

    Im Board seit:
    29.03.06
    Zuletzt hier:
    16.05.12
    Beiträge:
    13
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 16.04.12   #3
    das ganze sollte einfach auf einer bühne (1 leinwand, 1 Beamer, keine livebilder) eingesetzt werden. Content sind bilder und videos
     
  4. Hell_Dunkel

    Hell_Dunkel HCA Lichttechnik HCA

    Im Board seit:
    24.02.10
    Zuletzt hier:
    23.06.18
    Beiträge:
    300
    Ort:
    München
    Zustimmungen:
    119
    Kekse:
    5.462
    Erstellt: 16.04.12   #4
    Dann sollte sich das ausgehen.

    Ich würde das folgendermaßen lösen (wenn es kostenlos sein soll).

    Ausgangsmaterial:
    Videos: Als Video verwenden
    Bilder: Mit einem beliebigen Videobearbeitungsprogramm als Video "konvertieren"
    Außerdem brauchst du ein "Video", das nur einen schwarzen Bildschirm darstellt.

    Vorgehensweise:
    Alle Videos in Winamp einsortieren und zur Sicherheit als Playlist speichern.
    MagicQ MediaCenter und Winamp konfigurieren. Winamp sollte im Vollbild laufen. Als Ausgangsvideo das mit dem schwarzen Bildschirm wählen.

    Die Videos in Winamp einfach mit dem MagicQ MediaCenter über Artnet ansprechen und zwischen den Videoeinspielungen einfach das Video mit dem schwarzen Bild abspielen.


    Ich habe das so noch nicht probiert und weiß auch nicht, wie sich Winamp im Fullscreen beim Videowechsel verhält. Aber einen Versuch wäre das auf jeden Fall mal wert.



    Komerzielle Lösung: Jeder x-beliebige Mediaserver...

    Gruß
    Martin
     
    gefällt mir nicht mehr 2 Person(en) gefällt das
  5. andy8990

    andy8990 Threadersteller Registrierter Benutzer

    Im Board seit:
    29.03.06
    Zuletzt hier:
    16.05.12
    Beiträge:
    13
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 16.04.12   #5
    danke für die tips.

    problem habe ich nur, dass das media centre meinen winamp nicht findet.
     
  6. Hell_Dunkel

    Hell_Dunkel HCA Lichttechnik HCA

    Im Board seit:
    24.02.10
    Zuletzt hier:
    23.06.18
    Beiträge:
    300
    Ort:
    München
    Zustimmungen:
    119
    Kekse:
    5.462
    Erstellt: 16.04.12   #6
    Ok, das könnte daran liegen, dass das mediaCenter unter C:\Program Files\Winamp sucht und du vermutlich Winamp unter C:\Program Files (x86)\Winamp installiert hast. Ich habe das damals so gelöst, dass ich eine Verknüpfung auf Winamp in den entsprechenden Ordner gelegt habe und alle benötigten Files auch dorthin kopiert habe. Effektiv habe ich jetzt unter beiden Ordnern den gleichen Inhalt.
     
    gefällt mir nicht mehr 2 Person(en) gefällt das
  7. andy8990

    andy8990 Threadersteller Registrierter Benutzer

    Im Board seit:
    29.03.06
    Zuletzt hier:
    16.05.12
    Beiträge:
    13
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 16.04.12   #7
    danke, genau das wars :-)

    jetzt hab ich nur noch eine frage. wie muss ich das netzwerk configurieren?

    Komponenten sind:

    grandMA ultralight IP 10.0.0.27
    laptop IP 10.0.0.1

    netzwerk steht, und kommuniziert. getestet mit onPC und 3D

    aber irgendwie läuft das ding so nicht.
     
  8. Hell_Dunkel

    Hell_Dunkel HCA Lichttechnik HCA

    Im Board seit:
    24.02.10
    Zuletzt hier:
    23.06.18
    Beiträge:
    300
    Ort:
    München
    Zustimmungen:
    119
    Kekse:
    5.462
    Erstellt: 16.04.12   #8
    Im MediaCenter folgendes:

    Devices - Winamp Control- Häckchen bei Instance 1 und Artnet Universe mit Startadresse eingeben. Rechts müsste dann stehen: Enabled. Winamp found.

    Bei mir ist das Pult (Chamsys) über einen Router mit dem Winamp Rechner (auf dem auch bei mir zeitgleich GrandMA OnPC im Verbund mit 3D zur Visualisierung läuft) verbunden. Dieser Rechner hat eine via DHCP vom Router vergebene IP. Ich habe da ehrlich gesagt an den Adressen noch nie was ändern müssen.

    (Hat mich übrigens auch gewundert, da Artnet ja eigentlich auf 2.??? und 10.??? spezifiziert ist, soweit ich weiß.)

    Sorry, dass ich dir da gerade nicht weiterhelfen kann.
     
  9. andy8990

    andy8990 Threadersteller Registrierter Benutzer

    Im Board seit:
    29.03.06
    Zuletzt hier:
    16.05.12
    Beiträge:
    13
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 16.04.12   #9
    trotzdem danke einstweilen für die hilfe. mal schauen, ob ich das irgendwie zum laufen bringe
     
  10. Hell_Dunkel

    Hell_Dunkel HCA Lichttechnik HCA

    Im Board seit:
    24.02.10
    Zuletzt hier:
    23.06.18
    Beiträge:
    300
    Ort:
    München
    Zustimmungen:
    119
    Kekse:
    5.462
    Erstellt: 16.04.12   #10
    Vielleicht kannst du uns dann kurz Rückmeldung geben, ob und wie du es zum laufen gebracht hast.

    Weitere Hilfe könntest du im Chamsys.de Forum finden. Da sind einige Leute recht fit in Sachen Netzwerk/Artnet.
     
  11. andy8990

    andy8990 Threadersteller Registrierter Benutzer

    Im Board seit:
    29.03.06
    Zuletzt hier:
    16.05.12
    Beiträge:
    13
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 17.04.12   #11
    Also der fehler und die lösung sind so blöd wie einfach, dass ich mir das da eigentlich gar nicht schreiben traue :-)

    grandMA ändert, egal welche IP dem pult gegeben wird, die ARTNET adresse um. also:

    pultIP 192.168.0.1 wird umgewandelt in ARTNET IP 2.168.0.1

    deswegen hats nicht gefunzt.
     
  12. Hell_Dunkel

    Hell_Dunkel HCA Lichttechnik HCA

    Im Board seit:
    24.02.10
    Zuletzt hier:
    23.06.18
    Beiträge:
    300
    Ort:
    München
    Zustimmungen:
    119
    Kekse:
    5.462
    Erstellt: 17.04.12   #12
    Schön, dass es jetzt geht.

    Persönliches Interesse: Funktioniert das mit Winamp und den Videos so wie ich mir das überlegt habe?
     
  13. andy8990

    andy8990 Threadersteller Registrierter Benutzer

    Im Board seit:
    29.03.06
    Zuletzt hier:
    16.05.12
    Beiträge:
    13
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 17.04.12   #13
    Ja, das geht grundsätzlich!

    Ich vermisse nur eine Art Fade bei den Videos, damit das Ganze nicht immer so aprupt passiert. Aber das geht schon so.
     
  14. Hell_Dunkel

    Hell_Dunkel HCA Lichttechnik HCA

    Im Board seit:
    24.02.10
    Zuletzt hier:
    23.06.18
    Beiträge:
    300
    Ort:
    München
    Zustimmungen:
    119
    Kekse:
    5.462
    Erstellt: 17.04.12   #14
    Das ist natürlich nicht schön. Winamp kann wohl nur Audio ein/ausblenden.

    2 Ideen:
    * ggf. gibt es ein Winamp Plugin für den Zweck. (glaube ich nicht)
    * Bei allen Videos eine FadeIn/FadeOut Sequenz hinzufügen. Leider habe ich keine Ahnung vom Videoschnitt. In der Bildbearbeitung lassen sich solche simplen Operationen aber automatisieren und z.B. auf alle Dateien in einem Ordner anwenden. Falls das nicht geht, wird das wohl sehr arbeitsintensiv.


    (3.Idee: den Winamp Ansatz verwerfen und eine Alternative suchen. "Gehen Sie zurück ins Gefängnis, gehen Sie dabei nicht über Los" ;) )
    Dazu vielleicht auch mal dieses Thema durchlesen: http://www.paforum.de/phpBB/viewtopic.php?f=3&t=76117
    Der Ansatz mit vvvv (http://www.vvvv.org) erscheint mir auch für dich interessant. Allerdings dürfte da aus dem Gefühl heraus einiges an Einarbeitung nötig sein. (Ich kenne die Software allerdings nicht)
     
    gefällt mir nicht mehr 2 Person(en) gefällt das
Die Seite wird geladen...

mapping