VST "kann nicht geladen werden"

  • Ersteller Chriss_Guitar
  • Erstellt am
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
Vielleicht hat jmd von euch eine Antwort auf mein Problem, dass sich wie folgt darstellt:
Ich besitze etliche VST's unter anderem Guitar Rig 3, ez-drummer (drummkit from hell), philharmonika, die ich mir alle gekauft habe oder hab schenken lassen... seit Mitte letzten Monats auch NI Akoustik Piano. Ich habe es ganz normal installiert und die VST-Datei auch in meinen VST-Ordner kopiert (so wie bei allen anderen Sachen auch).

Bin ich in Reaper, und gehe auf "New instrument or track" und wähle dann Akoustik Piano aus, dann kann ich über mein Keyboard( mittels midi an meiner m-audio 24/96) wunderbar eben das vst steuern und auch aufnehmen.
Bin ich aber in Cubase SX3 - welches ich eig. hauptsächlich benutze - kann ich das plugin dort nicht benutzen. Habe daraufhin mal in der Plugin-liste nach geschaut und gesehen, dass Cubase dort schrieb, dass es NI akoustik piano nicht laden kann. Auch in der Effektliste, welche ich auswählen kann, wenn ich die Effekte in einer Spur auswählen möchte, erscheint mir NI Akoustik Piano nur - und das ist das noch komischere - unter den DirectX-Effekten.
das wäre das Erste.

Zum zweiten: Über dieses Keyboard möchte ich ja auch gern in Cubase meine Midi-sachen einspielen(Hab im Moment nichts besseres und für mich recht es momentan noch...ein richtiges MIDI-Keyboard wird aber demnächst angeschafft ;) )

Komischerweise habe ich im Transport-manager zwar einen Ausschlag sobald ich eine Taste auf dem Keyboard drücke, kann aber weder ein vst oder sonst was drauf legen.
Erst, wenn ich in einer Audiospur z. B. EZ-Drummer eingestellt habe, eine Midispur erstellt und dort unter Routing die audiospur auswähle, kann ich auf mein vst zugreifen.
Ich weiß jetzt nicht, ob das bei SX3 normal ist...ein bekannter jedoch hat Cubase 4 und das funktioniert in der Hinsicht problemlos.
vll. weiß ja einer von euch mehr.:redface:

lg, chriss
 
Eigenschaft
 
Pfeife
Pfeife
Registrierter Benutzer
Zuletzt hier
29.01.23
Registriert
30.11.05
Beiträge
6.470
Kekse
9.410
Ort
Erfurt
Vielleicht NI nochmal installieren, und darauf achten, daß es auch als VST installiert wird.
Ja, bis zu den 3er Versionen muß eine MIDI-Spur angelegt werden, und das gewünschte Instrument als Ausgang gewählt werden, wodurch zusätzlich eine sog. VST-Spur entsteht, die einer Audio-spur nicht unähnlich ist. Ab den 4er Versionen gibt es sog. Instrumentenspuren, welche die MIDI und die Audiospur gleich vereinen.
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
Achsoo, also ist das völlig normal, dass ich sowohl eine Audio als auch eine Midispur anlegen muss, und mein Instrument dann von der Audio auf die Midispur route :screwy:

Was muss ich denn dann explizit machen um über die Midispur dann das ausgewählte aufnehmen zu können? Bzw, welche Spur muss dann für die Aufnahme "gearmt" sein?

Da sollte man sich ja glatt überlegen, sich nicht das Geld zu sparen, um gleich auf Version 5 um zu steigen..(oder wenigstens V4)

Zur Installation:

Soweit ich weiß, wird NI Akoustik Piano als VST installiert. Ich muss lediglich meinen VST-Ordner angeben und dort installiert er mir dann alle DLL's hin. Das ist einmal die

-Akoustik Piano.dll
-Akoustik Piano VST.dll

Werde es jetzt einfach nochmal so machen, dass ich zuerst Cubase installiere und erst dann meine VST's...vll. liegt es ja daran.


Trotzdem schonmal danke

lg
 
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
Achsoo, also ist das völlig normal, dass ich sowohl eine Audio als auch eine Midispur anlegen muss, und mein Instrument dann von der Audio auf die Midispur route

no no no - da hast Du etwas vollkommen Falsch.

Es gibt MIDI-Spuren, die sind für MIDI-Instrumente gedacht, wie z.B. VST-Instrumente.
Als erzeugst Du eine MIDI-Spur und stellst dort als Ausgabegerät das gewünschte Gerät ein - in Deinem Fall halt das vorher in das VST-Instrumenten 'Rack' geladenen VSTi.

Im Beispiel eZDrummer, lädst Du ein Instrument, das zwar einen MIDI-Eingang aber bis zu 16 Audio-Ausgabe-Kanäle bereitstellt. Für diese Audioausgabe-Kanäle erzeugt Cubase automatisch dann auch die entsprechenden Fader im Mixer. Also im einfachsten Fall hast Du den MIDI-Fader und einen zu dem VST einen VST-Fader.

Also nirgendes eine Audio-Spur.

Da man über den MIDI-Fader die Lautstärke eigentlich nicht wirklich regeln kann, das macht man über die Anschlagstärke, isr dieser Regler eigentlich meist ziemlich nutzlos - bei manchen VSTi's wirkt er aber auf die Anschlagstärke.

Bei der neueren Instrumentenspur hat man den MIDI-Fader sozusagen weggelassen und nur den VST-Fader bereitgestellt - dieser Spurtyp funktioniert aber nur mit VSTi's die nur einen Stereo-Audio-Ausgang benutzen - also ist dieser Typ für den eZDrummer nicht geeignet.
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
Gut, das verstehe ich.

Mein Problem ist aber, dass ich in der Effektliste meiner Midi-Spur, ez-drummer, NI Akoustik Piano usw usw garnicht habe. Das finde ich lediglich in der Effektliste meiner Audiospur.

Wenn ich jetzt eine Audiospur erstelle, dort meinen Effekt nehme (z. B. EZ-Drummer), dann höre ich erstmal nichts..

Jetzt erstelle ich eine MIDI-Spur und stelle dort als Insert-effekt die Audiospur ein...dann geht es komischer Weise..mom ich werde gleich noch einen Screenshot anhängen.

EDIT:

Bild 1 zeigt meine Effektliste....ez-drummer ist komischerweise auch nicht aufzufinden (ich werd wohl wirklich alles mal Deinstallieren müssen und dann neu aufsetzen)

Bild 2 ist die Midispur. Ich habe vorher in der Audiospur den Pro53 als Insert-Effekt eingestellt...
 

Anhänge

  • fx1.jpg
    fx1.jpg
    167,5 KB · Aufrufe: 213
  • fx2.jpg
    fx2.jpg
    159,2 KB · Aufrufe: 214
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
Logisch - weil eZDrummer ist ja auch kein Effekt ;)

drück mal die F11 - da get ein Fenster auf, in dem sind mehrere 'Slots' untereinander - wenn Du nun in eines der Slots klickst geht die Liste mit den verfügbaren VSTi's auf.

Schau Dir doch einfach mal die 'Getting started' Dokumentation zu Deinem Cubase an, da ist das Schritt für Schritt beschrieben - mit Screenshots.
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
ja..werd ich auf jeden Fall mal machen, scheint mir ja dann doch ein wenig "tiefgründiger" zu sein. (also das Problem ansich)

Danke trotzdem schonmal für die Hilfe.

lg
 
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
nee - eigentlich ist es ganz einfach, man muß es nur einmal verstanden haben.

{MIDI-Daten-->[MIDI-Spur]->[MIDI-Fader]->[VSTi]}->[Audio-Daten]->[VST-Fader]->Summen-Stereo-Schiene
-----------------------hier MIDI Effekte ---------------------------------hier Audio-Effekte


EDIT: Der Pro53 z.B. ist einmal der Synth - bei den VST-Instrumenten, aber die im Pro53 integrierte Effektsektion ist auch für andere als Effekt zugänglich - deshalb erscheint hier der Pro53 auch unter den Effekten, aber darüber wird nicht der Synthie angesteuert, sondenr man nur die Effekte nutzen. Deshalb gibt es da auch die 2 DLL's

Pro-53.dll - Synthie
Pro-53fx.dll - Effekte
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
:D sry, das habe ich jetzt garnicht verstanden :D

Ich versuch das jetzt mal anhand meines Beispiels um zu wälzen:

{MIDI-Daten-->[MIDI-Spur]->[MIDI-Fader]->[VSTi]}->[Audio-Daten]->[VST-Fader]->Summen-Stereo-Schiene

MIDI-Daten: Die Daten, die mein keyboard sendet--> gehen an die Midi-Spur. Der Midi-Fader bekommt ein VST zugewiesen(?)

sry, da blick ich nicht ganz durch....konnte jetzt im Manual auch nichts finden....oder stell ich mich gerade einfach nur Blöd an? :D:screwy:

EDIT: Naja, der pro53 war jetzt nur als beispiel gedacht.

hauptsächlich geht es mir vor allem um EZ-Drummer und das NI Akoustik Piano, weil ich eben genau diese beiden VST's brauche.
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
Ach jetzt verstehe ich! Dankesehr, werde es sofort testen..und hoffen, dass es geht.

Big Thx!

lg, chriss

EDIT:

Super, EZ-Drummer funktioniert schonmal super :)

Jetzt muss ich nur noch rausbekommen, warum er NI Akoustik Piano nicht laden kann..und dann ist die Welt wieder i. O.

Dickes Dankeschön...
 
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
hast Du die Soundlibrary vom A-Piano richtig installiert - versuch mal die Standalone Version zu starten und ob da die Libraries auftauchen.
Das A-Piano besteht ja nicht nur aus der dll.
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
naja das ist ja das Problem - standalone funktioniert das programm fehlerfrei und so, wie es soll.

Lediglich cubase meckert rum...reaper erkennt es ohne Probleme...in der light version von live 7 die bei meiner soundkarte war funktioniert es auch fehlerfrei.

lg
 
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
die dll ist auch in einem Ordner, der von Cubase durchsucht wird?

geh mal auf 'Geräte' -> 'Plugin-Informationen' und schau ob es dort aufgelistet ist und welche Ordner alle durchsucht werden.
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
ja klar, ist in meinem "Stamm" VST-Ordner, dort kommen alle meine VST's hin. Habe es aber auch schon in den VST-Ordner von Cubase selber kopiert und es ändert sich nichts...ich habe mal einen Screen gemacht von der VST-Liste in Cubase.
 

Anhänge

  • vst-library.jpg
    vst-library.jpg
    199 KB · Aufrufe: 191
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
nunja - da ist nicht viel vom A-Piano zu sehen - entweder es die DLL liegt doch in einem anderen Ordner oder sie ist defekt oder nicht richtig Registriert.
Hast Du schon mal auf 'Liste Aktualisieren' geklickt?
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
ja schon gemacht....

habe die dll auch schon umbenannt und neu rein kopiert - bringt aber nichts. Aktualisieren genau so wenig.

Ich denke mal, es wäre das klügste, SX 3 und sämtliche Plugins einmal zu deinstallieren und dann cubase zuerst zu installieren...danach die Plugins....vll. bringt es ja was?!

lg
 
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
mhh - wenn es nur diese eine DLL ist, dann würd ich A-Piano einfach nochmal drüber installieren. gabs da nicht auch Updates - welche Version hast Du?
 
Chriss_Guitar
Chriss_Guitar
Registrierter Benutzer
Zuletzt hier
23.01.23
Registriert
15.05.06
Beiträge
771
Kekse
6.987
Ort
Kempten
also version is 1.0.0.014

habe jetzt die AkoustikPiano DXi.dll nochmal in den VST ordner gesteckt..mal schauen ob jetzt was anders ist..notfalls, wirds einfach nochmal installiert....irgendwo muss der fehler ja liegen...:screwy:
 
pico
pico
HCA-Recording
Ex-Moderator
HCA
Zuletzt hier
29.12.22
Registriert
30.06.07
Beiträge
15.015
Kekse
68.039
Ort
Maintal near Frankfurt/M
ahhh - no - das ist die falsche DLL - Du brauchst eine ohne DXi - diese:
AkoustikPianoVST.dll
 

Ähnliche Themen


Neue Themen

Unser weiteres Online-Angebot:
Bassic.de · Deejayforum.de · Sequencer.de · Clavio.de · Guitarworld.de · Recording.de

Musiker-Board Logo
Oben