BFD2 hakt oft, Dropouts, etc. - Einstellungen/Hardware ???

  • Ersteller Schacky
  • Erstellt am
Schacky
Schacky
Registrierter Benutzer
Zuletzt hier
18.12.22
Registriert
18.03.08
Beiträge
97
Kekse
1
Ort
Bochum-Riemke
Ich habe das Problem, dass BFD(2) beim Abspielen mit Cubase 5 hakt. Ich weiß nicht, ob es am PC, der Hardware, etc, oder den Einstellungen liegt.



Während des Abspielens hakt BFD2, was ohne nie passiert. Meistens passiert dies, wenn KitPieces zum ersten Mal gespielt werden (entweder die HiHat oder sonst was setzen einzeln ein, oder ein neuer Songteil setzt auf einmal andere Becken ein - es kommt also nicht auf die Menge der beanspruchten Samples an, sondern meistens, wenn ein KitPiece zum ersten Mal erklingt, z.B. keine Samples spielen und nur eine einzelne HiHat wird angespielt und es hakt, danach läuft es flüssig bis zum nächsten neuen Sample. Meistens bei Becken, denke, weil die Sample-Länge dort am höchsten ist.)


Während der Aufnahme läuft es meiner Meinung nach stabiler - weiß nicht, ob sich da Cubase bemüht besonders bei Aufnahmen stabil zu bleiben.


Bei Mixdowns sind oft Beckenausfälle zu vernehmen, ähnlich wie den Hakern beim Abspielen. Entweder sie hören abrupt auf oder aber stottern sich so rein, bis dass man dann nur noch das Ausklingen am Ende hört.


PC: AMD Phenom II X6 (1100T), 6x 3,3 Ghz, 16GB Ram PC3 (1333 MHz / aber Timings von Autoeinstellungen "nur" auf CL9 gestellt, sonst alles erkannt)

Im Betrieb sind dank zwei Zusatzlüfter meist nur 35Grad der CPU messbar (jedenfalls das, was angezeigt wird laut "Speccy").

Die Festplatten sind so aufgeteilt, dass auf der ersten (500GB, 32MB Cache) Win7 (64bit) und Cubase installiert ist, auf der zweiten (640GB, 64MB Cache) BFD2 & BFD-Erweiterung "Evil Drums", sowie mehrere kleine VST´s und auf der dritten Platte (500GB, 32MB Cache) werden halt Projekte, Audiodateien, etc. gespeichert. Alle Platten drehen mit 7200rpm.


Ich stelle zum Aufnehmen und Abspielen bei BFD2 auf "offline". Die Einstellungen bei "Engine" habe ich mit 8192 und 16384 probiert - ich wusste nicht, was mehr beansprucht wird, aber denke mir, wenn ich 16GB RAM habe, kann ich da ruhig (bzw. besser) auch auf 16GB stellen, da das ja die Stabilität in die Festplatten/Streaming-Schonung reinbringen sollte (?) - Jedenfalls bei beiden Einstellungen für mich kein Unterschied feststellbar, das Haken bleibt.

Das Manual sagt, man solle die Einstellung so niedrig wie "möglich" einstellen und mit 16384 und 32768 würde es auf den meisten Rechnern laufen. Verstehe ich nicht so ganz, heißt für mich, dass man den RAM nur so weit beanspruchen sollte, wie keine Dropouts zu hören sind, was meistens nur durch die sinnvolle Nutzung von mehr RAM ausgeglichen werden kann. Bei mir funktioniert es aber auch bei 16384 wie gesagt schon nicht.



Meine Kits sind meist recht groß. Unter 16384 Buffersize sind ca. 1,14GB im Ram angegeben. Lade ich hierbei ein größeres KitPiece dazu, so geht BFD2 "out of Ram" - egal ob das beim 6GB RAM - Laptop oder am 16GB RAM - PC ist, die Größe bleibt gleich.


Ich kann mir nicht vorstellen, dass am PC, der Aufteilung oder den Festplatten irgendwas nicht ausreichend genug dafür ist, selbst am Laptop (wo es aber noch mehr hakt und stottert).


[Ich nehme schon lange nicht mehr mit dem Laptop (Win7 64bit, i7, 6GB Ram, 7200er Platte zum Aufnehmen) auf, da dort die Probleme ähnlich, aber noch schlimmer sind, auch beim Aufnehmen hakt es dann ab und zu. Außerdem kommt es dort SEHR OFT vor, dass man einen Sound anspielt (oder auch beim Versuch des Abspielens) und dann hakt es, hört auf, nix geht und man muss erst abwarten, bis der Ton ca 4mal abgehackt wie ne springende CD langsam wiederholt durchgeorgelt ist... so macht das alles kein Spaß. Hier habe ich die Vermutung, dass das aufgrund Mangel an Festplatten an der internen 5400rpm auf die ich neben Win7 und Cubase auch noch BFD2 packen musste.. (?)]
 
Eigenschaft
 
tomeso
tomeso
Registrierter Benutzer
Zuletzt hier
17.11.17
Registriert
26.02.09
Beiträge
60
Kekse
238
Ort
Mannheim
Hallo Schacky,

das was Du beschreibst klingt stark nach einer falschen Konfiguration Deines BFD2. Schnelle Blinddiagnose per e-Mail Handauflegen ... hast Du eventuell "Load All To RAM" aktiviert? Der Schalter "Offline" solte beim normalen Arbeiten übrigens nicht aktiviert sein, sondern nur für das Offline Bouncing, also dem Schreiben von Audiospuren. Dabei wird Cubase genug Zeit gegeben, auch lange ausklingende Becken komplett zu berechnen.

Du schreibst ja an einer Stelle, dass das RAM knapp wird und das lässt sich mit den richigen Einstellungen in den Engine Preferences vermeiden. BFD2 läuft grundsätzlich auch auf deutlich langsameren Rechnern.

Mein Vorschlag: melde Dich mal bei uns (www.tomeso.de) und wir gehen die wichtigsten Einstellungen durch.

Gruß
Frank
 
Schacky
Schacky
Registrierter Benutzer
Zuletzt hier
18.12.22
Registriert
18.03.08
Beiträge
97
Kekse
1
Ort
Bochum-Riemke
Hallo Frank,

vielen Dank für die Antwort. Ich glaube da steckte schon die Antwort drin!

Als erstes habe ich mal die ganzen Songs nochmal "online" probiert. Ich habe jetzt 10 Songs probiert und an den gewohnten Stellen war kein Haken mehr zu hören. Gegenprobe mit "offline" - es hakt! Manchmal ist die Lösung so einfach und man sieht es nicht ;) Ich hatte halt gelesen, dass "offline" für die Berechnung der Becken beim Aufnehmen sinnvoll ist, und das dann entweder falsch gemerkt, Gedankenfehler,.. oder aber mein Englisch reichte nicht aus, um das nur auf das Bouncen zu beziehen... wie dem auch sei, hatte ich das die ganze Zeit wohl falsch im Kopf.

Nochmal zu dem RAM: Bei 16GB verbaut am besten den Buffer auf die 16384 stellen oder wie geht man bei dieser Einstellung vor?

Ich habe außerdem noch die Max Velocity Layers auf 256 erhöht, um alle nutzen zu können und zwei meiner Meinung nach nützliche Features angeklickt (Anti-Machingun Mode und Disable SideStick-Tuning) -das nur nebenbei

Im Anhang mal zwei Pics des Sets und der Engine.

Gruß, Schacky
 

Anhänge

  • BFD2 in Cubase KitPieces cut 60%.JPG
    BFD2 in Cubase KitPieces cut 60%.JPG
    140,6 KB · Aufrufe: 192
  • BFD2 in Cubase Engine cut 60%.JPG
    BFD2 in Cubase Engine cut 60%.JPG
    117,3 KB · Aufrufe: 202
tomeso
tomeso
Registrierter Benutzer
Zuletzt hier
17.11.17
Registriert
26.02.09
Beiträge
60
Kekse
238
Ort
Mannheim
Hi Schacky,

da BFD2 ja mit großen Datenmengen arbeitet sind die von Dir genannten Parameter ausschlaggebend für die Preformance Deines Systems. Jedes einzelne Instrument besitzt ja zu dem eigentlichen Direktsignal noch gleichzeitig alle Raum- und Ambientkanäle plus dem Bleeding der Instrumente. Mit anderen Worten: spielst Du die Snare, werden gleichzeitig bis zu 11 Audiokanäle abgespielt.

In Deinem Bild sind 20 Instrumente zu sehen, davon allein 15 Becken. Wenn Du nun alle Becken anspielst und diese entsprechend lange ausklingen, sind das allein 165 Audiokanäle die BFD2 verwalten muss. Das geht natürlich nur mit Diskstreaming, wobei ein gewisser Anteil des Audiokanals bereits ins RAM vorgeladen wird. Wie groß dieser ersten Teil ist, wird mit dem RAM Buffer eingestellt. Der sollte theoretisch so groß wie möglich sein.

In der Praxis sieht das aber etwas anders aus, bleiben wir bei den Becken:
Bekanntlich können bestimmte Instrumente bis über 200 Velocity Layer besitzen (vor allem die Librarys von Platinum Samples). Die meisten Becken haben aber eher so um die 30-40 Layers und verschiedene Artikulationen (Bell, Crash etc).

Der Wert den Du für den RAM Buffer einstellst wird also mit der Anzahl der Layers multipliziert und das wiederum mit der Anzahl der Artikulationen. Bei "großen" Instrumenten mit vielen Artikulationen wie z.B. Snares und Hi-Hats sind das sehr schnell viele Datenpakete. Damit wird aber der Ladevorgang deutlich langsamer als mit kleinen Buffergrößen. Und damit der Workflow etwas zäher ...

Sooo, das war jetzt etwas weit ausgeholt ... hier jetzt ein paar pauschale Tipps:
- Wenn der Datendurchsatz des Systems eher groß ist (also schnelle HD an schneller Schnittstelle), dann eher die RAM und Disk Buffer klein einstellen. Wenn sie zu klein sind, einfach die nächste Größe ausprobieren.
- Ist das System eher nicht so schnell oder anders ausgelastet, die Buffer eher etwas größer wählen, dann hat die Harddisk etwas mehr Zeit um alle Samples zu finden und die Daten bereitzustellen.
- In der Layout-Phase des Songs einfach mit weniger Layers (15-30) arbeiten und dann bei der Detailarbeit bzw. dem Mixdown erst auf größere Werte umstellen.
- Die Layeranzahl kann übrigens je Instrumententyp separat eingestellt werden. Wenn die Kick sowieso immer Volldampf gibt, kann man hier ruhig weniger verwenden und für filigranes wie Becken, Snare oder Hi-hat eher mehr verwenden.
- Ich persönlich würde immer den 16 Bit Modus (siehe Preferences) verwenden. Gerade bei Drums ist der Unterschied extrem vernachlässigbar, aber der Datendurchsatz und der RAM Bedarf wird glatt halbiert. Zur Not kann man den 24 Bit Mode auch später beim Bouncen wieder aktivieren.

Ich hoffe das hilft Dir und eventuell mitlesenden Usern etwas weiter.

Viele Grüße

Frank
 
  • Gefällt mir
Reaktionen: 4 Benutzer
Schacky
Schacky
Registrierter Benutzer
Zuletzt hier
18.12.22
Registriert
18.03.08
Beiträge
97
Kekse
1
Ort
Bochum-Riemke
Vielen Dank!

Vieles davon hilft mir zum Verständnis und zum Ausprobieren.

An sich brauche ich beim Aufnehmen oder arrangieren auch keine höchste Qualität, werde da also zugunsten des Work-Flows bisschen an den Einstellungen drehen sowie sowieso die Ram-Einstellungen ausprobieren.
Einzig beim Programmieren würde ich auhc gerne Nuancen und Unterschiede hören, aber da macht es ja nichts, wenn es mal ne Sekunde hakt.
Hauptsache beim Mixdown ist dann alles im Fluss und beim Aufnehmen hakt es nicht, egal mit welcher Einstellung von BFD2 zumindest.

Grüße! Schacky
 

Ähnliche Themen


Neue Themen

Unser weiteres Online-Angebot:
Bassic.de · Deejayforum.de · Sequencer.de · Clavio.de · Guitarworld.de · Recording.de

Musiker-Board Logo
Oben