exportiertes MIDI - file über VST abspielen --> Problem

von Mark2, 19.01.08.

  1. Mark2

    Mark2 Registrierter Benutzer

    Im Board seit:
    19.01.08
    Zuletzt hier:
    1.09.12
    Beiträge:
    39
    Zustimmungen:
    0
    Kekse:
    92
    Erstellt: 19.01.08   #1
    Hallo zusammen,

    bin (Akustik-)gitarrist und möchte meine Songs mit etwas MIDI "aufpeppen" ...
    Da ich (noch) kein Masterkeyboard besitze,
    trotzdem aber mal hören wollte, was da so an Soundmöglichkeiten drin ist, habe ich folgendes versucht :

    hab mir Edirol HyperCanvas billig gebraucht besorgt, das dann als VST ins Cubase eingebunden;
    zu einem bestehenden Song von mir habe ich dann mit GuitarPro ein MIDI-file erzeugt, d.h.
    lediglich die Noten von Hand gesetzt und die so erhaltene Partitur dann als MIDI-file exportiert.

    Dieses MIDI-file dann ins Cubase zu den schon bestehenden Spuren als neue MIDI-Spur zugefügt, mit HyperCanvas
    verknüpft und fertig. Alles soweit prima geklappt, ich höre nun meinen Song vom MIDI - file begleitet, wie es sein soll.

    Durch den Export des MIDI-file aus GuitarPro ist dem MIDI-part nun aber scheinbar das Instrument "Steelstring Guitar"
    zugeordnet, da die Spur im GuitarPro eben auf dieses Instrument eingestellt war (GuitarPro nutzt den GS Wavetable).

    Beim Abspielen in Cubase springt der HyperCanvas nun immer wieder zurück auf "Steelstring Guitar", wenn die Wiedergabe beginnt. Egal
    welches Instrument ich vorher zugewiesen habe.
    Wenn die Wiedergabe läuft, kann ich das Instrument ändern, aber sobald ich z.B. geloopt abspiele und der Sequenzer wieder an den
    Anfang des MIDI - parts kommt, springts wieder auf Steelstring Guitar zurück. Ist zwar die Steelstring des VST´s, aber
    das hilft mir auch nicht ;-)) Ich wills ja als Orgel, Piano oder Flöte haben ...

    Jemand ´ne Ahnung, was ich da falsch mache ??

    Danke schonmal im Voraus und schönes Restwochenende !!!

    Gruß

    Mark
     
  2. Jean-M.B.

    Jean-M.B. HCA Yamaha Keys / InEar HCA

    Im Board seit:
    10.08.07
    Zuletzt hier:
    9.12.16
    Beiträge:
    3.235
    Ort:
    Weimar
    Zustimmungen:
    210
    Kekse:
    6.317
    Erstellt: 19.01.08   #2
    Vermutlich hat Guitar-Pro einen Program-Change-Wert für die Spur angelegt.
    Makiere in Cubase die Spur, gehe oben auf den Reiter "Midi" -> "Listen-Editor" und ändere den Program-Change-Wert (PC) am Anfang der Spur.
     
  3. Mark2

    Mark2 Threadersteller Registrierter Benutzer

    Im Board seit:
    19.01.08
    Zuletzt hier:
    1.09.12
    Beiträge:
    39
    Zustimmungen:
    0
    Kekse:
    92
    Erstellt: 19.01.08   #3
    THX Jacky,

    genau so funktionierts !!

    :great:
     
Die Seite wird geladen...

mapping