Probleme mit Midi bei FL Studio

von michael_goehner, 02.02.08.

  1. michael_goehner

    michael_goehner Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 02.02.08   #1
    Hi, ich habe ein Casio CT-670 von einem Kumpel ausgeliehen nun habe ich mir noch ein Mdidi Kabel gekauft un dies an die Soubnkarte und ans Keyoboard angeschlosen. Der Asiotreiber ist intaliert un wenn ich auf das Symol Asio4all klicke dann zeigt es auch den Midi einund Ausgang als Ok an. Nun habe ich es mit Fl studio getestt doch ich weis einfach nicht was für einstellungeh ich vornehmen muss, da dort so viele channel un sowas sind ich kapier da garnix mehr durch.

    Ich werde auch noch nen screenshot uploaden.

    Ich danke für eure Hilfe

    MfG. Michael Göhner
     
  2. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 02.02.08   #2
  3. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 03.02.08   #3
    Kann mire kienr einen kleinen Tip geben ich verzweifel fast.

    Hat das Problem auch jemand?
    Kennt jemand ne Seite auf der man gut Tips oer Infos bekommt?
    Was sin das für Channel undd Ports?


    Ich flehe euch an bitte helft mir.

    MfG. Michael Göhner

    PS. Wenn ihr noch mehr Screenshots oder Informationen arüber benötigt sagt es dann were ich mich sofort darum kümmern

    hab euch mal noch nen Screenshot von er Asio Sotware gemacht villeicht hab ic da ja was falsch eingestelt

    http://s2.***.net/images/080203/temp/eqfu7b3i.jpg
     
  4. Wolf-107

    Wolf-107 Registrierter Benutzer

    Im Board seit:
    26.12.05
    Zuletzt hier:
    3.03.10
    Beiträge:
    1.257
    Ort:
    Seevetal
    Zustimmungen:
    1
    Kekse:
    3.289
    Erstellt: 03.02.08   #4
    Schalte mal zusätzlich noch den
    Microsoft MIDI-Mapper in den Midisettings auf Sync.
    Bei Generic Controller brauchst du keinen anzuwählen.
     
  5. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 03.02.08   #5
    Dankr für deine antwort, ich habe es so gemacht wie beschrieben doch es geht imer nioch nciths. Ich weis nichtmal ob ichs richtig mache also wenn ich ie töne die ich aufm keyboard spiel aufm pc haben will mit fl stuio mus ich dann auf ads record zeichen un anach auf play oder ist das mit mii nicht so einfach? muss ich irgendwas zusätzlich machen damit ie töne überhaupt kommen?

    http://s2.***.net/images/080203/temp/55hhkqju.jpg

    Müssen ie rotmarkieren TReile leuchten weil das tun sie nicht

    Danke für eure Hilfe MFG Michael Göhner
     
  6. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    27.11.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 03.02.08   #6
    OT @michael_goehner

    kannst Du Dir vielleicht mal etwas mühe beim schreiben geben ?? :mad:
     
  7. Wolf-107

    Wolf-107 Registrierter Benutzer

    Im Board seit:
    26.12.05
    Zuletzt hier:
    3.03.10
    Beiträge:
    1.257
    Ort:
    Seevetal
    Zustimmungen:
    1
    Kekse:
    3.289
    Erstellt: 03.02.08   #7
    Ich muss Pico jetzt mal zustimmen.
    Bitte schreibe doch mal in einem einigermaßen verständlichen Deutsch, mit Satzzeichen, Groß-/Kleinschreibung und vollständigen Sätzen.
    Bei deinem letzten Beitrag hab ich in Zeile 2 aufgehört zu lesen, kam mir vor wie besoffen.

    Sorry, aber bitte nochmal ein neuer Versuch.


    Mal Kurz Back2Topic:
    Ganz banal gefragt: Du machst das Midikeyboard aber an, bevor du FL-Studio startest, oder?
     
  8. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 04.02.08   #8
    Ok ich werde mir Mühe geben beim schreiben. Doch das alles Fehlerfrei ist kann ich nicht versprechen.

    Klar schalte ich das Keyboar ein bevor ich FL-Stuio Starte.

    Da ich so gut wie keine Ahnung von Midi habe, weis ich nichtmal ob ich das überhaupt alles richtig mache.

    Muss der Ton vom Keyboard auch kommen wenn ich nicht aufnehme?
    Also sowie wenn ich die Tastatur benutze?

    Oder kommt der Ton nur wenn ich etwas bestimtes zusätzlich anmach?

    Wäre sehr nett von euch wenn mir jemand erklären könnte auf was ich achten muss.

    MfG. Michael Göhner

    PS. Eine Rechtschreibprüfung habe ich nicht durchlaufen lassen, aber ich hoffe das man es so lesen kann.
     
  9. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 04.02.08   #9
    So, gerade habe ich es geschaft das das Midi out funtioniert.

    Ich habe einen neuen Pattern (weis nicht ob der Name stimmt) erstellt als Midi out und dann konnte ich auf dem Computer was spielen und dies kahm auf dem keyboard.

    Doch damit das ging habe ich bei den Midi settings eine Portnummer angeben müssen.

    Bei Midi in gibt es sowas nicht und ich habe auch keine Ahnung wie das überhaupt funktioniert.

    Ich hoffe ihr könnt alles lesen und mir weiterhelfen.

    MfG. Michael Göhner
     
  10. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    27.11.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 04.02.08   #10
    so nun muss man sich nicht mehr so Anstrengen beim lesen ;)

    ich kenne FL Studio nicht aber mal prinzipiell gibt es 2 Möglichkeiten mit einem Keyboard zu arbeiten

    1. Das Keyboard hat eine eigene Klankerzeugung, dann kann man das Audiosignal des Keyboards von den Line-Out Ausgängen in die Audio-In des PC's verbinden und dann nimmt das als Audio auf.

    2. Das Keyboard wird nur als 'Tastatur' gebraucht, dann wird der MIDI-Out vom Keyboard mit dem MIDI-IN des PC's verbunden und die Klangerzeugung findet in einem 'Virtuellen' Synthesizer im PC statt. Das ganze macht man in einer Sequenzer Software (ich nehme mal an das FL eine solche ist). Dazu muss man zuerst eine MIDI-Spur erzeugen, diese dann zu dem MIDI-IN 'verbinden' - wenn das richtig gemacht ist, müsste die Anzeige in dem Programm (in Deinem letzten Screenshot 'MIDI activity' ) beim drücken einer Taste am Keyboard flackern.
    Um jetzt auch was hören zu können, mus auf dieser Spur noch ein Synthesizer (bei vielen Programmen sind das sogannte VST's) 'geschaltet' werden, diese erzeugt aus den MIDI-Daten - denn mehr ist MIDI nicht, nur Tönhöhe, Tonlänge, Anschlagstärke usw. - ein Audiosignal in der dort einzustellenden Klangfarbe. Diese Audiosignal wird dann wieder der Soundkarte 'zugeführt' und steht dann am Audio-Out der Karte zur Verfügung.

    Wenn Du jetzt in der Spur MIDI-Daten aufgenommen oder per Editor geschrieben hast, kannst du die Spur auch auf das MIDI-OUT routen - also 'virtuelle verbinden' und dann von dem MIDI-OUT des MIDI-Interface in das MIDI-IN des Keyboards gehen und dann sollte das Keyboard die gespielten Noten wiedergeben


    So - noch eine Sache, da man über MIDI mehrere Geräte zusammenschalten kann, muß ja jedes Gerät wissen wann es was spielen soll - dazu gibt es in den MIDI-Daten noch die Kanäle. Jedes Gerät bekommt eine Kanalnummer zugewiesen und wenn jetzt ein MIDI-Datenpaket ankommt, prüft das Gerät ob die Kanalnummer seine ist und reagiert dann darauf. Also muss es an Deinem Keyboard und in der Software noch Einstellungen für die Kanäle geben und die müssen dann entsprechend zusammen passen. Der Kanal 10 ist üblicherweise für Drums 'reserviert'.

    hab grad mal auf der Webseite rumgesucht - ist aber auch alles in der Hilfe ganz gut beschrieben http://www.flstudio.com/help/
     
  11. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 04.02.08   #11
    Ok danke für deine Antwort.

    Jetzt habe ich das mal richtig verstanden.

    Nun habe ich das Problem das ich die neu erzeugte Spur nicht zu dem Midi in verbinden kann (Jedenfals weis ich nciht wie das gehen soll).

    MfG. michael Göhner
     
  12. Wolf-107

    Wolf-107 Registrierter Benutzer

    Im Board seit:
    26.12.05
    Zuletzt hier:
    3.03.10
    Beiträge:
    1.257
    Ort:
    Seevetal
    Zustimmungen:
    1
    Kekse:
    3.289
    Erstellt: 04.02.08   #12
    Also allgemein muss dieses kleine Midi-Lämpchen leuchten wenn du auf dem Keyboard eine Taste drückst.
    Tut es das?
    Wenn du keinen Port angibst, dann sind automatisch alle Ports belegt.Die Ports brauchst du im Prinzip nur, wenn jede taste etwas anderes machen soll (z.B. zwei verschiedene Tasten steuern 2 verschiedene Synths an).
    Bei Synchronisation Type in den Midisettings muss Midi-Clock stehen.
     
  13. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 04.02.08   #13
    Das Lämpchen hat bisher noch garnicht geleuchtet.

    Also Ich brauche keinen Port angeben und dann müsste es Funktionieren?

    Midi Cklock steht drinn.

    Danke für deine Hilfe

    MfG. Michael Göhner

    PS. Für was sin ie Channel da?
     
  14. Wolf-107

    Wolf-107 Registrierter Benutzer

    Im Board seit:
    26.12.05
    Zuletzt hier:
    3.03.10
    Beiträge:
    1.257
    Ort:
    Seevetal
    Zustimmungen:
    1
    Kekse:
    3.289
    Erstellt: 04.02.08   #14
    So, hier sind mal Screens von meinen Midi-Einstellungen.
    Einfach mal vergleichen.
    Oben bei Output ist der Microsoft Midi-Mapper auf Sync gestellt (der is nur grad versteckt):
    Unbenannt.JPG
    Unbenannt2.JPG

    Zum Thema Midichannel lies mal das hier:
    http://home.snafu.de/sicpaul/midi/midi0e.htm
     
  15. schmoegel

    schmoegel Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    11.06.12
    Beiträge:
    2
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 16.02.08   #15
    sehr gut, dass das thema noch relativ aktuell ist und ich keine uralten themen ausbuddeln muss.
    ich hab das gleiche problem, nur hab ich anstatt eines midi-ein/ausgangs in der soundkarte (den ich nicht habe) so einen midi/usb-adapter benutzt und versuche seit einiger zeit vergeblich, mein yamaha psr 240 zu benutzen, um fruityloops zu 'steuern'.
    ich hab schon in den einstellungen rumgespielt, in der systemsteuerung, und die anleitung zu dem ollen keyboard hab ich mir auch schon runtergeladen, aber nichts gefunden. funktionieren tut allerdings nichts.

    wäre schön, wenn man mir weiterhelfen könnte. :)
     
  16. 4feetsmaller

    4feetsmaller Mod Emeritus Ex-Moderator HFU

    Im Board seit:
    28.08.06
    Zuletzt hier:
    26.07.16
    Beiträge:
    6.980
    Ort:
    Brotterode | Th
    Zustimmungen:
    30
    Kekse:
    9.833
    Erstellt: 17.02.08   #16
    Was ist das für ein Adapter ? Sind die Treiber davon installiert ?
     
  17. schmoegel

    schmoegel Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    11.06.12
    Beiträge:
    2
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 17.02.08   #17
  18. michael_goehner

    michael_goehner Threadersteller Registrierter Benutzer

    Im Board seit:
    17.08.07
    Zuletzt hier:
    14.03.10
    Beiträge:
    110
    Ort:
    Uttenhofen/Rosengarten/Schwäbisch Hall/Baden Würte
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 23.02.08   #18
    Ich habe mir jetzt nochmal alles intensiv nachgeschaut und weis genausowenig als voher.
    Ich finde es schonmal erleichternt das ich nicht der einzigste mit dem Problem bin, denn dadurch kann ich einen defekt der Hardeware ausschlißen.

    Sollte jemand noch irgendeinen Tip haben oder wissen was wir falsch machen, den bitte ich uns zu helfen

    MfG. Michael Göhner
     
  19. moosichris

    moosichris Registrierter Benutzer

    Im Board seit:
    16.02.08
    Zuletzt hier:
    18.12.10
    Beiträge:
    312
    Ort:
    Berlin
    Zustimmungen:
    0
    Kekse:
    75
    Erstellt: 15.05.08   #19
    Ersteinmal muss unter Input Dein Midi-Interface erkannt bzw. aktiviert sein. An alles, was im

    Menü mit Midi zu tun hat, muss ein Häkchen gesetzt sein. Dann musst Du wissen, ob Deine

    Aufnahme im Step-Sequencer oder Deiner Piano-Roll landen soll.

    Im FLStudio gibt es an zwei Stellen eine Midi-Import-Funktion: Einmal im Main-Panel unter

    Import und in der Piano Roll unter den Piano Roll-Options unter File/ Import Midi File.

    Verwendest Du den Step-Sequencer musst Du noch einen Channel einstellen, in welchen das

    Midi aufgenommen werden soll.
     
  20. zero241181

    zero241181 Registrierter Benutzer

    Im Board seit:
    23.05.07
    Zuletzt hier:
    31.01.14
    Beiträge:
    5
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 07.04.10   #20
    Tag auch hab auch ein kleines Proplem und zwar hab ich Fl Studio und reason am laufen. Gespielt wird über ein Axiom 61.
    Ich höre und sehe alles wenn ich spiele, allerdings kann ich um etwas in fl aufzunehmen NUR im Piano roll per hand etwas anklicken damit töne kommen, die er dann ja auch speichert.
    klappt eigendlich alles wunderbar, auch mit verschiedenen tönen ohne groß was zu wechseln, aber wenn ich auf aufnahme drücke und über das axiom spiele gibt er die Töne zwar ab aber er speichert sie nicht in der Lane wo sie eigendlich erscheinen soll.
    hab schon versucht zu googeln und yt hab ich auch so ziemlich durch.

    thx 4 help
     
Die Seite wird geladen...

mapping