QLC+ und Audio-Trigger aus der DAW heraus funzt nicht

  • Ersteller Schnetty
  • Erstellt am

S
Schnetty
Registrierter Benutzer
Zuletzt hier
13.05.22
Registriert
02.11.04
Beiträge
15
Kekse
485
Hallo,

ich bastel seit einiger Zeit mit QLC+ für die Band an unserem Lichtsetup.
Beim Sound 2 Light Problem bin ich irgendwann auch soweit gekommen, das ich aus StudioOne (meine DAW) heraus über das Midi Loopback Plugin per Midi diverse Dinge starten kann ( vorm Einzähler alles Resetten, dann den Audio-Trigger einschalten, die Cue-List starten usw) und ich konnte auch aus der DAW heraus mit dem Song das Audio-Widget in QLC+ antriggern, das alles hat schon funktioniert. Jetzt hab ich 2 Wochen nicht daran weiter gearbeitet und wollte gestern mal wieder ran, aber ich bekommen keinen Pegel mehr in das Audio Widget. Änderungen am Laptop zwischenzeitlich waren, eine Testversion einer Drum-Software (Modo Drums), die mir dann aber nicht gefallen hat und so hab ich´s wieder deinstalliert und das letzte Win10 Update musste ich einspielen. Keine Ahnung ob das ursächlich ist.

Mein Setup:

Acer 17" WIN10 Laptop
Presonus StudioOne Artist v5.4.1
Presonus Studio24C Audio Interface
QLC+ 4.12

Ich hab in QLC die Audio Ein/Ausgänge auf Standardgerät, was bisher ja immer funktioniert hat (das Standardgerät ist dann halt das Presonus Audio-Interface) und MIDI hört auf das Loopback Plugin, was auch funktioniert
In der DAW ist der Audio Ausgang auf das Studio24c gelegt und wenn ich jetzt nen Song in die DAW lade und zusammen mit der Midispur starte, dann seh ich zwar, das die Midibefehle machen was sie sollen, aber ich bekomme aus der DAW heraus keinen Pegel mehr in das QLC Audio Widget. Auch wenn ich ein MP3 aus VLC-Player oder den Windows Mediaplayer starte, reagiert QLC nicht.

Einzig wenn ich in den Line-In vom Audio Interface einen Einspieler hänge (aktuell mein Tablet), dann kommt etwas an.

Hat da jemand ne Idee warum QLC offensichtlich auf keinerlei vom Laptop abgespielter Musik mehr reagiert?

Ich hab zwar beim suchen im Board auch nachfolgenden Thread gefunden, aber da der User die eingebaute Soundkarte verwendet, ist das für mich nicht hilfreich und das in einer Antwort verlinkte Video ist nicht mehr on:
https://www.musiker-board.de/threads/qlc-sound-to-light.701799/

Greets
Schnetty

Ich hab mal Screenshots meiner Einstellungen an der DAW und QLC gemacht:
studio-one-audiogeraet.jpg


studio-one-audiogeraet.jpg
 
Eigenschaft
 
chrisderock
chrisderock
Registrierter Benutzer
Zuletzt hier
17.05.22
Registriert
14.08.08
Beiträge
1.310
Kekse
4.931
Ort
Nürnberg
Hmm, ja, ein weit verbreiteter Fehler. Wenn Du Dein Interface in QLC+ als Eingang wählst nutzt der die physischen Eingänge des Gerätes. Der Ton der rauswärts geht kommt nicht in QLC+ an. Ev. kannst Du im Routing vom Interface was drehen damit da ein Loopback erzeugt wird. Standard ist sowas aber nicht.
 
S
Schnetty
Registrierter Benutzer
Zuletzt hier
13.05.22
Registriert
02.11.04
Beiträge
15
Kekse
485
Hmm, mag sein, muss ich mir mal genauer anschauen. Ich hab gefühlt schon alle Optionen durch - das blöde ist, es hat schon funktioniert. Ich hab allerdings bis auf das Modo-Drums (was allerdings nicht so sauber funktioniert hat und ich es deswegen auch wieder deinstalliert hab) und mein letztes Windows Update nix nachinstalliert das ev. die Konfig hätte ändern können.
 
chris_kah
chris_kah
HCA PA- und E-Technik
HCA
Zuletzt hier
17.05.22
Registriert
18.06.07
Beiträge
6.690
Kekse
82.815
Ort
Tübingen
Wenn ich z.B. Youtube Audio mitschneiden will, nutze ich als Eingangsgerät den Stereomix.
Das muss man aber erst einmal freischalten, das ist per Default nicht sichtbar.

Mit dem Kniff kann ich dann den Ton aufnehmen, der aus den Lautsprechern rauskommt.
 
S
Schnetty
Registrierter Benutzer
Zuletzt hier
13.05.22
Registriert
02.11.04
Beiträge
15
Kekse
485
Das wär für mich eher ne suboptimale Lösung. Wie gesagt, das alles hat ja schon funktioniert. Ich hab nur absolut keinen Schimmer warum mit einem mal nicht mehr. Interface Treiber neu installieren, das Universal Control von Studio One updaten und die Firmware des Audio Interface aktualisieren hat jedenfalls nix gebracht. Alle Routingversuche sind ebenfalls erfolglos geblieben.

Wir haben jedoch zwischenzeitlich mal den Live-Betrieb ausprobiert und festgestellt, das Sound 2 Light komplett Müll ist. Das Audio Widget lässt sich nicht so einstellen, das es nur auf den Aktzent-Klick hört und per Divisor hätt ich gern gehabt. das es z.B. nur alle 4 Takte mal schaltet. Der Klicktrack besteht ganz klassisch aus 2 Klicksounds, den Akzent und eben den leiseren Klick. Sag ich dem Audio-Trigger "hör nur auf den lautesten Klick" dann tut er das mal, und mal eben nicht obwohl es immer genau der gleiche Klick-Sound ist.
Egal wie die Schwellwerte eingestellt waren und welche Frequenzbereiche ich abhören lasse, es funzt nicht so wie ich es haben will. Zudem lässt sich die Faderstellung des Audio WIdgets offensichtlich nicht speichern. Nach jedem QLC Neustart und Set laden steht das Teil wieder auf 100%. So komm ich nicht weiter und die elende Rumprobiererei hält mich nur auf.

Also hab ich was anderes gemacht, das mich zufriedenstellt:
Ich schalte am Anfang in der Midispur die gewünschte CuelList ein, dann hab ich 2 Schalter gebaut. Einer macht in den QueLists nen Step vor, einer nen Step zurück. Die Schalter hören jetzt auf ne Midinote, die ich den QueLists dann als "Step vor" und "Step zurück" zuweise. In Studio One spiele ich jetzt per Midi-Keyboard live die entsprechenden Noten und siehe da, ich kann punktgenau mit deutlich weniger Aufwand als bei den individuell geproggten Stücken und vor allem dem ungenauen Gefummel mit dem Audio-Trigger eine QueList anwählen und diese dann per Midi durch steppen. 2 Probeläufe gemacht, dann aufgezeichnet. 2 Korrekturen per Hand und da war der Song innerhalb einer halben Stunde komplett fertig und das ganze sieht super aus. QueLists mit Szenen, Wacklerfahrten usw hab ich ja schon tonnenweise gebaut, da kann ich schon ein paar QueLists mit füttern.

Auf diese Weise bau ich jetzt die restlichen Songs, für die ich nicht speziell eine Show gebaut hab und dann ist Ruhe im Karton :)

Greets
Schnetty
 
Zuletzt bearbeitet von einem Moderator:
chrisderock
chrisderock
Registrierter Benutzer
Zuletzt hier
17.05.22
Registriert
14.08.08
Beiträge
1.310
Kekse
4.931
Ort
Nürnberg
und festgestellt, das Sound 2 Light komplett Müll ist.
Willkommen in der wirklichen Welt... :D
Spass beiseite. Ich hab mein Setup folgendermaßen:
* Einen Soloframe mit so vielen Pages wie Songs in der Setlist sind. Die Pages werden per MIDI-Spur umgeschaltet (pro Page eine Note). Die folgenden Befehle wirken dann nur auf die aktuelle Page.
* In der Page eine Cuelist deren Steps dann wieder per MIDI weitergeschaltet werden.
* Pro Songteil (Strophe, Vers, whatever) einen Step in der Cuelist gemacht der das dafür benötigte List steuert.

So bekommen wir ne anständige Show programmiert die zusammen mir dem Clicktrack läuft. Und alles sit genau so wie wir das wollen. Audio-Trigger brauchts da garnet.
 
S
Schnetty
Registrierter Benutzer
Zuletzt hier
13.05.22
Registriert
02.11.04
Beiträge
15
Kekse
485
Hmm, das mit den Pages musst du mir mal erklären.
Aktuell hab ich in der virtuellen Konsole ein paar Rahmen erstellt, in einigen alle Movinghead relevanten Teile "EFX, Beamfarben" usw. In einem Rahmen die Cuelists die ich verwenden will in einem weiteren die PAR´s mit Farben und ein Rahmen mit Songspezifischen Schaltern, die dann diverse Szenen/Sequenzen usw antriggern sollen, die ich für individuell programmierte Songs verwende.

Wieviel Songs kannst du denn so bedienen?
Bei uns müssten das so ca 270 werden. Per Midi hab ich Oktaven von -2 bis +8 zur Verfügung. Das schränkt die Möglichkeiten ja doch etwas ein.
Vielleicht ist meine Herangehensweise aber auch zu kompliziert.

Blöd find ich, das ich keine Möglichkeit finde, eine EFX Wacklerfahrt als standard auszuwählen und dann taktgenau die Farben wechseln kann (z.b. ne Collection mit nem EFX und einer CueList drin, die ich dann passend weiter steppe. Aber wie kann ich die dann per Midi weiter schalten?.
Aktuell bau ich das über ne Collection (EFX rein, Beam Farbe rein, Par Farbe rein) wenn ich die dann wechsle, startet im ungünstigsten Augenblick die neue Collection wenn der Wackler grad z.B. die Hälfte der Fahrt abgefahren ist. So startet das EFX dann von vorne, was dann hässliche Ruckler ergibt.
 
chrisderock
chrisderock
Registrierter Benutzer
Zuletzt hier
17.05.22
Registriert
14.08.08
Beiträge
1.310
Kekse
4.931
Ort
Nürnberg
Hmm, das mit den Pages musst du mir mal erklären.
Dort ist das mit den Pages erklärt: https://qlcplus.org/docs/html_en_EN/vcframe.html
Bei uns müssten das so ca 270 werden.
In einem Set? Das nenn ich mal sportlich ;) Aber da findet man sicher auch eine Lösung.
Blöd find ich, das ich keine Möglichkeit finde, eine EFX Wacklerfahrt als standard auszuwählen und dann taktgenau die Farben wechseln kann
Da fällt mir spontan das Speeddial (https://qlcplus.org/docs/html_en_EN/vcspeeddial.html) ein. Das läst sich per "MIDI Beat Clock" (https://qlcplus.org/docs/html_en_EN/midiplugin.html) ansteuern und dann zum timen von anderen Geschichten nutzen.
 
S
Schnetty
Registrierter Benutzer
Zuletzt hier
13.05.22
Registriert
02.11.04
Beiträge
15
Kekse
485
Thanx,

Hab mal mit dem SoloFrame rumprobiert. Das klappt nach anfänglichen Probs jetzt aber. Ein Problem hab ich allerdings noch.
Manche Songs würde ich gern am Ende per Masterdimmer langsam runter faden. Kann man das auch irgendwie per Midi ansteuern?
Sieht ja nich soo geil aus wenn bei jedem Song am Ende stumpf ein Blackout kommt. Klingt der Song am Ende aus, würd ich gern nen Fader haben, der dann praktisch weich runter zieht.
 
chrisderock
chrisderock
Registrierter Benutzer
Zuletzt hier
17.05.22
Registriert
14.08.08
Beiträge
1.310
Kekse
4.931
Ort
Nürnberg
Manche Songs würde ich gern am Ende per Masterdimmer langsam runter faden. Kann man das auch irgendwie per Midi ansteuern?
Das würd ich nicht per Master machen sondern indem ich am Ende des entsprechenden Chasers (ich nehm für alle Songs einen Chaser in dem die Parts nacheinander angeordnet sind) eine entsprechende Blackout-Scene einfüge. Weiter wird im Chaser der "Fade In Speed" auf "Per Step" gesetzt und bei der Blackout-Scene der Fade In Speed auf die gewünschte Dauer. Die restlichen Steps dann wie gewünscht einfaden.
 
S
Schnetty
Registrierter Benutzer
Zuletzt hier
13.05.22
Registriert
02.11.04
Beiträge
15
Kekse
485
Ahh, OK, schade das es sowas nicht global gibt. Z.B. ne Funktion die man antriggert und dann in der Funktion sagt "Zieh den Dimmer runter in x-Sec"
 

Ähnliche Themen


Unser weiteres Online-Angebot:
Bassic.de · Deejayforum.de · Sequencer.de · Clavio.de · Guitarworld.de · Recording.de

Musiker-Board Logo
Oben