Richtige Buffer Size

von Ravine, 17.07.07.

  1. Ravine

    Ravine Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 17.07.07   #1
    Servus !

    Bin ganz neu hier . . .also vergebt mir wenn jemand schon mal nachgefragt hat. . .

    Ich nehme mit Pro Tools m - Powered auf. Habe einen Leistungsstarken PC und eine M- Audio Firewire Soundkarte ( FW 1814 ) und einen Presonus Firestudio Wandler.
    Habe versucht Vocals aufzunehmen. . .Betohnung liegt auf versucht. . .

    Es ergeben sich knackser in der Aufnahme. Das ist mir so noch nie passiert, denn diese Knackser lassen sich auch nicht mit tieferen oder höheren Buffer Sizes beheben . . .

    Habe von 128 - 2048 Samples, sämtliche Buffer Levels und Playback Buffers ausprobiert aber es knackst !!

    Hat jemand eine Idee ??
    Besten Dank !
    Freundliche Grüsse
    Stephan
     
  2. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 17.07.07   #2
    Ist das Firestudio nicht auch ein vollwertiges Interface? Wie hast du die Komponenten verkabelt? Mit welchem Gerät genau wird aufgenommen?

    Ich tippe auf ein Problem der Geräte untereinander bzw. eine nicht funktionierende/vorhanden Synchronisation.
     
  3. ars ultima

    ars ultima HCA Recording HCA

    Im Board seit:
    19.03.05
    Zuletzt hier:
    21.11.14
    Beiträge:
    16.702
    Ort:
    Düsseldorf
    Zustimmungen:
    867
    Kekse:
    36.410
    Erstellt: 18.07.07   #3
    Stimmt. Unnötig teure Kombination, wenn man das Firestudio nur als ADAT-PreAmp nutzt :) Falls du das tust, dann könnte es in der Tat ein Synch Problem sein. Vielleicht ist nicht eindeutig einstellt, dass ein gerät Master und das andere Slave ist.
     
  4. Ravine

    Ravine Threadersteller Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 18.07.07   #4
    Das Firestudio ist nicht an Firewire an geschlossen, d.h. es läuft als Standalone Gerät. Nur die ADAT OP des Firestudio sind mit den ADAT IP vom M-Audio verbunden.
    Das M- Audio Interface ist als Master eingestellt.

    Ich finds nur komisch das es auch knackt wenn der Presonus ausgeschaltet ist, bzw. wenn ich mit dem M-Audio Interface aufnehme.

    Daher denke ich das etwas mit Software - einstellungen nicht stimmt, Buffer Size oder so. . .

    Besten Dank trotzdem für eure Antworten !
    MFG Stephan
     
  5. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 18.07.07   #5
    Also wenn mich mein Wissensstand in Sachen ADAT jetzt nicht im Stich lässt: wenn du das Firestudio an hast, und das M-Audio als Master fungiert, musst du zusätzlich eine Verbindung vom M-Audio zum Firestudio per ADAT herstellen, also in beide Richtungen...

    Schlag mich ars, wenns falsch ist ;)
     
  6. ars ultima

    ars ultima HCA Recording HCA

    Im Board seit:
    19.03.05
    Zuletzt hier:
    21.11.14
    Beiträge:
    16.702
    Ort:
    Düsseldorf
    Zustimmungen:
    867
    Kekse:
    36.410
    Erstellt: 18.07.07   #6
    Von ADAT hab ich ehrlioch gesagt auch kaum Ahnung :) Kann mir aber nicht vorstellen, dass man in beide Richtungen verbinden muss, macht für mich wenig Sinn.
     
  7. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 18.07.07   #7
    Naja ADAT ist ja nicht bidirektional...

    Also in meinem schlauen Büchlein ("Das digitale Tonstudio") steht dazu folgendes:

    Es wird also mit den Audiodaten zusammen eine Information übertragen, aus der der Empfänger den Takt des Senders erkennen kann [...] und sich dazu synchronisiert.


    Daraus interpretiere ich jetzt einfach: wenn das Firestudio als Master fungieren würde, wäre alles ok, weil es dann das Clock-Signal per ADAT mitschickt. Da es aber wohl Slave ist, kann es den Takt vom Master aber nicht bekommen, weil es keinen ADAT Input erhält.
     
  8. Ravine

    Ravine Threadersteller Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 20.07.07   #8
    Besten Dank für eure Antworten.

    Kfir hat zu 50% recht :).
    ADAT ist ein Signal das keine externe Clock benötigt um eine Synchronisation herzustellen. Es muss aber nicht im Closed Loop verbunden werden.

    Habe nun den Fehler entdeckt.
    Klingt komisch, aber beide Gerät müssen auf Interne Clock ( also Master ) stehen, auch das Firestudio. Dies ist allerdings nur nötig wenn man das Firestudio als Standalone Gerät braucht, bzw. nicht am Firewire angeschlossen hat. So hab ich nun einfach beide Geräte auf 16 Bit, 44.1Khz eingestellt und siehe da . . .keine Knackser mehr.

    Besten Dank für eure Unterstützung.
    LG Stephan
     
  9. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 21.07.07   #9
    Hm, also das will ich als Wahrheit so nicht ganz glauben...wenn zwei Geräte digital miteinader kommunizieren, ist eine Synchronisation unumgänglich. Und wenn beide Geräte auf Internal stehen, wird nix synchronisiert, sondern "jeder kocht seine eigene Suppe".

    Kommt mir jedenfalls sehr seltsam vor, auch wenns scheinbar funktioniert.
     
  10. Ravine

    Ravine Threadersteller Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 23.07.07   #10
    Was genau glaubst du denn nicht ganz :) ? Dass es jetzt funktioniert oder das ADAT nicht zwingend eine Synchronisation braucht ?
     
  11. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 24.07.07   #11
    Letzteres.

    Eine digitale Verbindung kann ohne definierte Synchronisationsverhältnisse eigentlich nicht funktionieren.

    Ich würde eher vermuten, dass sich eines der Geräte "geschlagen" gibt und eben beim Betrieb auf Slave umschaltet.
     
  12. Ravine

    Ravine Threadersteller Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 24.07.07   #12
    Sagt dir Full Duplex was ?
    Das ist ein Weg wie man zwei Geräte miteinander verbinden kann, ohne Synch, und es läuft trotzdem einwandfrei.

    Funktioniert allerdings nur bei selbsttaktenden Signalen, ADAT / SPDIF / AES EBU.

    Das Signal liefert gleichzeitig einen Code der vom Empfänger verstanden wird, auch ohne Word Clock, etc.

    D.h. der Empfänger weiss wann ein "Wort" anfängt und wann ein "Wort" aufhört.
    Somit können ohne Synch. Daten transportiert werden, ohne knackser etc.
    Lediglich die Samplingfrequenz und Bitrate müssen aufeinander angepasst werden.

    Klär mich bitte auf wenn ich mich total auf dem Holzweg befinde :)
     
  13. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 24.07.07   #13
    Also Full Duplex ist schlicht die Fähigkeit, Audio gleichzeitig wiedergeben und aufnehmen zu können. Wo du da jetzt hier den Zusammenhang herstellst, ist mir schleierhaft :confused:
    Full Duplex hat nämlich mit der Schnittstelle erst mal nix zu tun, das ist eher eine Soundkarten-interne Sache.

    Ja, ADAT&Co. sind selbstsynchronisierende Schnittstellen und schicken ihre Sync-Signal mit, und brauchen daher kein Wordclock. Aaaber, um sich synchronisieren zu können, muss einem Gerät ja gesagt werden, dass es sich auf das ADAT-Signal synchronisieren muss.
    Und wenn die Daten ohne Sync transportiert werden, kommt es in aller Regel zu Knacksern, Aussetzern und anderem unschönen Quatsch.

    Du sagst es doch selbst: der Code muss vom Empfänger verstanden werden. Wenn aber beide Geräte ihre jeweils interne Taktung verwenden, gibt es doch gar keinen Empfänger.
    Wenn die Synchronisation steht, muss man auch nicht bei beiden Geräten die Samplerate einstellen, der Slave schaltet dabei nämlich automatisch mit dem Master um.

    D.h. nach wie vor behaupte ich einfach mal locker ;), dass im Betrieb eines der beiden Geräte auf Slave schaltet.

    Es ist ja im Grunde auch egal, es funktioniert ja offenbar. Nur wenn beide Geräte auf Master stehen im Betrieb, widerspricht das jeglicher Logik bei digitalen Verbindungen.

    Anderer Gedanke: mit welcher Samplingrate hattest du denn davor gearbeitet (als es knackste)? ADAT kann in einer Leitung maximal acht Kanäle bei max. 48kHz übertragen. Aber ich denke mal das ist klar...?

    PS: Zur Thematik ADAT-Sync mit zwei Leitungen: im Manual meines DPS II Preamps (mit ADAT in/out) steht auch: wenn am ADAT in (!) ein Signal anliegt, kann er sich darauf takten.
    Also braucht es wohl durchaus auch eine Rückleitung, um das Sync-Signal per ADAT zu erhalten.
     
  14. Ravine

    Ravine Threadersteller Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 24.07.07   #14
    oops, was missverstanden :)

    Als es knackste hatte ich den Presonus auf Clock , also Slave, und den M-Audio auf Internal, also Master. Verbunden hatte ich beide via BNC Stecker im Closed Loop.
    Zusätzlich natürlich noch den ADAT vom Presonus zum M-Audio.
    Allerdings hat die Synchronisation nicht wirklich funktioniert. d.h es gab knackser und wenn ich beim M-Audio die Samplingfrequenz umschaltete, schaltete der Presonus nicht mit. . .Was er eigentlich ja hätte tun müssen.

    Die Meinung war eigentlich schon das ich den Presonus via WC an den M-Audio, den Master, synche, aber das gab ich mitlerweile auf . . .

    Oder hast du einen Fehler entdeckt bei der Synchronisation ?
    Falls ja, immer her damit :)

    Besten Dank !
     
  15. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 25.07.07   #15
    Na das kann ja nicht funktionieren!

    Die BNCs dienen nur für die Taktung per WordClock Generator, das ist aber ein weiteres externes Gerät! Den Takt kann man dann an den BNC-Buchsen bei den Geräten durchschleifen.
    Wordclock via Taktgenerator ist eben eine externe Sync, und keine selbstsynchronisierende Schnittstelle. Die verwendeten Geräte selber haben keinen eigenen WC-Generator.
    Du hattest also in deinem ursprünglichen Setup defakto keine funktionierende Synchronisation :o
    Wenn du nur per ADAT - und zwar in beide Richtungen - verkabelt hättest, dürfte alles ok gewesen sein.


    Ja, siehe oben :)

    Also nochmal zusammengefasst:
    Word Clock ist eine externe Taktung und erfolgt über extra WC-Generator (meist sehr teure Geräte). Verkabelung entweder sternförmig vom WC-Generator an alle "Konsumenten", oder eben an den BNC-Buchsen durchschleifen. Einstellung an den zu taktenden Geräten heißen dann meist "External", "WordClock" oder ähnlich.

    ADAT&Co. synchronisieren sich selbst, und dementsprechend ist auch keine weitere Verkabelung nötig. Wenn also wie in deinem Fall der Preamp via ADAT an das Interface gehängt wird, reicht die ADAT-Verkabelung (in beide Richtungen) aus. Der Preamp sollte dann am besten Slave sein, d.h. er taktet sich auf "ADAT".
    Das Interface dagegen bleibt als Master auf "Internal", also taktgebend.
    Und damit verhält sich dann der Slave auch korrekt, was Sampleratenwechsel vom Master etc. betrifft.
     
  16. Ravine

    Ravine Threadersteller Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 25.07.07   #16
    Ach so. . .Na klar, jetzt leuchtets ein. Wie peinlich . . .:(

    Also, das probier ich mal ; ADAT in beide Richtungen.
    Schreib dir dann obs klappt !

    Besten Dank :)
     
  17. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 25.07.07   #17
    Ich habe heute mal "Nägel mit Köpfen" gemacht und meinen ART Preamp mit zwei Toslink-Kabeln digital eingebunden. Und voila: tut einwandfrei. Die Sync steht ohne Mucken.

    Also nur Mut! ;)

    PS: Auch wenn ich mich frag, warum ich mir eigentlich extra für diesen Preamp vor drei Monaten (analoge) Kabel und Stecker gekauft hab...ja, hätte man sich doch gleich richtig schlau gemacht :o:rolleyes::(
     
  18. Ravine

    Ravine Threadersteller Registrierter Benutzer

    Im Board seit:
    17.07.07
    Zuletzt hier:
    12.07.11
    Beiträge:
    143
    Ort:
    Zürich
    Zustimmungen:
    1
    Kekse:
    582
    Erstellt: 26.07.07   #18
    Hab den Supporter meines Vertrauens gefragt wegen den ADAT Kabel. . .Natürlich hattest du recht :) Es müssen zwei Kabel, also hin und zurück , gelegt werden !

    Habe noch etwas neues gelernt; wenn du zwei Geräte via WC Synchst, solltest du diese nicht im Closed Loop, also nicht hin und zurück verhängen. Ha ha ha . . .Das hatte ich natürlich auch falsch. . .

    Glaube ich breche Ausbildung ab und wechsle zu Bäcker Konditor oder so. . .He he :)

    Andere Frage : Arbeitest Du per Zufall mit Pro Tools ?
    Falls ja, kennst du die Fehlermeldung "Access Violation" ?
    Seit ein paar Tagen kommt diese nämlich und blockiert mein Pro Tools m_powered komplett. Tolle Sache. . . .
     
  19. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 27.07.07   #19
    Ne, hab mit Pro Tools generell eher wenig Erfahrung. Als ich noch eine M-Audio Karte hatte, hab ich mal die M-Powered Demo probiert...aber keinen rechten Nutzen darin gesehen.


    Zu was lässt du dich denn ausbilden? :)

    Achja, mein Gott...ich hab das bis vor kurzem auch nicht wirklich sicher gewusst (siehe meine ersten Beiträge hier im Thread), auch wenn es im nachhinein absolut logisch ist.
     
  20. topo

    topo HCA Recording Ex-Moderator HCA

    Im Board seit:
    05.07.04
    Zuletzt hier:
    6.12.16
    Beiträge:
    8.063
    Ort:
    Frankfurt a.M.
    Zustimmungen:
    566
    Kekse:
    21.124
    Erstellt: 27.07.07   #20
    Ich fahre meinen Art Preamp nur mit nur einem Toslink-Kabel.
    Bisher haben alle Recordings damit geklappt.

    Mir ist nicht wirklich klar, warum ich ein zweites Kabel bräuchte:confused:


    Topo :cool:
     
Die Seite wird geladen...

mapping