Focusrite Scarlet 2i2, Probleme mit Latenz und Mono/Stereo

  • Ersteller Mr. NoName
  • Erstellt am
M

Mr. NoName

Registrierter Benutzer
Zuletzt hier
23.09.13
Registriert
11.01.08
Beiträge
699
Kekse
1.270
Ort
Frankfurt am Main
Hallo!

Bin totaler Recording-Newbie habe mir paar Dinge zum Homerecording (hauptsächlich E-Gitarre) gekauft, unter Anderem das Focusrite Scarlet 2i2 Interface, welches mir ein paar Probleme bereitet.

Zunächst einmal ist die Latenz recht hoch, momentan ist es auf 24 bit bei 44100 Hz (geht glaube ich bis 96kHz bei dem Gerät) eingestellt und auf 7 bzw 8 x 1024 Samples, wodurch sich eine errechnete Latenz von 185 ms ergibt. Ich finde das ist ziemlich hoch, denn das Signal kommt deutlich zeitversetzt auf die Kopfhörer bzw. Monitore. Natürlich hat das Ding eine option zum direkten abhören (direct monitoring), trotzdem frage ich mich ob man das nicht noch verbessern könnte und wenn ja, wie?
Als Betriebssystem läuft Windows Vista in der 64 bit Version und als DAW probiere ich mometan mal Reaper aus.

Dann wäre ich auch schon beim zweiten Problem: Wenn ich etwas aufnehme, ist es in der Wiedergabe nur in mono und nur auf dem linken Kanal. Beim abhören ist alles in Butter (nutze AKG Studiokopfhörer, funktioniert bestens, also es ist nicht defekt), es kommt auf beiden Kanälen bzw. auf die, auf die ich das Signal gelegt habe.
Als Mikrofon habe ich momentan nur ein SM57, aber daran liegt es ja wohl nicht.
Wenn ich jetzt versuche in Stereo aufzunehmen, nimmt er nur links auf. Wenn ich versuche in mono auf dem RECHTEN Kanal aufzunehmen, nimmt er nichts auf, obwohl das Mikrofon auf jeden Fall ein Signal vernimmt (sehe ich am Lämpchen vom Interface). In der DAW hingegen nimmt er gar nichts wahr oder auf.
Auf dem linken Mono-Kanal funktioniert es bestens
Das verwirrt mich extrem, woran könnte das liegen? Das verstellen des Pan-Reglers ändert auch nichts an der Situation.

Hoffe Ihr könnt mir da weiterhelfen und bedanken tue ich mich im Vorraus. :great:

Mit freundlichen Grüßen, NoName
 
Vill-Harmonix

Vill-Harmonix

HCA Logic
HCA
HFU
Zuletzt hier
04.05.21
Registriert
18.04.09
Beiträge
2.476
Kekse
11.927
Ort
Sankt Wendel
Zum zweiten Problem:

Du verwendest in Reaper eine Stereospur. Die Musst Du auf Mono umschalten - denn Dein Mikrofon ist ja auch Mono. Nach der Aufnahme kannst Du dann per Panorama-Regler das Signal da positionieren, wo Du willst.
Bei einer Stereospur gibt es übrigens meistens keinen Panoramaregler sondern einen Balance-Regler, der das Verhältnis von Rechtem und Linkem Signal festlegt. Wenn rechts nichts ist (bei Dir ist ja am Eingang 2 keine Klangquelle angeschlossen) bringt ein drehen des Reglers nach rechts nur Stille.

Zum Ersten Problem:
Regle die Latenz runter. Wie unter Windows die Einstellmöglichkeiten sind, entnimmst Du dem Handbuch - evtl. muss man das auch in Reaper machen.

Clemens
 
M

Mr. NoName

Registrierter Benutzer
Zuletzt hier
23.09.13
Registriert
11.01.08
Beiträge
699
Kekse
1.270
Ort
Frankfurt am Main
Zum zweiten Problem:

Du verwendest in Reaper eine Stereospur. Die Musst Du auf Mono umschalten - denn Dein Mikrofon ist ja auch Mono. Nach der Aufnahme kannst Du dann per Panorama-Regler das Signal da positionieren, wo Du willst.
Bei einer Stereospur gibt es übrigens meistens keinen Panoramaregler sondern einen Balance-Regler, der das Verhältnis von Rechtem und Linkem Signal festlegt. Wenn rechts nichts ist (bei Dir ist ja am Eingang 2 keine Klangquelle angeschlossen) bringt ein drehen des Reglers nach rechts nur Stille.

Zum Ersten Problem:
Regle die Latenz runter. Wie unter Windows die Einstellmöglichkeiten sind, entnimmst Du dem Handbuch - evtl. muss man das auch in Reaper machen.

Clemens

Hallo, danke für die zügige Antwort!

Ich habe es sowohl mit einer Stereo als auch Monospur versucht und wie gesagt, in beiden Fällen wird nur links aufgenommen und links wiedergegeben. Dann habe ich natürlich versucht, per Pan(orama) Regler das Signal der Monospur auf die rechte Seite zu setzen: Geht nicht. Kommt immer noch kein Sound rechts. Und die Kopfhörer funktionieren einwandfrei, wenn ich das 'Direct Monitoring' vom Focusrite anstelle, dann höre ich auf beiden Ohren etwas. Auch wenn ich Musik anschalte und es mit den Kopfhörern höre gibt es auch kein Problem.
Darum bin ich ja so verwirrt. :/

Und das mit der Latenz runter regeln habe ich ebenfalls versucht, aber alles unter 8 x 1024 Samples in Reaper (also unter 180 ms) hört sich schrecklich an, es knackst nur noch etc.
Die Treiber habe ich auch von der Focusrite Homepage, sollten also aktuell sein. Der Rechner sollte auch nicht das Problem sein, habe einen ~ 3 Ghz Dual Core CPU und 8 GB Ram (weder besonders toll, noch besonders schlecht also)

Mit freundlichen Grüßen, NoName
 
Vill-Harmonix

Vill-Harmonix

HCA Logic
HCA
HFU
Zuletzt hier
04.05.21
Registriert
18.04.09
Beiträge
2.476
Kekse
11.927
Ort
Sankt Wendel
Ich habe es sowohl mit einer Stereo als auch Monospur versucht ...
Dann hast Du bei der Monospur irgendeinen Einstellungs/Bedien-Fehler.

Versuche es nochmal in einem neuen, leeren Projekt.
Eine echte(!) Monospur funktioniert nie "nur Rechts" wenn gleichzeitig eine Stereospur ("Musik") beidseitig abgespielt wird. Dann funktioniert eine Monospur genau da, wo sie mit dem Pan-Regler hingedreht wird.

Zur Latenz kann ich nix sagen (Mac-User) ausser dass mir dieser Wert sehr seltsam vorkommt - das hat auch nix mit Rechner oder Interface zu tun - höchstens mit der Konfiguration.


Clemens
 
L

lunarr

Registrierter Benutzer
Zuletzt hier
01.05.16
Registriert
30.01.11
Beiträge
50
Kekse
63
Ort
Kiel
EDIT2: Schade, das 2i2 hat die MixControl Software scheinbar nicht, das macht den gesamten ersten Block Text überflüssig. Was mich dann aber interessieren würde: Wenn du deine Monospur aufgenommen hast und mit 0 Pan abspielst, wie wird das in Reapers Mixer angezeigt? Gibt es einen Ausschlag auf beiden Seiten des Masters oder nur auf einer? Und auch jetzt wieder nur zur Sicherheit hab ich mal nen Screenshot gemacht. Wenn du Stereo respektive "rechts" Mono (ich nehme mal an du meinst den rechten Eingang am Interface damit) aufnimmst haste in diesem kleinen Menü in der Spur da auch Stereo -> Mic1/Mic2 oder (für rechts) Mono -> Mic2 ausgewählt, gell?

reaper.png

Zur Latenz, vielleicht sogar zu beidem: Die Scarlett Suite von der Website respektive der CD hast du installiert oder? Wenn ja bitte schließe Reaper und Konsorten und mach mal die Scarlett MixControl auf. Dort entkoppelst du zunächst mal Eingang eins und zwei, indem du die beiden übereinandergelegten Kreise (über dem M-Button) anklickst. dieser sollte nun nicht mehr blau sein. Wenn das noch nicht getan war könnten wir die Lösung für das Panning-Problem haben. Dann kannst du, sofern gewollt, die Samplerate (da wo rot 44.1KHz steht) hochstellen, muss aber nicht sein. Wichtig ist, dass 'n Stück da drunter (ganz unten) "Settings" steht. Draufklicken, Buffer Size auf 2, 3 oder 4 ms stellen (kannst danach mal n bisschen was auf Youtube hören. Wenns knackst oder abbricht höher stellen). Dann Reaper auf, Monospur aufnehmen und hoffentlich glücklich sein. =)

EDIT: Außerdem hab ich gerade nochmal in Reaper geprüft. Da klickst (sofern du die neue hast) auf Options -> Preferences. Im dann geöffneten Fenster solltest du automatisch auf "Devices" sein. Rechts stellst du dann bei Audio System "ASIO" ein, bei ASIO Driver "Focusrite USB 2.0 Audio Driver" sofern das noch nicht getan ist. Alle anderen Einstellungen sollten eigentlich automatisch richtig sein, aber zur Sicherheit: Die Checkboxen "request sample rate" und "request block size" sollten nicht aktiviert sein. Das trifft auch auf alle anderen (außer natürlich "Enable Inputs") zu. Apply drücken nicht vergessen. Danach kannst du sicherheitshalber außerdem mal auf ASIO Configuration drücken und gucken, ob sich die Sample Rate und die Buffer Length mit den in der MixSuite eingestellten Werten decken. Sollte der Fall sein. Wenn nicht... Keine Ahnung. Dann würd ich mal die ganzen Treiber und Reaper deinstallieren und dann in logischer Reihenfolge (erst Treiber, dann Reaper) wieder installieren. Cheers!
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: 2 Benutzer
M

Mr. NoName

Registrierter Benutzer
Zuletzt hier
23.09.13
Registriert
11.01.08
Beiträge
699
Kekse
1.270
Ort
Frankfurt am Main
Erstmal vielen, vielen Dank für die Antworten!

Konnte heute wieder dran rumwerkeln und habe es innerhalb von ein paar Minuten, vor Allem dank des Beitrages von lunarr, gelöst. Und zwar beide Probleme wie es scheint.
Ich Idiot hatte natürlich nicht 'ASIO' ausgewählt, sondern 'WaveOut' (bzw. das war bei Reaper schon so eingestellt). :bang:

Mit freundlichen Grüßen, NoName
 

Ähnliche Themen

Neue Themen

Unser weiteres Online-Angebot:
Bassic.de · Deejayforum.de · Sequencer.de · Clavio.de · Recording.de

Musiker-Board Logo
Oben