GM Midi Files mit Cubase SE

von Tax-5, 31.12.04.

  1. Tax-5

    Tax-5 Registrierter Benutzer

    Im Board seit:
    11.09.03
    Zuletzt hier:
    21.03.15
    Beiträge:
    1.075
    Ort:
    Rünenberg
    Zustimmungen:
    13
    Kekse:
    138
    Erstellt: 31.12.04   #1
    Wollte mal ein paar GM Midi Files mit Cubase SE machen.
    Klappte alles ganz wunderbar bis zum Export.

    Nach dem exportieren waren alle Stimmen mit dem Piano (erste GM Stimme) belegt.

    Das gleiche Problem habe ich mit Logic (Fun).

    Wie kann ich das beheben ? Möchte schon gerne Chor usw... hören..
     
  2. Tax-5

    Tax-5 Threadersteller Registrierter Benutzer

    Im Board seit:
    11.09.03
    Zuletzt hier:
    21.03.15
    Beiträge:
    1.075
    Ort:
    Rünenberg
    Zustimmungen:
    13
    Kekse:
    138
  3. .Jens

    .Jens Mod Emeritus Ex-Moderator HCA

    Im Board seit:
    18.08.03
    Zuletzt hier:
    3.12.16
    Beiträge:
    10.615
    Ort:
    Hamburg
    Zustimmungen:
    1.926
    Kekse:
    23.787
    Erstellt: 27.01.05   #3
    Als welchen Filetyp (Typ 0/Typ1) hast du es denn exportiert, und vor allem, womit hinterher wieder angehört?
    Ohne weitere Angaben ist es numal schwer, den Fehler zu finden.

    Also konkreter werden, bitte: wie war das Prjojekt aufgebaut (jeder Kanal eine eigene Spur, alles in einer Spur? Welcher Klangerzeuger, wie exportiert, usw...)

    Jens
     
  4. Tax-5

    Tax-5 Threadersteller Registrierter Benutzer

    Im Board seit:
    11.09.03
    Zuletzt hier:
    21.03.15
    Beiträge:
    1.075
    Ort:
    Rünenberg
    Zustimmungen:
    13
    Kekse:
    138
    Erstellt: 27.01.05   #4
    Ich habe es zum Test mit beiden Formaten (1 und 0) versucht.
    Angehört habe ich das MIDI File nacher im Media Player auf verschiedenen PC's. Noch diverse andere Player.

    Also um noch konkreter zu werden:

    Ich wollte einen Track im Midi Format machen um diesen später als Hintergrundmusik auf einer HP zu verwenden.
    Der Track enthält 5 Spuren:

    Kanal 1 - Synth Bass 1
    Kanal 2 - Saw Tooth
    Kanal 3 - Choir Pad
    Kanal 10 - Analog Kit
    Kanal 11 - Electronic Kit

    Solange ich im Programm die Sounds eingestellt habe klingt alles so wie es soll. Nacher als MIDI File sind allen Kanälen das Piano (Program 001) zugewiesen.

    Exportiert habe ich folgendermassen:
    Nachdem ich Spur für Spur arrangiert habe, habe ich die Marker gesetzt (Links, rechts) und auf im Menüpunkt "Exportieren" "als MIDI File" gewählt. Dann den Typ ausgewählt und voila.

    Beides habe ich mit Logic Fun und Cubase SE ausprobiert.

    Da wäre am Rand noch zu erwähnen dass wenn ich den Song im Programm wieder lade die gleiche Instrumenten Nummer wieder vorhanden ist. Es erklingt trotzdem nur ein Piano. Ich muss den Klang also nochmals laden.
     
  5. .Jens

    .Jens Mod Emeritus Ex-Moderator HCA

    Im Board seit:
    18.08.03
    Zuletzt hier:
    3.12.16
    Beiträge:
    10.615
    Ort:
    Hamburg
    Zustimmungen:
    1.926
    Kekse:
    23.787
    Erstellt: 27.01.05   #5
    und welches VST-Instrument o.ä. hast du jeweils in Logic und Cubase benutzt?

    Zur (vermutlichen) Lösung deines Problems:
    [​IMG]
    Dort müssen nicht nur die Kanäle richtig eingetragen sein, sondern auch Bank und Program (im Bild beide auf "off", also wird diese Information nicht gespeichert bzw. übertragen).
    Welche Bank/Programmnummer das ist (für GM) müsstest du nachsehen, das kann man aber am GM-Instrument ablesen oder sich eine Liste ergooglen (-> Fleissarbeit für dich ;) )

    Jens
     
  6. Tax-5

    Tax-5 Threadersteller Registrierter Benutzer

    Im Board seit:
    11.09.03
    Zuletzt hier:
    21.03.15
    Beiträge:
    1.075
    Ort:
    Rünenberg
    Zustimmungen:
    13
    Kekse:
    138
    Erstellt: 27.01.05   #6
    Ich habe gar kein VST benutzt.. Die Program Nummer hatte ich schon eingestellt. War (k)ein Problem.. Das mit der Bank könnte das Problem sein.. Ich teste es mal und gebe Bescheid.
     
  7. Tax-5

    Tax-5 Threadersteller Registrierter Benutzer

    Im Board seit:
    11.09.03
    Zuletzt hier:
    21.03.15
    Beiträge:
    1.075
    Ort:
    Rünenberg
    Zustimmungen:
    13
    Kekse:
    138
    Erstellt: 27.01.05   #7
    Es ist zum verzweifeln. Es kann ja nicht sein dass auf jeder Bank das gleiche passiert.
    Ich habe Drums (das falsche Drum Kit) und immer noch nur Piano Sounds.
     
  8. Hans_3

    Hans_3 High Competence Award HCA

    Im Board seit:
    09.11.03
    Beiträge:
    16.142
    Zustimmungen:
    1.119
    Kekse:
    49.592
    Erstellt: 27.01.05   #8
    Die Informationen für die Instrumente müssen auf jeden Fall mit in die jeweilige Spur, damit sie von einem fremden Wiedergabeprogramm gelesen werden können.

    Das macht Cubase - glaube ich - aber nicht automatisch, da man ja sonst andersum nicht die Wahl hätte, eine MID-Datei ohne GM zu erzeugen.

    Beim "alten" Cubase VST erscheint beim Midi-Exportieren ein Dialogfenster, in dem "Part-Parameter" angeklickt sein sollte = alle im Inspector eingestellten Parameter eines Parts werden zusammem mit den Spuren exportiert. Das sollte beim SE nicht viel anders sein. Vielleicht ist das ja die Lösung.
     
  9. Tax-5

    Tax-5 Threadersteller Registrierter Benutzer

    Im Board seit:
    11.09.03
    Zuletzt hier:
    21.03.15
    Beiträge:
    1.075
    Ort:
    Rünenberg
    Zustimmungen:
    13
    Kekse:
    138
    Erstellt: 27.01.05   #9
    ALso bei Logic erscheint das nicht.
    Ich werde morgen mal schauen ob das so ist ob da ein Dialog kommt. Ich werde mich nochmals melden.
    Danke für die Hilfe schon mal. :great:
     
  10. Tax-5

    Tax-5 Threadersteller Registrierter Benutzer

    Im Board seit:
    11.09.03
    Zuletzt hier:
    21.03.15
    Beiträge:
    1.075
    Ort:
    Rünenberg
    Zustimmungen:
    13
    Kekse:
    138
    Erstellt: 03.02.05   #10
    Also da war kein Dialog o.Ä. bei dem ich irgendwelche Parameter hätte festlegen können.

    Konnte nur zwischen Typ 0 und Typ 1 wählen.

    PS: Habe ich schon erwähnt dass ich mit Cubase SE arbeite ?
     
Die Seite wird geladen...

mapping