Keyboard - Ton bleibt "stecken" (keine note off-Meldung)

von Max_Piano, 03.09.10.

Sponsored by
Casio
  1. Max_Piano

    Max_Piano Registrierter Benutzer

    Im Board seit:
    03.06.08
    Zuletzt hier:
    30.08.16
    Beiträge:
    14
    Ort:
    RP
    Kekse:
    10
    Erstellt: 03.09.10   #1
    Hallo Leute,

    zuerst, mit welchem Equipment spiele ich:
    Ich habe drei Keyboards, ein Doepfer Stagepiano und zwei Miditech Masterkeyboards. Diese werden über MIDI an ein Audiointerface und weiter via USB an Laptop mit Logic Pro 7 geschickt.
    Playback (Drum, Bass) wird als Audiofile geschickt und die Synthi-Linien spiele ich direkt (also alles via Logic Pro). Dann kommt noch E-Guitar, Gesang dazu, aber das hat jetzt mit meinem Problem nix zu tun.

    Folgendes Problem tritt zeitweise bei mir auf:
    Ich spiele auf dem Keyboard und plötzlich hört ein Ton nicht mehr auf zu klingen. Der einzelne Ton spielt dann ewig weiter und ich muss Logic stoppen und wieder neu starten, damit es aufhört.

    Meine Erklärung ist, dass der Note off-Befehl nicht geschickt bzw. nicht verarbeitet wird, was meint ihr? Kann das sein oder gibt es dafür auch andere Ursachen? Interessanterweise ist mir das nur bei den Miditech-Keyboards passiert.
    Habt ihr einen Tipp wo hier der Hund begraben liegt? Liegts an den Miditech... sind ja keine teuren Teile gewesen oder am Laptop bzw. der Software?

    Woran kann das liegen?
    Kennt ihr das Problem und wenn ja, wie kann man es lösen??
    Was mache ich, wenn mir das live auf der Bühne passiert? (bis jetzt wars nur im Proberaum, weil wir erst ein paar Gigs hatten... war scheinbar nur Glück)

    Ich danke euch für eure Hilfe!

    Greets
    Mark
     
  2. Mathes(csp-band)

    Mathes(csp-band) Registrierter Benutzer

    Im Board seit:
    19.03.06
    Zuletzt hier:
    6.09.10
    Beiträge:
    222
    Ort:
    Lübeck
    Kekse:
    10
    Erstellt: 03.09.10   #2
    Hallo,
    im Grunde stelle ich in meinem Thread auch das gleiche Problem...
    Hoffe, dass einer eine Lösung kennt.

    Kommt nur beim Miditech vor, nicht aber bei meinem E-MU Keyboard.

    Liegt es evtl. an unausgereifter USB-Technik beim Miditech oder um fehlerhafte Treiber?
     
  3. Max_Piano

    Max_Piano Threadersteller Registrierter Benutzer

    Im Board seit:
    03.06.08
    Zuletzt hier:
    30.08.16
    Beiträge:
    14
    Ort:
    RP
    Kekse:
    10
    Erstellt: 03.09.10   #3
    Hm, wenn es bei dir auch nur beim Miditech vorkommt, könnte dort wirklich die Lösung liegen.
    Seltsam, denn ich frage mich, was man mit popeligen Note on/Note off Sends viel verkehrt machen kann.... so als Keyboard.... :D

    Gibt es eigentlich eine Art Fusstaster, den man zwischenschalten kann und der schlicht einfach wie eine "Panic-Taste" fungiert?
    Ich denke mir, wenn man kurz mal ausschaltet und sofort wieder an, dann könnte das ganze auch behoben sein... wenn man es schnell macht, kriegts niemand mit.
     
  4. HaraldS

    HaraldS Mod Emeritus Ex-Moderator

    Im Board seit:
    03.03.05
    Zuletzt hier:
    21.09.20
    Beiträge:
    4.953
    Ort:
    Recklinghausen
    Kekse:
    30.018
    Erstellt: 05.09.10   #4
    Naja, bisher vermutest du ja nur, daß es am Keyboard liegt. Ich würde eher vermuten, daß es zu 99% nicht am Keyboard liegt, eben genau weil dort kaum was falschzumachen ist. Viel eher kann es sein, daß die von dir verwendete Software die Note-offs nicht richtig umsetzt.

    Um das rauszukriegen kannst du am einfachsten beim Spielen alle Daten aufnehmen. Wenn ein Notenhänger vorkommt, schau dir genau die Daten an und schau nach, ob die empfangenen Daten mit dem übereinstimmen, was du gespielt hast.

    Besser, weil objektiver, geht es noch mit MIDIOX und MIDIYOKE. Leite mit MIDIYOKE alle Daten durch MIDIOX hindurch zu Logic und schau im Monitorfenster, ob alle Note-offs korrekt gesendet wurden.

    AFAIK kannst du den MIDI Solutions Event Processor (evtl. auch den Event Processor Plus) so programmieren, daß er einen All Notes Off-Befehl sendet. Das ist aber teuer und aufwändig.

    Harald
     
Die Seite wird geladen...

mapping