Triton: Program Change

von Thommes, 10.07.08.

  1. Thommes

    Thommes Registrierter Benutzer

    Im Board seit:
    10.11.07
    Zuletzt hier:
    23.03.13
    Beiträge:
    32
    Ort:
    Kaiserslautern
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 10.07.08   #1
    Hi,

    ich benutze ein Korg Triton Classic als Masterkeyboard für mein Setup und habe das Problem, dass ich beim Aufrufen von einer Combi Program Change Daten gesendet werden, aber keine Volume Werte dazu, bzw beide zu schnell hintereinaner.

    Angesteuert wird ein MP4 und ein NEII. Beim MP4 hab ich das noch nicht testen können, aber bei meinem Electro funktioniert das so nicht, bzw ich müsste die Combi 2 mal hintereinander aufrufen, dann gehts - die Volume Werte werden also nicht gefiltert oder sowas.

    Gibts da irgendwelche Möglichkeiten das zu umgehen?

    Thommes
     
  2. TritonFreak

    TritonFreak Registrierter Benutzer

    Im Board seit:
    20.12.05
    Zuletzt hier:
    14.10.16
    Beiträge:
    835
    Ort:
    Wuppertal
    Zustimmungen:
    1
    Kekse:
    868
    Erstellt: 10.07.08   #2
    Hi,

    komisch, das Problem hatte ich noch nie .... :confused:
    Mir kommt das sehr komisch vor. Midi-Daten gehen eigentlich so schnell durch die Leitung, dass solche Befehle eigentlich nicht verschluckt werden sollten ...
    reagieren MP4 und NEII auf Volume-Send wenn du das über den Fader im Display "live" veränderst ??


    ich würde folgende Möglichkeiten prüfen/checken und damit mal etwas rumprobieren:
    - Sind die Timbres innerhalb der Combi die NEII und MP4 umschalten sollen auf "EX2" oder "EXT" ?
    - ist in den Midi-Parametern bei den entsprechenden Timbres "Other Control Change" auf "enable" und/oder evtl. andere Midi-Befehle nicht angeschaltet ...??

    im Global-Modus würde ich vielleicht mal folgendes ausprobrieren:
    enable exclusive -> off
    enable Combination + evtl. BankChange -> off

    Bank-Mode mal zwischen Korg und GM umschalten, mal schauen was dann passiert ...

    mehr fällt mir jetzt spontan nicht ein .... vielleicht kommt mir ja nochmal ne Idee wenn ich meinen Silberbarren wieder hier stehen habe ...

    wenn gar nichts von dem geht, würde ich die Sounds auf den externen Geräten direkt so programmieren dass ein Volume-Send gar nicht mehr nötig wäre ...
    oder evtl. die Programmierung und die Changes über einen Miditemp machen ....
    Das klappt in jedem Fall, wäre dann allerdings wieder mit Kosten und Aufwand verbunden.

    Vielleicht haben dg-keys oder tax-5 als Triton-User noch ne Idee ???? evtl. richy ... abgeleitet vom LE und X50 .....

    Grooves,

    Mig
     
  3. Thommes

    Thommes Threadersteller Registrierter Benutzer

    Im Board seit:
    10.11.07
    Zuletzt hier:
    23.03.13
    Beiträge:
    32
    Ort:
    Kaiserslautern
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 10.07.08   #3
    Die Sachen hab ich alle schon ausprobiert - hat nicht geholfen.
    Es kann natürlich sein, dass es am Electro liegt. Am MP4 kann ich es zur Zeit nicht ausprobieren (erst am Mittwoch wieder).

    Im globalen Midi Filter sind nur Program Change und Control Change aktiviert - in den Combis filtere ich normalerweise nichts (es sei denn ich brauch einen Controller nur auf einem Midi Kanal, etc.)
    Die Timbres stehen auf EXT und schalten ja auch die Programme richtig um, nur die Lautstärke wird nicht mitgesendet.
    Wahrscheinlich ist es irgendeine kleine Einstellungssache die ich übersehe.

    edit: Wenn ich die Lautstärke der Timbre "live" veränder, dann funktionierts.
     
  4. HaraldS

    HaraldS Mod Emeritus Ex-Moderator

    Im Board seit:
    03.03.05
    Zuletzt hier:
    10.04.14
    Beiträge:
    4.890
    Ort:
    Recklinghausen
    Zustimmungen:
    750
    Kekse:
    29.296
    Erstellt: 11.07.08   #4
    Es gibt ja immer wieder Geräte, die nach einem Soundwechsel ein paar Millisekunden zur benötigen, bevor sie andere Daten sinnvoll verarbeiten können - der Triton nach einem Moduswechsel ist selbst so ein Beispiel. Vielleicht arbeitet der NE genauso. Ich würde mal mit einem Sequenzerprogramm die Program-Change- und Volume-Daten senden und dabei ausprobieren, welchen zeitlichen Abstand die Daten brauchen, um vom NE korrekt verarbeitet zu werden. Außerdem kannst du prüfen, in welchem zeitlichen Abstand der Triton diese gleichen Daten sendet.

    Dadurch hast du noch keine Lösung des Problems, aber zumindest kannst du den Fehler daraufhin eingrenzen, ob es am Timing bzw. der Verarbeitungsgeschwindigkeit liegt. Wenn das der Fall sein sollte, hilft nur das Erstellen eigener Sequenzen, die die Program-Change- und Volume-Daten im richtigen Abstand senden. Allerdings ist das extrem umständlich zu handhaben, aber ohne Zusatzequipment die einzige Lösung.

    Harald
     
  5. Martman

    Martman Registrierter Benutzer

    Im Board seit:
    14.09.05
    Zuletzt hier:
    6.12.16
    Beiträge:
    4.009
    Ort:
    Hamburg
    Zustimmungen:
    926
    Kekse:
    16.450
    Erstellt: 11.07.08   #5
    Moment mal, das könnte eine Lösung sein.

    Frage an die Triton-Benutzer: Kann man per RPPR auch Program Change u. ä. abfeuern? Gut, man müßte jedes Mal RPPR aktivieren, aber vielleicht wär das eine Lösung, und in der Reihenfolge der Songs wär man auch flexibler.


    Martman
     
  6. TritonFreak

    TritonFreak Registrierter Benutzer

    Im Board seit:
    20.12.05
    Zuletzt hier:
    14.10.16
    Beiträge:
    835
    Ort:
    Wuppertal
    Zustimmungen:
    1
    Kekse:
    868
    Erstellt: 12.07.08   #6
    geniale Idee .... :great:

    hab's gerade mal ausprobiert. ist zwar etwas frickelig zu programmieren aber: es geht ...
    das eröffnet mir völlig neue Möglichkeiten ...

    einfach per Step-Recording eine "normale Note" einfügen und dann über den Event-Edit aus der Note einen Controller-Befehl mit Bank und ProgrammChange machen. dann per "insert" (im event-edit) eine neue note einfügen, ein paar Ticks nach hinten verschieben und daraus einen Volumen-Befehl basteln.

    geile Sache ... :)
    ob das allerdings die sinnvolle Lösung für Thommes Problem ist, sei jetzt mal dahingestellt :o

    Haken an der Sache:
    man ist immer im Sequenzer-Modus unterwegs, muss dementsprechend immer alles auf Diskette oder SCSI-Laufwerk abspeichern UND was bei gerade bei der Nutzung von externen Klangerzeugern ärgerlich sein wird: man hat keine Möglichkeit interne und externe Midi-Zonen zu mischen. Heißt: man hat die Tastatur entweder "intern" und dann auch gerne gesplittet und gelayert bis der Azrt kommt oder halt nur "extern". Beides parallel geht nicht ! Jedenfalls hab ich bisher noch nicht herausgefunden wie ...

    Grooves,

    Mig
     
  7. Thommes

    Thommes Threadersteller Registrierter Benutzer

    Im Board seit:
    10.11.07
    Zuletzt hier:
    23.03.13
    Beiträge:
    32
    Ort:
    Kaiserslautern
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 12.07.08   #7
    Danke für eure Vorschläge.

    Live bin ich immer im Combi-Modus unterwegs und habe mich auch noch nicht näher mit dem Sequencer beschäftigt.
    Falls man so keine Internen und externen Zonen mischen kann, fällt das eher weg für mich.

    Aber das ganze liegt am Electro - ich habe mir heute mittag ein Midi-Interface besorgt (wurde eh mal Zeit) und ein wenig mit Midi-OX und Cubase rumgespielt.

    Der Triton sendet PC und CC direkt hintereinander (~1ms), sende ich das ganze mit Cubase funktionierts beim Triton (Übernimmt die vorgegebene Lautstärke), der Electro braucht ca. 60ms Abstand zwischen den Daten.

    Kann man denn bei einer Miditemp Matrix eine kleine Verzögerung einstellen oder gibts da evtl noch andere Lösungen?

    Thommes
     
  8. Thommes

    Thommes Threadersteller Registrierter Benutzer

    Im Board seit:
    10.11.07
    Zuletzt hier:
    23.03.13
    Beiträge:
    32
    Ort:
    Kaiserslautern
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 16.07.08   #8
    Habs heute am MP4 getestet, da klappts auch.
     
  9. Thommes

    Thommes Threadersteller Registrierter Benutzer

    Im Board seit:
    10.11.07
    Zuletzt hier:
    23.03.13
    Beiträge:
    32
    Ort:
    Kaiserslautern
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 05.08.08   #9
    Hi,

    ich wollte den Thread nochmal ausgraben und fragen, ob man mit ner Miditemp Matrix eine Verzögerung zwischen ProgChange und VolumeChange einprogrammieren kann?

    Falls das nicht klappt muss ich halt einfach die Volume Werte im NE fest abspeichern.

    Btw, weiss jemand zufällig, ob man beim MP4 per SysEx die Setup Bänke umschalten kann und obs nen Editor für den PC gibt - wollte nicht extra nen neuen Thread eröffnen...

    Gruß
    Thommes
     
  10. TritonFreak

    TritonFreak Registrierter Benutzer

    Im Board seit:
    20.12.05
    Zuletzt hier:
    14.10.16
    Beiträge:
    835
    Ort:
    Wuppertal
    Zustimmungen:
    1
    Kekse:
    868
    Erstellt: 05.08.08   #10
    Hi !

    Ich denke, dass es mit einem normalen Matrix-SetUp nicht geht.
    Über den Umweg über einen Song müsste das aber gehen. Du programmierst zwei SetUps. Einen mit den PrgChanges und einen zweiten mit den VolumeChanges und sagst im dazugehörigem Song erst SetUp 1 und dann SetUp 2.

    Alternativ: mit den sogenannten Jobs arbeiten die du per Fusstaster weiterschaltest. Du kannst Jobs ja klar definieren, dass per Foot-Switch ein x-beliebiges SetUp angewählt wird.

    Hab das selbst noch nicht genutzt, kann daher nicht sagen wie frickelig das Prozedere bei der Programmierung ist. Bei den aktuelleren Matrizen ( :screwy: :cool: ) kann man das aber sicherlich über die dazugehörige Software oder Fernbedienung programmieren.


    Grooves,

    Mig
     
  11. pauly

    pauly Registrierter Benutzer

    Im Board seit:
    14.10.03
    Zuletzt hier:
    8.12.16
    Beiträge:
    205
    Ort:
    LImburg
    Zustimmungen:
    11
    Kekse:
    154
    Erstellt: 05.08.08   #11
    Auch hi,

    hatte das gleiche Problem bei meinem Motif. Wenn man in einen anderen Modus schaltet, z.B. von Voice in Performance Modus, dann benötigt man CC Befehle und dann Programm Change. Das Umschalten in einen anderen Modus per CC dauert immer einige ms, Daher wurde der PChange dann verschluckt.

    Ich habe einen Miditemp. Da kann man dann beleibige Zeitintervalle zwischen den Befehlen einprogrammieren. Seit da klappt es immer. Ich steuere damit meine Keyboards, Expander, Gitarrenpods, Voiceworks etc. von einer Stelle aus und jedes Bandmitglied hat dann seine einstellungen parat.
     
Die Seite wird geladen...

mapping