Verzögerung/Latency Probleme mit GR5 / UMC22 trotz ASIO4ALL

M

MarSel

Registrierter Benutzer
Zuletzt hier
24.09.19
Registriert
19.07.19
Beiträge
6
Kekse
0
Hallo Zusammen,

ich habe schon mehrfach gesucht, nicht nur in diesem Forum - kann mein Problem aber leider nicht lösen.

Problem:
Ich bekomme die Einstellung nicht hin, dass ich keine Verzögerung beim Gitarre spielen über das Interface habe.
Egal was ich an den Settings mache, wird der Sound immer verzögert wieder gegeben.

Mein SetUp:
Interface: Behringer U-Phoria UMC22
Treiber: ASIO4ALL
Programm: Guitare Rig 5
Input (am Interface): E-Gitarre
Output (am Interface): Samsung Soundbar (Über Aux Kabel mit Adapter (Audio Adapter 6,35mm Klinkenstecker auf 3,5mm Klinken Buchse angeschlossen)
Einstellungen ASIO4ALL: siehe Screenshot
Wenn ich niedriger als 256 Samples gehe, oder die Sample Rate erhöhe, bekomme ich nur noch abgehakten Ton (CPU stellt sich off/on im wechsel)
Ich habe auch ein bisschen versucht, an der Latency Compensation & den Options rumzuspielen, jedoch ohne Erfolg.

upload_2019-7-19_19-29-36.png



Kann mir jemand helfen?
Sind noch weitere Informationen nötig?

Viele Grüße und vielen Dank im vorraus :)
 
Signalschwarz

Signalschwarz

Registrierter Benutzer
Zuletzt hier
13.05.21
Registriert
19.02.11
Beiträge
10.567
Kekse
21.801
Du hast schon die richtige und die einzige für die Audio-Hardware relevante Einstellung gefunden. Und wenn sich über diese die Latenz nicht reduzieren lässt, ohne dass der Rechner überfordert ist (die CPU schaltet nicht on/off, das Gesamtsystem ist schlichtweg überfordert) und es zu Aussetzern kommt, dann ist das eben so, an diesem Problem lässt sich so direkt nichts lösen.

Was Du machen kannst ist, die Einstellungen von BIOS und OS versuchen zu optimieren, falls es an untauglicher Hardware (da geht's nicht allein um GHz und GB) scheitert, führt nur Neukauf zu einer Besserung.
 
M

MarSel

Registrierter Benutzer
Zuletzt hier
24.09.19
Registriert
19.07.19
Beiträge
6
Kekse
0
Vielen Dank schonmal @Signalschwarz

Durch ein paar recherchen habe ich gelesen, dass die Einstellung bei 256 Sample eigentlich ausreichen sollte - Also warum sollte man die Latenz noch weiter reduzieren?

Vielleicht noch ein paar Infos zu meinem System:
Windows 10 - 64 Bit
i5 Prozessor
8GB RAM
2 Kerne - 2,7 GHz

Wenn ich den Taskmanager nebenher laufen lasse, sieht auch alles OK aus (CPU & Arbeitsspeicher bleiben im niedrigen Bereich)

Meinst du das System ist nicht ausreichend?

(Ich werde mal schauen ob ich etwas zur BIOS Optimierung finde)
 
Banjo

Banjo

MOD Recording/HCA Banjos
Moderator
HCA
Zuletzt hier
13.05.21
Registriert
05.07.07
Beiträge
21.969
Kekse
97.887
Ort
So südlich
256 Samples Latenz, bzw. nachdem das Signal ja von der Gitarre in den Rechner rein muss und von Guitar Rig auch wieder raus, macht in der Summe also 512 Samples. Bei 44,1 kHz entspricht das alleine einer Latenz von fast 12 Millisekunden, dazu kommen noch so 1 bis 2 Millisekunden in den Wandlern im Interface.

Das kann schon spürbar werden beim Spielen.

Was sagt denn der Latency Checker: https://www.heise.de/download/product/dpc-latency-checker-52865

Banjo
 
M

MarSel

Registrierter Benutzer
Zuletzt hier
24.09.19
Registriert
19.07.19
Beiträge
6
Kekse
0
@Banjo

Das sagt der Latency checker:
upload_2019-7-19_20-36-18.png
 
Banjo

Banjo

MOD Recording/HCA Banjos
Moderator
HCA
Zuletzt hier
13.05.21
Registriert
05.07.07
Beiträge
21.969
Kekse
97.887
Ort
So südlich
Ja, das sieht wirklich nicht gut aus.

Hast Du denn schon mal probiert, was da vorgeschlagen wird, sprich im Gerätemanager einzelne Devices mal temporär zu deaktivieren, um zu sehen, ob sich etwas verbessert? Natürlich geht das nur für entbehrliche Devices, wenn Du die einizge Grafikkarte deaktivierst, hast Du ein Problem.

Es gibt auch noch ein anderes Latency-Monitor-Programm, das die betroffenen Treiber auflistet, aber der Name ist mir entfallen, vielleicht kann jemand helfen?

Banjo
 
M

MarSel

Registrierter Benutzer
Zuletzt hier
24.09.19
Registriert
19.07.19
Beiträge
6
Kekse
0
Hi @Banjo

jetzt sieht es so aus..
upload_2019-7-19_20-59-45.png
 
Banjo

Banjo

MOD Recording/HCA Banjos
Moderator
HCA
Zuletzt hier
13.05.21
Registriert
05.07.07
Beiträge
21.969
Kekse
97.887
Ort
So südlich
Hattest Du was geändert?

Das war der Latency-Monitor, den ich noch im Hinterkopf hatte, der gibt auch an, welcher Treiber am längsten das System blockiert:

https://www.resplendence.com/latencymon

Banjo
 
M

MarSel

Registrierter Benutzer
Zuletzt hier
24.09.19
Registriert
19.07.19
Beiträge
6
Kekse
0
@Banjo
ja, hatte ich..
Das "absolute maximum" ist dadurch gestiegen..
Hier ist das was der andere Test ausgibt
upload_2019-7-19_22-11-29.png

--- Beiträge wurden zusammengefasst ---
@WolfChild
Danke für deinen Input - ich werde das mal auschecken und ausprobieren :)
 
Banjo

Banjo

MOD Recording/HCA Banjos
Moderator
HCA
Zuletzt hier
13.05.21
Registriert
05.07.07
Beiträge
21.969
Kekse
97.887
Ort
So südlich
Was sagt denn der Taskmanager zur CPU-Last, wenn der Rechner ganz normal auf dem Windows Desktop auf Eingaben wartet?

Banjo
 
M

MarSel

Registrierter Benutzer
Zuletzt hier
24.09.19
Registriert
19.07.19
Beiträge
6
Kekse
0
@WolfChild
Die Windows Optimierung hat leider nicht viel gebracht.
In die erweiterten BIOS Einstellungen bin ich leider nicht reingekommen.

@Banjo
CPU ist immer so bei 20% - 30%


Ich war Samstag dann im Session in Walldorf.
Dort hatte ich mich dann mit ein paar Fachleuten von der Interface Abteilung unterhalten.
Die meinten dann, dass das "Behringer U-Phoria UMC22" Interface für 40€ einfach zu schlecht ist.
Zum Vergleich habe ich mir jetzt das "Focusrite Scarlett 2i2 3rd gen" mitgenommen. Das scheint viel besser zu funktionieren!

(Behringer U-Phoria UMC22 (Werte auch in der description) = Hier komme ich mit Input/Processing/Output auf insgesamt 24,6ms - niedriger habe ich es mit keiner Einstellung geschafft
Focusrite Scarlett 2i2 = Hier komme ich mit Input/Processing/Output auf insgesamt 3ms)
 
Banjo

Banjo

MOD Recording/HCA Banjos
Moderator
HCA
Zuletzt hier
13.05.21
Registriert
05.07.07
Beiträge
21.969
Kekse
97.887
Ort
So südlich
Freut mich für Dich!

Allerdings sind die Messwerte und eine CPU-Last von 20-30% im Stillstand des Rechners Anzeichen, dass da was faul ist. Nicht dass irgendeine Malware auf Deinem Rechner Bitcoins berechnet oder sowas. Schau mal im Taskmanager, welche Programme da soviel CPU verbraten, normal wären ein paar Prozent in Ruhe. Und lass mal ein paar Virenscanner über Deinen Rechner laufen. Normal ist das nicht.

Banjo
 
Basselch

Basselch

MOD Recording HCA Mikrofone
Moderator
HCA
Zuletzt hier
13.05.21
Registriert
30.10.06
Beiträge
12.253
Kekse
56.023
Ort
NRW
Hallo,

...kann auch durchaus noch was anderes sein als Malware - es gibt genügend Hersteller, die jede Menge Kleinkram bei der Installation unbemerkt hintendranschmeißen, der zwar durchaus z. B. zur Hardware gehörig ist, aber sinnloserweise ständig im Hintergrund irgendwie rumrödelt.
Kandidaten sind z. B. Digitalkameras mit ihrer ggfs. auf dem Rechner installierten Betrachter- und Bearbeitungssoftware.
Lade Dir bei Heise oder bei CHIP mal den Process Explorer herunter, der könnte eventuell auch noch weiterhelfen...

Viele Grüße
Klaus

P.S.: Mal ein Vergleichswert aus dem Task Manager meines Rechners: Laufender Echtzeitschutz des Virenscanners, Firefox mit mehreren Tabs offen, NAS-Navigator an und noch so ein paar andere kleine Teilchen. Ergibt bei mir derzeit summa summarum unter Win 7 pro, 8 GB RAM und einem Xeon ES645 eine CPU-Last, die ganz knapp über Null pendelt, in der Spitze mal für einen Moment 3 oder 4 Prozent.
 
Banjo

Banjo

MOD Recording/HCA Banjos
Moderator
HCA
Zuletzt hier
13.05.21
Registriert
05.07.07
Beiträge
21.969
Kekse
97.887
Ort
So südlich
Ja, ich kenne auch die Installation mit 1000 unnötigen Utilities ab Werk, aber die sind selten aktive CPU-Fresser. 25-30% ist auf so einem i5 ein voll ausgelasteter Kern plus Grundrauschen.

Banjo
 
djbobo

djbobo

Registrierter Benutzer
Zuletzt hier
13.05.21
Registriert
28.02.13
Beiträge
1.194
Kekse
1.600
ASIO4All ist ein Pseudo-ASIO Treiber der auf den mehr oder weniger langsamen System-Treibern aufsetzt.
24ms Roundtrip ist unbrauchbar.
Mit einem Audio-Interface eines Markenherstellers, der echte ASIO-Treiber bereitstellt sollte ein aktueller Rechner mit i5/i7 Prozessor locker max. 10ms schaffen.
Windows auf Audio optimieren gehört dazu.
 
LtdBoomer

LtdBoomer

Registrierter Benutzer
Zuletzt hier
06.05.21
Registriert
01.12.16
Beiträge
339
Kekse
527
Ort
Das RuhrgeBeat
@WolfChild
Die meinten dann, dass das "Behringer U-Phoria UMC22" Interface für 40€ einfach zu schlecht ist.
Klar sagen die das.Als Ergebnis hast Du ja bei denen das andere Interface gekauft...;)

Mal davon ab,Ich hab mit dem Behringer eine Eingangslatenz von 3.5 ms und eine Ausgangslatenz von knapp 6 ms.
Man nehme nur den richtigen Treiber,thats all.
Der nennt sich - BEHRINGER_2902_X64_2.8.40 -
Den gibt es im Netz.
;)
--- Beiträge wurden zusammengefasst ---
Mit einem Audio-Interface eines Markenherstellers,
Was ist ein Markenhersteller?
Ist Behringer keine Marke?
 

Ähnliche Themen

Neue Themen

Unser weiteres Online-Angebot:
Bassic.de · Deejayforum.de · Sequencer.de · Clavio.de · Recording.de

Musiker-Board Logo
Oben