Asio4all - 2 Soundquellen gleichzeitig verwenden

von cereal_man, 11.04.12.

  1. cereal_man

    cereal_man Registrierter Benutzer

    Im Board seit:
    16.02.11
    Zuletzt hier:
    26.10.17
    Beiträge:
    29
    Zustimmungen:
    11
    Kekse:
    262
    Erstellt: 11.04.12   #1
    Hallo,
    zum nächtlichen Gitarre-Üben verwende ich immer ein Klinke-USB-Kabel-Interface, Guitar Rig für den Sound und Asio4all als Treiber, damit der Gitarrensound möglichst ohne große Latenzen auf meinen Kopfhörern ankommt.
    Nun benutze ich allerdings meist noch Guitar Pro zum Üben, da zB die Songs meiner Band alle als Guitar Pro Dateien vorliegen und das Üben so am einfachsten ist und am meisten Spaß macht. Da aber Asio4all den Audio-Ausgang blockiert, kommt vom Guitar Pro leider kein Sound am Kopfhörer an.

    Daher meine Frage:
    Gibt es eine Möglichkeit, 2 Soundquellen (in diesem Fall Guitar Rig und Guitar Pro) über Asio4all wiederzugeben? Vielleicht einen "Mixer" ähnlich dem in Windows integrierten, mit dem man beide Audio-Signale mixen könnte, der aber dennoch nahezu latenzfreies Arbeiten ermöglicht?

    Ich danke im Vorraus für eure Antworten!!!
     
  2. Dummer Sack

    Dummer Sack Gesperrter Benutzer

    Im Board seit:
    14.12.11
    Zuletzt hier:
    17.05.12
    Beiträge:
    490
    Zustimmungen:
    63
    Kekse:
    1.020
    Erstellt: 12.04.12   #2
    Ich glaube, dass das nicht funktioniert. Um Welches Kabel-Interface handelt es sich?
    Etwas bessere Interfaces sind üblicherweise in der Lage, einmal über ASIO Sound auszugeben und dann gleichzeitig noch per Multimediatreiber.

    - Der Sack
     
  3. cereal_man

    cereal_man Threadersteller Registrierter Benutzer

    Im Board seit:
    16.02.11
    Zuletzt hier:
    26.10.17
    Beiträge:
    29
    Zustimmungen:
    11
    Kekse:
    262
    Erstellt: 12.04.12   #3
    Es handelt sich um das billigste vom Billigen: https://www.thomann.de/de/the_tbone_usb1g.htm
    Letztlich würde mir das aber sowieso nichts nützen, wenn es gleichzeitig über Asio und Multimediatreiber Sound ausgeben könnte, da ich ja nicht den Sound vom Interface über die Kopfhörer hören möchte, sondern den Sound von Guitar Rig und ohne Asio ist die Latenz leider zu groß.
     
  4. Dummer Sack

    Dummer Sack Gesperrter Benutzer

    Im Board seit:
    14.12.11
    Zuletzt hier:
    17.05.12
    Beiträge:
    490
    Zustimmungen:
    63
    Kekse:
    1.020
    Erstellt: 12.04.12   #4
    Hm, jetzt verstehe ich was nicht.
    Das Interface - ob billig oder nicht - benutzt du doch für Guitar Rig, oder? Das läuft dann über den ASIO Treiber, ja? Und am Interface ist dein Kopfhörer angeschlossen?
    Oder ist das alles ganz anders?

    - Der Sack
     
  5. cereal_man

    cereal_man Threadersteller Registrierter Benutzer

    Im Board seit:
    16.02.11
    Zuletzt hier:
    26.10.17
    Beiträge:
    29
    Zustimmungen:
    11
    Kekse:
    262
    Erstellt: 12.04.12   #5
    Achso, nein^^ das hast du falsch verstanden, das Interface ist nur ein Kabel mit USB-Anschluss am einen Ende und Klinkenstecker am andern Ende.
    Die Gitarre hängt am Interface, das geht in den Computer und an der HD-Audio-Soundkarte am PC hab ich die Kopfhörer hängen.
    Der Ausgang von der Soundkarte wird allerdings von Asio4all gesperrt, sodass Windows nicht mehr darauf zugreifen kann, solange der Guitar Rig den Ausgang blockiert. Deshalb kommen über den Kopfhörer nur die Sounds von Guitar Rig und keine Windows-Töne oder eben Guitar Pro.
     
  6. Dummer Sack

    Dummer Sack Gesperrter Benutzer

    Im Board seit:
    14.12.11
    Zuletzt hier:
    17.05.12
    Beiträge:
    490
    Zustimmungen:
    63
    Kekse:
    1.020
    Erstellt: 12.04.12   #6
    Ok, jetzt verstehe ich.
    Also, vielleicht gibt es irgendwelche kuriosen Möglichkeiten, das zum Laufen zu bringen. Aber wenn du sowas häufiger machen willst, würde ich dir die Anschaffung eines zumindest halbwegs gescheiten Interfaces ans Herz legen. Das muss ja nicht die Welt kosten, da ist man schon mit ca. 70-80 Euro dabei.

    - Der Sack
     
  7. javi

    javi Registrierter Benutzer

    Im Board seit:
    10.12.05
    Zuletzt hier:
    18.09.18
    Beiträge:
    632
    Zustimmungen:
    43
    Kekse:
    1.360
    Erstellt: 12.04.12   #7
    Ich bin mir nicht 100% sicher aber das müßte mit einem Line6 Audio Interface funktionieren.Das kann man als Hauptsoundkarte einstellen (dabei die interne Computersoundkarte deaktivieren).Erkundige dich aber bevor du sie kaufen solltest ob das wirklich so machbar ist.

    https://www.thomann.de/de/line6_pod_studio_gx.htm
     
  8. Dummer Sack

    Dummer Sack Gesperrter Benutzer

    Im Board seit:
    14.12.11
    Zuletzt hier:
    17.05.12
    Beiträge:
    490
    Zustimmungen:
    63
    Kekse:
    1.020
    Erstellt: 12.04.12   #8
    Das kann man mit sehr vielen Soundkarten so machen. Die müssen eben "multiclient" fähig sein, das aber auch noch beherrschen, wenn ein Programm per ASIO zugreift. Es gibt mittlerweile sogar Karten, die "multiclient ASIO" können, das braucht man aber meistens eher nicht.

    - Der Sack
     
  9. cereal_man

    cereal_man Threadersteller Registrierter Benutzer

    Im Board seit:
    16.02.11
    Zuletzt hier:
    26.10.17
    Beiträge:
    29
    Zustimmungen:
    11
    Kekse:
    262
    Erstellt: 15.04.12   #9
    Okay, danke für die Antworten, das bestätigt zumindest das, was ich befürchtet habe, nämlich, dass ich noch ein weiteres Interface werde anschaffen müssen. Ich besitze bereits das Tascam US 144 - damit klappt auch alles so, wie ich das haben will. Nun habe ich mir für meine Studentenbude noch das Kabel-Interface gekauft, damit das Tascam zuhause bei Mami stehen bleiben kann und ich es nicht immer hin- und herschleppen muss =P
    Also kaufen werd ich mir nicht noch ein Interface - das nächste Interface, das ich mir kaufe, wird mindestens 8 Kanäle haben und das ist mir zur Zeit noch zu teuer ;)

    Falls also noch jemandem eine Lösung einfällt, die kein Geld kostet, wäre ich über eine Antwort sehr erfreut, aber ich fürchte, es geht tatsächlich nicht =(
     
Die Seite wird geladen...

mapping