Midis und der TR...

von Leef, 17.03.08.

  1. Leef

    Leef Registrierter Benutzer

    Im Board seit:
    16.03.07
    Beiträge:
    4.274
    Ort:
    Sachsen
    Zustimmungen:
    409
    Kekse:
    5.574
    Erstellt: 17.03.08   #1
    Sicher ein leidiges Thema, aber umso mehr hoffe ich daß es für mein Problem eine Lösung gibt.

    Ich lade ein Midi von der SD Karte in den Sequenzer des Korg TR, soweit alles ok. Als nächstes muß ich im Utility Menü GM Initalize wählen damit die GM Sounds geladen werden. Soweit auch alles ok.

    Jetzt kommts aber, einige Midis spielen sehr schön alle eingestellten Instrumente andere hingegen spielen alles nur mit Klavier.
    Ich vermute das Problem in den Programm-Change Befehlen oder sowas in den Midis, kennt jemand eine Lösung des Problems?

    Gibt es hierfür vllt sogar ein Tool was die Midis für den TR kompatibel macht?

    Heißen Dank! :great:
     
  2. Martman

    Martman Registrierter Benutzer

    Im Board seit:
    14.09.05
    Zuletzt hier:
    3.12.16
    Beiträge:
    4.004
    Ort:
    Hamburg
    Zustimmungen:
    926
    Kekse:
    16.450
    Erstellt: 17.03.08   #2
    Handelt es sich bei allen Dateien wirklich um Standard-MIDI-Files, oder kann es sein, daß einige davon Instrumenteneinstellungen für ein anderes Gerät enthalten?


    Martman
     
  3. Leef

    Leef Threadersteller Registrierter Benutzer

    Im Board seit:
    16.03.07
    Beiträge:
    4.274
    Ort:
    Sachsen
    Zustimmungen:
    409
    Kekse:
    5.574
    Erstellt: 17.03.08   #3
    Das weiß ich im Detail gar nicht so genau, ich vermute mal dort sind ein paar XG Befehle oder soetwas dabei, da sie mein kleines Yamaha Keyboard besser verdaut als der TR.

    Aber wie bekomme ich die Befehle raus? Bzw das geht so nicht oder? Es fehlen ja dann die Anweisungen die in XG geschrieben sind.
    Ich habe schon wie ein Irrer gegoogelt nach XG to Korg konverter usw. Aber ich finde nüx. :(

    Gerade nochmal rumgetestet. Mein Yamaha spielt es problemlos ab, die ältere Korg X3 mit Problemen aber die Instrumente stimmen grob und die TR alles nur mit Piano. Elende Diva :D

    Ich vermute mal es sind dann keine laschen GM files sondern mit etwas XG gewürzt oder so.
    Also brauche ich eine Lösung wie ich daraus normale GM Files mache. :(

    Na vielleicht weiß jemand eine Lösung. Sonst muß man wohl selber ran und alles programmieren? :screwy:
     
  4. Leef

    Leef Threadersteller Registrierter Benutzer

    Im Board seit:
    16.03.07
    Beiträge:
    4.274
    Ort:
    Sachsen
    Zustimmungen:
    409
    Kekse:
    5.574
    Erstellt: 17.03.08   #4
    Hier sind zwei der bösen Dateien. Vielleicht erkennt man daran ja was das Problem ist... :evil:
     

    Anhänge:

  5. TritonFreak

    TritonFreak Registrierter Benutzer

    Im Board seit:
    20.12.05
    Zuletzt hier:
    14.10.16
    Beiträge:
    835
    Ort:
    Wuppertal
    Zustimmungen:
    1
    Kekse:
    868
    Erstellt: 17.03.08   #5
    Hi,

    ich hab mal die "fliegende Schwester" über Cakewalk und über den Song-Play Modus meines Tritons gejagt und habe das gleiche Problem.
    Über Cakewalk werden die richtigen Sounds gespielt, weil es in der jeweiligen Spur so hinterlegt wurde bzw. so abgespeichert wurde.
    Damit können Triton und TR aber scheinbar nichts anfangen. Korg benötigt augenscheinlich am Anfang des Midi-Files einen ProgrammChange-Befehl. Und genau der fehlt.

    Du wirst also, meiner Ansicht nach nicht um eine Programmierung per Hand nicht drum herum kommen :(

    Grooves,

    Mig
     
Die Seite wird geladen...

mapping