Soundwechsel über Midi (Triton LE zu XV-5080)

von Morbu, 10.11.06.

  1. Morbu

    Morbu Registrierter Benutzer

    Im Board seit:
    09.08.06
    Zuletzt hier:
    5.01.08
    Beiträge:
    8
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 10.11.06   #1
    Tach

    Kürzlich habe ich mir ein Rack (Roland XV-5080) gekauft und möchte dieses nun über ein Korg Triton LE ansteuern. Das Spielen klappt dabei auch ganz gut. Nun möchte ich aber vom Triton aus die Sounds am XV-5080 wechseln können, was ich irgendwie nicht hinbekomme. Wenn ich irgenwelche Tasten zur Änderung des Programs am Triton betätige, wechselt das XV-5080 in den GM-Modus. Mit der Anleitung bin ich auch nicht gross weitergekommen.

    Was ich auch noch erreichen möchte ist, dass ich entweder Sounds aus dem Triton spiele (so dass man das XV-5080 nicht hört), dann aber vollständig auf das XV-5080 wechseln kann (durch einen Soundwechsel am Triton), so dass man nur noch die Sounds vom XV-5080 hört! Ist das möglich? Ich kenne mich halt noch nicht so recht aus bei Midi-Fragen.

    Ich hoffe, ihr versteht ungefähr was ich meine;)! Irgendwie bin ich einfach gerade etwas überfordert mit allem:(. Ich weiss auch gar nicht, nach welchen Stichworten ich in der Anleitung genau suchen müsste. Habt ihr irgendwelche Lösungsansätze bereit?

    Cheers

    M~
     
  2. bluebox

    bluebox HCA Keyboard HCA

    Im Board seit:
    30.10.03
    Zuletzt hier:
    2.12.16
    Beiträge:
    2.333
    Ort:
    Südpfalz
    Zustimmungen:
    91
    Kekse:
    4.976
    Erstellt: 10.11.06   #2
    Hallo !

    Was du vor hast funktioniert bestimmt. Du musst hier aber die richtigen Banc-Select-Befehle eingeben.
    Schrieb mal an richy eine PM, der hat einen LE und ein Roland XP-60. Midi und Sounds sind sein Spezialgebiet - der kann dir das ganz genau erklären.

    bluebox
     
  3. Morbu

    Morbu Threadersteller Registrierter Benutzer

    Im Board seit:
    09.08.06
    Zuletzt hier:
    5.01.08
    Beiträge:
    8
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 10.11.06   #3
    Okay, danke für die schnelle Antwort;). Dann werde ich ihm gleich mal schreiben!
     
  4. HaraldS

    HaraldS Mod Emeritus Ex-Moderator

    Im Board seit:
    03.03.05
    Zuletzt hier:
    10.04.14
    Beiträge:
    4.890
    Ort:
    Recklinghausen
    Zustimmungen:
    750
    Kekse:
    29.296
    Erstellt: 10.11.06   #4
    Besorg dir mal MIDIOX und lass dir mal die MIDI-Daten anzeigen, die die Triton sendet. Die kannst du dann analysieren (macht MIDIOX teilweise auch selbst) und eingrenzen, woran der Fehler liegt. Du kannst die fraglichen Daten hier auch mal posten.

    Harald
     
  5. richy

    richy HCA Soundprogrammierung HCA

    Im Board seit:
    12.10.04
    Zuletzt hier:
    2.05.12
    Beiträge:
    2.384
    Zustimmungen:
    43
    Kekse:
    3.169
    Erstellt: 10.11.06   #5
    Hi
    @Harald Sehr gute Idee
    Aber ich denke es liegt bei Morbus Prob gar keine Fehlfunktion vor, sondern er weiss einfach nicht wie er die Sache angehen koennte.
    Und ob er mit HEX Befehlen zurechtkommt ?

    @Morbu
    Wahrscheinlich willst du beide Geraete im Combi. bzw. Performance (XV) Modus spielen. Das waere auch mein Vorschlag.
    Was haeltst du davon ?
    Da wird sich erstmal ein Problem ergeben, denn ich vermute beide Geraete haben vielleicht nicht die selbe Anzahl von Combination/Performance Speicherplaetzen. Danach solltest du erstmal schauen. Annahme
    LE pro Bank 128 Combis
    XVpro Bank 032 Combis:
    Drueckst du am LE Combi 33 springt der XV evtl auf die Nummer 01 der naechsten Bank.
    Das koennte die Ursache fuer den Wechsel in den GM Mode sein.

    Schau mal nach der Anzahl und steppe den LE beginnend bei A 01 durch die Combi Nummern. Was passiert dann am XV ?
    Eventuell kann man hier am XV ein Mapping einstellen.(Eher unwahrscheinlich)

    Alle diese Einstellungen sollten sich im System / Midi Menue befinden.

    (FUER FOLGENDES HAB ICH INZWISCHEN NE BESSERE LOESUNG :)
    (Kannst also auch zum naechsten Thread springen.)

    Falls hier nichts geht, muesstest du dich eben nach dem Verhalten des XV richten. COMBI Change scheint aktiviert. Das ist schon mal was.
    PRG Change wuerde ich am XV deaktivieren, damit innerhalb einer Combi aus versehen kein Programm gewechselt wird.

    Den Triton stumm schalten...

    Da waere die einfachste, uneleganteste Methode die Sounds am Triton einfach in der Combi zu muten, also stumm zu stellen.
    Entweder indem du in der Combi alle Volumen auf 0 stellst.
    Das waere aber Soundverschwendung.

    Ich wuerde einen Switch Knopf dafuer opfern.
    Ziel Beispiel:
    Drueckst du SW2 schalten sich die Programme vom LE auf Volume=0

    Leider leider ...
    ist das beim Triton etwas umstaendlich zu realisieren. Du musst im Programm
    Mode dies realisieren. Wie das erklaert schreibe ich dir bei bedarf.
    Du musst das organisieren. Ich habe das auch gemacht, um mittels Switch
    innerhalb einer Combi Programme ein und aus zu schalten.
    Z.B. einen Streicher hinzufuegen.
    Praktischerweise hab ich das im Programmnamen mit SW vermerkt.
    /

    Probier jetzt erstmal das durchsteppen von A1 ab aus.
    ciao
     
  6. richy

    richy HCA Soundprogrammierung HCA

    Im Board seit:
    12.10.04
    Zuletzt hier:
    2.05.12
    Beiträge:
    2.384
    Zustimmungen:
    43
    Kekse:
    3.169
    Erstellt: 11.11.06   #6
    Anmerkung:

    Die Loesung mit einem Switch den Le zu muten stellt einen erheblichen Programmieraufwand dar. Wieviele Sounds willst du eigentlich verwenden ?
    Weiterhin hast du damit noch keine Loesung auch mal den Le alleine zu
    spielen. Also den XV zu muten.
    Und auch der kontrollierte Performance Wechsel ist nur halbherzig geloest.

    Mir ist noch eine andere Loesung eingefallen, die einfacher ist.
    Weiss aber nicht ob das so funktioniert wie ich es mir vorstelle.
    LE und XP 60 sind gerade im VW Bus verpackt.
    Kann erst naechste Woche testen ob das funktioniert.

    Grundidee:
    Du stellst Le und XV zunaechst auf unterschiedliche globale Midi Kanaele:
    Beispiel:
    LE Kanal 1
    xv Kanal 2

    Ergebnis:
    Im Combi und Programm Mode kannst du den LE spielen, ohne dass der XV
    hierdurch irgendeine Midi Information erhaelt.
    Er bleibt also stumm und ignoriert auch Programmwechsel.
    Beide Geraete sind praktisch nicht miteinander verbunden.

    Jetzt der Trick. (Weiss noch nicht ob das klappt)
    Nun wechselst du am LE in den Sequenzermode. Zuvor hast du dort einen
    oder ein Set von leeren Songs geladen, deren Aufgabe lediglich darin besteht dein Midi System zu managen.
    Der Sequenzer Mode wird jetzt zu deinem XV Mode.

    Anm (Kannst du ueberspringen):
    Im Prinzip ist der Sequenzer Mode vom LE das eigentliche Gegenstueck
    zum Performance Mode der Roland Workstations. Erst hier hast du wie bei
    Roland die volle Kontrolle ueber 16 statt 8 Programme im Combi Mode.
    Leider kommt diese Eigenschaft des Sequenzer Modes im LE Manual nicht so
    richtig zur Geltung.
    Es gibt auch einen bedauerlichen Nachteil:
    (2) Combis lassen sich ruck zuck einer 16 er Combi in den Sequenzer kopieren.
    Allerdings geht der umgekehrte Weg anscheinend nicht.
    Combi Sound Zusammenstellungen lassen sich nicht vom Sequenzer zurueck in den Combi Mode kopieren. Oder weiss hier jemand wie das geht ?
    Als Combi Archivierung ist der SEQ Mode also nur bedingt faehig.
    Aber zurueck zum eigentlichen Vorhaben:
    /Anm

    Wenn mich nicht alles taeuscht verhaelt es sich im Sequenzer Mode nun so:
    Der LE sendet dort das Spiel auf der Tastatur unter dem Midi Kanal den man zuletzt in dem Song bearbeitet hat.
    Damit haettest du nun die Moeglichkeit den Le auf verschiedenen Send Kanaelen, im Beispiel zwischen Kanal 1 und Kanal 2 umzuschalten.

    Klingt kompliziert aber in der Praxis waere das ganz einfach:
    Zunaechst spielst du den LE im Combi Mode.

    Jetzt drueckst du die Sequenzertaste.
    Ist kein Songs geladen, ertoent da default das Programm A1 auf allen Midi Spuren auf Midi Kanal 1.
    Du gehst jetzt sinnigerweise auf Midi Spur 2.
    Ordnest dieser den Midi Kanal 2 zu.
    Der LE sollte jetzt auf Kanal 2 senden ! (Hoffentlich ist dem so :-)
    Also der Kanal den der XV im Beispiel empfaengt.
    Die Lautstaerke der Midi Spur 2 stellst du auf Null.
    Oder noch sehr viel einfacher:
    Du setzt die Lautstaerke des Programms A1 beim Triton auf Null.

    Jetzt solltest du nur den XV hoeren.

    Ergebnis:
    Combi druecken: Klangerzeugung vom LE
    Sequenzer druecken: Klangerzeugung vom XV

    Und den SEQ "Song",Midi File, speicherst du als "XV-5080-solo" ab.

    Natuerlich kannst du mit der Methode auch "Songs" also Sounds erstellen, in denen LE und XV zusammen den Sound aufbauen.

    ... und wie kann ich mit dieser Methode die Performances vom XV gezielt umstellen ?
    Auch das muesste gehen. Dazu musst du fuer jede Performance des XV einen
    "leeren" Song erstellen. Und das Umstellen auf die Performance sendest du in dem Song als System Exclusive Message. Das geht auf jeden Fall.
    Sobald du den Song anwaehlst, wechselt der XV auf die entsprechende Performance, ohne dass du den Sequenzer startest.

    Klingt nun auch wieder kompliziert. Waere es aber nicht.
    Nehmen wir an der XV hat die Performances A,B 1..64

    Praxis:
    Du laedst in deinen LE ein SEQ Set: "Mein XV 5080"
    Das enhaelt die Midi Songs
    A1, A2,A3 ....A64
    B1, B2, B3 ....B64

    Waehlst du Song B13 stellt sich der XV automatisch auf Performance B13 um.
    Um die SYS EX zu Programmieren benoetigst du einen kleinen SYS EX Editor.
    Das ist lediglich ein kleiner HEX Befehl.

    Bischen stupide ... aber diese Programmierarbeit koennte ich fuer dich uebernehmen und dir dann einfach das Midi File Set zusenden.
    Ne Sache von ein zwei Stunden.
    Muesste natuerlich wissen wieviele Performance Baenke und Nummern der XV aufweist.

    Ergebnis:
    Du laedst dieses Set in den Sequenzer.
    Waehst du im Sequenzer den "Song" A 05 wird am XV die Performance A 05 angewaehlt etc ...

    Am einfachsten und flexibelsten waere natuerlich eine extra Tastatur fuer den XV.

    ciao
    richy
     
  7. Morbu

    Morbu Threadersteller Registrierter Benutzer

    Im Board seit:
    09.08.06
    Zuletzt hier:
    5.01.08
    Beiträge:
    8
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 11.11.06   #7
    Hallo

    Danke für die ausführlichen Antworten! Ich werde mal ausprobieren, wieweit ich damit komme. Allerdings möchte ich den XV vorwiegend im Patch-Modus betreiben, aber schon auch im Performance-Modus. Und das Problem beim Soundwechsel am XV ist, das das XV in die GM-Bank wechselt, sobald ich am LE nur schon am Rad zur Soundänderung drehe.

    Aber ich müsste ja wohl beim LE im Seq-Modus nicht für jeden Sound am XV einen Song erstellen, nur für diejenigen, die ich auch effektiv verwende, oder sehe ich das falsch? Ich muss allerdings sagen, dass ich den Seq-Modus der LE nicht gut kenne, ist aber offenbar mal Zeit, sich intensiv damit auseinander zu setzen. Bis jetzt habe ich halt einfach gespielt, aber die Möglichkeiten des Keyboards nicht weiter angeschaut.

    Und ja, beim Programmieren wäre ich froh um Hilfe. Die Programmierung von Keys ist etwas völlig neues für mich, gerade wenn's um das System geht!

    Ich melde mich wieder, sobald ich das ganze mal ausprobiert habe. Zu tun habe ich ja jetzt genug;)!

    Cheers

    M~
     
  8. richy

    richy HCA Soundprogrammierung HCA

    Im Board seit:
    12.10.04
    Zuletzt hier:
    2.05.12
    Beiträge:
    2.384
    Zustimmungen:
    43
    Kekse:
    3.169
    Erstellt: 11.11.06   #8
    Hi
    >
    Aber ich müsste ja wohl beim LE im Seq-Modus nicht für jeden Sound am XV einen Song erstellen, nur für diejenigen, die ich auch effektiv verwende,
    >
    genau :-)

    >
    das das XV in die GM-Bank wechselt, sobald ich am LE nur schon am Rad zur Soundänderung drehe.
    >
    solltest du vielleicht auch mal Haralds Vorschlag nachgehen und schauen ob der LE nicht einen GM Reset sendet oder der XV dies hinzufuegt.
    (Im System Midi Menue)

    Im LE Manual Seite 124 GLOBAL MODE. Tatsaechlich kann man hier ein GM Mapping einstellen !

    So ein Mapping wird es auch es auch fuer den XV geben.
    Solltest du damit schnell in den Griff bekommen.
    Viel Erfolg


    ciao
     
  9. Morbu

    Morbu Threadersteller Registrierter Benutzer

    Im Board seit:
    09.08.06
    Zuletzt hier:
    5.01.08
    Beiträge:
    8
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 18.11.06   #9
    Tach

    Ich habe gerade mal wieder etwas am Keyboard und am Rack rumgeschraubt und ausprobiert, was ich mit dem Sequencer erreichen kann. Zuerst habe ich das Midi-Mapping am LE umgestellt, also auf Korg und nicht mehr auf GM. Das entsprechende habe ich auch beim XV gemacht (im System unter Midi, Rx-Switch alles mit GM oder GS auf off gesetzt). Nun wechselte ich in den Sequencer-Modus (LE) und in den Perform-Modus (XV).Wenn man nun den Sound am LE über Rad oder Tastatur wechselte, wechselte einfach das angewählte Patch der entsprechenden Performance. Die Performance selber wechselte dabei nicht, nur der Sound klang natürlich anders, weil sie wie gesagt nun mit einem anderen Patch aufgebaut ist. Wenn ich nun direkt am XV die Performance verstellte, stellte sich eine andere Performance ein (sollte es ja auch;)), auch wenn ich beim LE in den Program-Modus wechselte. Als ich aber beim LE wieder in den Sequencer-Modus wechselte, stellte sich bei der gerade verwendeten Performance das Patch wieder auf das vorher ausgewählten Patch um. Die Performance selbst änderte dabei nicht, nur wieder der Klang.

    Eigentlich wäre es ja kein Problem, wenn sich die Patches so umstellen lassen würden. Leider sind das aber alles nur Patches aus den GM- und GM2-Bänken!

    Ich bin also nicht wirklich weitergekommen:(! Irgendwie habe ich aber dennoch das Gefühl, dass richy's Idee irgendwie funktionieren sollte. Irgendetwas mache ich aber vermutlich noch falsch! Hättet ihr noch eine Idee an was das liegen könnte? Ich komme selber leider gerade nicht mehr weiter!

    Sonst noch einen schönen Abend.

    Gruss

    M~
     
  10. TritonFreak

    TritonFreak Registrierter Benutzer

    Im Board seit:
    20.12.05
    Zuletzt hier:
    14.10.16
    Beiträge:
    835
    Ort:
    Wuppertal
    Zustimmungen:
    1
    Kekse:
    868
    Erstellt: 19.11.06   #10
    Moin !

    Wenn sich der XV so verhält wie die alten JVs (1080 usw...) dann ist der externe Wechsel von Patch -> Performance ein sys-ex befehl den du mit dem Triton nicht senden kannst, außer vielleicht im Sequenzer-Modus

    Mein Vorschlag:
    Triton generell im Combi-Mode, interner Midi-Kanal 1, den XV prinzipiell im Patch-Modus, interner Midi-Kanal 2. Im LE-Combi-Modus kannst du den sogenannten MIDI-Status einstellen(off, int, ext, ex2, siehe Manual Seite 58). Ex2 ist in dem Fall der Roland, hier musst du in der Combi dann den entsprechenden Midi-Kanal des XVs auswählen. Programm-Change kannst du dann mittels LSB/MSB (S.58) einstellen. Im XV Handbuch sollte stehen, welche Werte für welche Bank gelten.
    Beim Anwählen der entsprechenden Combi schaltet sich der XV mit um.
    Patch/Performance würde ich dann manuell umschalten.
    Du brauchst also für jeden Sound den du aus dem XV holst im LE eine Combi mit dem entsprechenden Prg-Change Befehl.

    Ist vielleicht etwas viel Programmieraufwand, aber so hat's bei mir mit Triton Classic und JV1080 einwandfrei funktioniert, da LE und XV vom Prinzip her ähnlich sind, sollte es auch klappen.

    BEATZ,

    Der Mig
     
  11. Morbu

    Morbu Threadersteller Registrierter Benutzer

    Im Board seit:
    09.08.06
    Zuletzt hier:
    5.01.08
    Beiträge:
    8
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 19.11.06   #11
    Hallo

    Okay, hört sich gut an. Ich denke schon, dass das XV in etwa so funktioniert wie die JVs. Allerdings habe ich trotzdem noch ein Problem. Ich stellte beim LE in einer
    Combi mal eine Stimme auf EX2, die anderen Stimmen der Combi stellte ich alle auf OFF. Dann stellte ich MSB und LSB ein (MSB=087, LSB=065 für Patch-Gruppe B). Am XV tat sich dabei aber noch nichts. Muss ich noch etwas tun, damit nun das XV in die gewünschte Bank springt? Wenn ich MSB oder LSB verstelle zeigt es mir an, dass ein Midi-Signal empfangen wird. Aber wie gesagt: Die Bank ändert sich nicht. Wenn ich übrigens aus dem Combi-Modus wechsle (z.B. in den Program-Modus), erhält das Patch am XV ein Sternchen (*), was eigentlich anzeigt, dass ein Sound verstellt wurde. Im Program-Modus und auch nach dem wechsel zurück in den Combi-Modus ist aber nichts mehr zu hören vom XV. Erst wenn ich das Patch am XV selber wechsle, höre ich wieder etwas.

    Ein weiteres Problem stellte sich beim LE. Ich wurde aus der Anleitung nicht ganz schlau, wie man den Midikanal für EX2 einstellen kann. Im Global-Modus hatte ich zuerst auf Midikanal 1 geschaltet (XV war auf Kanal 2), und wollte für das XV beim LE gleich eine Zeile unter EX2 auf Kanal 2 stellen (in dieser Zeile verstellt man doch den Midikanal, oder?). Vom XV war aber dann noch nichts zu hören, obwohl angezeigt wurde, dass ein Midi-Signal empfangen wird.

    @TritonFreak: Als du MSB und LSB am Triton eingegeben hast, ist denn das JV sofort in die gewünschte Bank gesprungen? Oder was hast du noch gemacht? Und wie bekomme ich das noch hin mit dem Midi-Kanal (1 und 2)?
    Grundsätzlich gefällt mir diese Idee aber sehr gut mit den programmierten Patches im Combi-Modus. Danke! Aber sollte halt noch laufen bei mir;)!

    Gruss

    M~
     
  12. TritonFreak

    TritonFreak Registrierter Benutzer

    Im Board seit:
    20.12.05
    Zuletzt hier:
    14.10.16
    Beiträge:
    835
    Ort:
    Wuppertal
    Zustimmungen:
    1
    Kekse:
    868
    Erstellt: 19.11.06   #12
    Bei mir war es so, dass solang ich im Edit Modus war, die Prog-Change-Befehle nicht gesendet wurden. Erst nach abspeichern und neuem Anwählen der Combi (also vorher auf ne andere) konnte ich testen ob das was ich eingebenen habe auch tatsächlich funzt.

    Patch oder Performance ??
    Wenn der Master-Kanal des XV auf 2 steht und der EX2 Kanal des Triton auch, dann müsste eigentlich auch was erklingen. :confused: Midi-Volumen ? Zone ?

    siehe oben ;)

    BEATZ,

    Der Mig
     
  13. Morbu

    Morbu Threadersteller Registrierter Benutzer

    Im Board seit:
    09.08.06
    Zuletzt hier:
    5.01.08
    Beiträge:
    8
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 20.11.06   #13
    Tach

    Ach so. Darauf bin ich gar nicht gekommen. Dann probiere ich nochmals was passiert, wenn ich zuerst alles abspeichere! Hoffe es klappt dann, sollte ja aber eigentlich dann gehen, wenn's bei dir so auch gegangen ist.
    Und das mit dem Midikanal krieg ich auch noch hin. Sonst schaue ich halt doch nochmals die Anleitung gut durch;).

    Mal schauen wann ich das nächste Mal Zeit habe zum ausprobieren...Melde mich dann wieder.

    Einen schönen Tag noch

    Cheers

    M~
     
  14. Morbu

    Morbu Threadersteller Registrierter Benutzer

    Im Board seit:
    09.08.06
    Zuletzt hier:
    5.01.08
    Beiträge:
    8
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 22.11.06   #14
    Hallo

    So, funktioniert jetzt alles! Der Trick lag eindeutig beim Abspeichern: Nachdem ich MSB, LSB und den Midikanal eingegeben und abgespeichert habe, funktionierte alles auf Anhieb! Ich musste also nichts mehr an den Midi-Zonen oder Volumen oder so regeln. Hat sich zum Glück alles erübrigt.

    Danke an alle, welche mir irgendwie weiterhelfen konnten! Alleine wäre ich vermutlich nicht so schnell ans Ziel gekommen;)!
    Jetzt kann ich mich ja voll aufs Spielen und Programmieren neuer Sounds konzentrieren:D ...

    Schönen Abend noch

    Cheers

    M~
     
  15. TritonFreak

    TritonFreak Registrierter Benutzer

    Im Board seit:
    20.12.05
    Zuletzt hier:
    14.10.16
    Beiträge:
    835
    Ort:
    Wuppertal
    Zustimmungen:
    1
    Kekse:
    868
    Erstellt: 23.11.06   #15
    Sehr gerne !!!! :great:
     
Die Seite wird geladen...

mapping