USB Interface - funzt nicht

von stefan64, 21.12.06.

  1. stefan64

    stefan64 HCA Tasten HCA

    Im Board seit:
    05.11.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    2.551
    Ort:
    Stuttgart
    Zustimmungen:
    39
    Kekse:
    2.382
    Erstellt: 21.12.06   #1
    Hallo,

    an meinem neuen GEM RP-X ist ein USB Interface, auch wird ein Treiber per CD und Webseite mitgeliefert.
    Als PC verwende ich einen HP Compac tc4200 mit Windows XP Professional
    Der Treiber wird auch schön installiert, verlangt seinen Reboot - wenn ich aber dann das USB-Kabel anschliesse, erkennt mein Computer "new Hardware USB <-> Serial" und verlangt eine Treiber-CD. Ein Zuweisen unter "System -> Hardware" geht nicht.... schlussendlich, so habe ich inzwischen rausgefunden, ist das ein von Roland erstellter Treiber, der einem USB-Interface einen seriellen Port zuweisen soll.
    Hat irgend jemand von Euch eine Idee, wie ich das zum Laufen bekomme? Wär Klasse....

    ciao,
    Stefan
     
  2. Jay

    Jay HCA Piano/Spieltechnik Ex-Moderator HCA

    Im Board seit:
    29.10.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    4.667
    Ort:
    München
    Zustimmungen:
    181
    Kekse:
    7.137
    Erstellt: 21.12.06   #2
    Das "USB-Serial" lässt darauf schließen, dass ein FTDI Baustein im GEM ist: FTDI Chip Home Page Auf der Seite gibts auch Treiber bzw. mögliche Konfigurationen. Wenn das nicht geht, reden wir weiter. ;) Hast du eigentlich mal versucht, sämtliche Meldungen zu ignorieren und trotzdem eine Übertragung probiert? Weil Windows XP unterstützt erstaunlich viel von Haus aus, und diese USB-Seriell-Geschichte ist doch relativ verbreitet, wenns nicht schnell sein muss, nix kosten darf und trotzdem USB draufstehen soll.

    PS: Eine Schweigeminute für den allseits geliebten und schmerzlich vermissten RS232-Port. :(
     
  3. michaelausS

    michaelausS Registrierter Benutzer

    Im Board seit:
    05.01.06
    Zuletzt hier:
    28.10.16
    Beiträge:
    172
    Zustimmungen:
    0
    Kekse:
    84
    Erstellt: 21.12.06   #3
    Bei solchen Lösungen sollte man zuerst die Treiber aufspielen und dann das Gerät einpömpeln.
     
  4. konbom

    konbom Registrierter Benutzer

    Im Board seit:
    18.06.06
    Zuletzt hier:
    23.01.12
    Beiträge:
    470
    Ort:
    Plettenberg/Sauerland
    Zustimmungen:
    0
    Kekse:
    351
    Erstellt: 21.12.06   #4
    Das erinnert mich irgendwie an die Installation meines USB-MIDI-Interfaces... Da muss man erst den Treiber installieren, und wenn man dann das Interface einstöpselt sagt er noch zweimal "Neue Hardware gefunden" und danach ist dann gut und man kann es benutzen.:screwy:
    Vielleicht sollten sich die Hersteller mal was anderes überlegen. Ich finde das höchst seltsam.:confused:
     
  5. stefan64

    stefan64 Threadersteller HCA Tasten HCA

    Im Board seit:
    05.11.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    2.551
    Ort:
    Stuttgart
    Zustimmungen:
    39
    Kekse:
    2.382
    Erstellt: 21.12.06   #5
    Lesen hilft :rolleyes: so hab ichs gemacht (s.o.)

    @Jay, Danke, sobald alles vor meiner Nase heute Abend werd ich die Treibers mal probieren :great:
     
  6. Cheldar

    Cheldar Registrierter Benutzer

    Im Board seit:
    26.09.03
    Zuletzt hier:
    7.06.16
    Beiträge:
    488
    Ort:
    Göttingen
    Zustimmungen:
    9
    Kekse:
    244
    Erstellt: 23.12.06   #6
    hast du das Interface direkt angeschlossen, oder noch nen USB-Hub dazwischen?

    Ich hatte shcon mehrfach USB-Geräte, die unbedingt ohne HUB angeschlossen werden wollten...

    JOa, der ließ sich so schön einfach programmieren... jetzt muss man nen riesen hickhack betreiben, um irgendwelche Bits zu lesen oder zu setzen :-/
     
  7. GEMservice

    GEMservice Registrierter Benutzer

    Im Board seit:
    02.01.07
    Zuletzt hier:
    3.04.12
    Beiträge:
    84
    Ort:
    Pirmasens
    Zustimmungen:
    0
    Kekse:
    60
    Erstellt: 04.01.07   #7
    Es gibt ein Programm das nennt sich Com Port Set Utility, das zeigt dir eventl. Konflikte an.
    Hast du das? Du hast warscheinlich irgeind ein Konflikt in dem du einen Port doppelt belegt hast.

    mfg
    Michael
     
  8. stefan64

    stefan64 Threadersteller HCA Tasten HCA

    Im Board seit:
    05.11.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    2.551
    Ort:
    Stuttgart
    Zustimmungen:
    39
    Kekse:
    2.382
    Erstellt: 04.01.07   #8
    Hallo Michael,
    nein, ich habe das Programm nicht. Kannst Du mir dazu näheres schreiben? Denn bisher habe ich die USB-Verbindung immer noch nicht zum Laufen gebracht.... Danke!
    ciao,
    Stefan
     
  9. Sticks

    Sticks Mod Emeritus Ex-Moderator HFU

    Im Board seit:
    07.10.03
    Beiträge:
    7.381
    Ort:
    "Rhinelunt"
    Zustimmungen:
    437
    Kekse:
    48.180
    Erstellt: 04.01.07   #9
  10. Hemming

    Hemming Registrierter Benutzer

    Im Board seit:
    05.01.07
    Zuletzt hier:
    5.01.07
    Beiträge:
    1
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 05.01.07   #10
    :) Hallöchen, lade mal den GEM Treiber ( es geht auch der GM-X Treiber von der Hompage gem-lem.de) dann gehst du auf Geräte manager und suchst den Treiber,
    dann anklicken, danach erweiterte Einstellungen( Advanced) und die Latenz Zeit
    auf 1 ( Eins) stellen, danach den Rechner nochmals starten, hat bei mir geholfen..
    Ich habe das RP- X ,tolles Teil.. melde mal ob´s geht.:) :great:

    HEMMMING
     
  11. stefan64

    stefan64 Threadersteller HCA Tasten HCA

    Im Board seit:
    05.11.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    2.551
    Ort:
    Stuttgart
    Zustimmungen:
    39
    Kekse:
    2.382
    Erstellt: 08.01.07   #11
    Du redest auch über Win XP?
    Treiber ist geladen, im Device Manager ist er drin, Advanced ist etwas das dort nicht angeboten wird, über eine genaue wo-muss-ich-klicken-Anleitung würde ich mich freuen.

    ciao,
    Stefan
     
  12. Jay

    Jay HCA Piano/Spieltechnik Ex-Moderator HCA

    Im Board seit:
    29.10.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    4.667
    Ort:
    München
    Zustimmungen:
    181
    Kekse:
    7.137
    Erstellt: 16.01.07   #12
    Kurzes Update: Auf meinem WinXP-Pro-Rechner ließ sich der USB-Anschluss ebensowenig überreden zu funktionieren. Allerdings funktionierte die Übertragung über MIDI (RP-X --> Lexicon Omega Studio --> Rechner), auch wenn mir das "warum" äußerst schleierhaft ist. Oder das "warum" des USB-Anschlusses, suchts euch aus. Zumal im Handbuch zum USB-Anschluss nix weiter steht und im Kapitel zur Datenübertragung ausschließlich von MIDI-Übertragung die Rede ist. :confused:

    Auch wenn ich jetzt langsam mit der Programmierung meiner Soundeinstellungen beginnen kann, hab ich immer noch das Gefühl, Bananenhardware gekauft zu haben. Reift beim Kunden ...
     
  13. andi.k

    andi.k Registrierter Benutzer

    Im Board seit:
    28.10.06
    Zuletzt hier:
    9.01.16
    Beiträge:
    629
    Ort:
    DD
    Zustimmungen:
    8
    Kekse:
    697
    Erstellt: 16.01.07   #13
    Bananenhardware.... lol :D

    Vor dem PRP hatten alle GEM Pianos ne serielle Schnittstelle für Midi in/out hatten. Scheinen sich beim RP-X nicht viel Arbeit gemacht, sondern einfach nen USB to serial converter (USB to RS232) an die bereits entwickelte Hardware gehangen zu haben.

    Dabei gibt's doch "richtige" USB Midi interfaces, die gar keinen Treiber brauchen, weil Windows, Max und Linux sie plug&play mäßig erkennen :confused:

    Hab mal nach dem COM Port Utility gegoogelt und bin fündig geworden:

    http://www.cadmusmicro.com/drivers/Utility-N.exe

    Vielleicht hilft Euch das.

    Wenn ich daran denke, wie Windows mit Bluetooth-to-serial oder IrDa-to-serial Treibern rumzickt (braucht man z.B. für Handy-Synchronisation oder IR-Fernbedienung), wird das hier nicht einfacher sein...
     
  14. Jay

    Jay HCA Piano/Spieltechnik Ex-Moderator HCA

    Im Board seit:
    29.10.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    4.667
    Ort:
    München
    Zustimmungen:
    181
    Kekse:
    7.137
    Erstellt: 17.01.07   #14
    Wobei es nicht zwingend um USB zu MIDI geht, sondern einfach nur um den Anschluss für die Konfiguration. Wenn ich ohnehin ein MIDI-Interface brauche, wozu dann der USB-Anschluss? Zumal er so umständlich zu handhaben ist.

    Die Konfiguration mit dem Tool über MIDI funktioniert einwandfrei und ist auch äußerst praktisch. Wenn man schon sowas hat und dann einen USB-Anschluss plant, wärs da nicht konzeptionell sinnvoll, dass der einfacher und "more powerful" ist als der Anschluss per MIDI? ;)
     
  15. stefan64

    stefan64 Threadersteller HCA Tasten HCA

    Im Board seit:
    05.11.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    2.551
    Ort:
    Stuttgart
    Zustimmungen:
    39
    Kekse:
    2.382
    Erstellt: 17.01.07   #15
    Naja, der USB-Anschluss parallel zum Midiinterface hat den entscheidenden Vorteil, dass man gleichzeitig Konfigurieren und spielen (also die Änderungen hören) kann - das ist ansonsten ein bissel mühsam (jedenfalls mit meinem Midi-Interface).

    ciao,
    Stefan
     
  16. Jay

    Jay HCA Piano/Spieltechnik Ex-Moderator HCA

    Im Board seit:
    29.10.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    4.667
    Ort:
    München
    Zustimmungen:
    181
    Kekse:
    7.137
    Erstellt: 17.01.07   #16
    ... hätte den entscheidenden Vorteil... weil es geht ja nicht. :p Aber an sich haste recht.
     
  17. andi.k

    andi.k Registrierter Benutzer

    Im Board seit:
    28.10.06
    Zuletzt hier:
    9.01.16
    Beiträge:
    629
    Ort:
    DD
    Zustimmungen:
    8
    Kekse:
    697
    Erstellt: 17.01.07   #17
    Wenn man das Ding sowieso komplett per Midi editieren kann, ist ein integriertes USB2MIDI interface schon sinnvoll da einfach zu realisieren und auf bereits entwickeltem Code aufgesetzt. Fuer ein Nicht-Midi-USB-Interface muessten die extra noch ein Protokoll entwerfen plus neuen Treiber/Schnittstelle im RP-X-Betriebssystem (vom PC-Treiber mal abgesehen). Am Ende haette man 2 verschiedene Interfaces, die irgendwie das gleiche koennen muessen, jedoch unterschiedlich implementiert sind -> anfaellig fuer Bugs. Aber USB-to-Serial-to-Midi ist da auch nicht besser, weil man nen extra Midi-Treiber fuer den PC entwickeln muss.

    stefan - USB und Midi geht gleichzeitig!? Kann mir nicht vorstellen, dass die 2 Midi-In drin haben sondern eher nen Midi-Merge machen. Sprich: es duerfte auch allein mit dem Midi-In funktionieren, wenn man ne Merge-Box nimmt oder folgende Software verwendet:

    MIDIOX
     
  18. Jay

    Jay HCA Piano/Spieltechnik Ex-Moderator HCA

    Im Board seit:
    29.10.03
    Zuletzt hier:
    5.12.16
    Beiträge:
    4.667
    Ort:
    München
    Zustimmungen:
    181
    Kekse:
    7.137
    Erstellt: 19.01.07   #18
    Ich zitier nochmal den selben Text ...
    Hab gerade herausgefunden, dass die Software ein MIDI-Thru hat, so dass man nix umstecken muss, sondern auch bei Konfiguration per MIDI alles gleich testen kann. Aufbau:

    P90 (MIDI-Out) --> Lexicon (MIDI-In) --> Rechner (USB vom Lex.) --> Lexicon (MIDI-Out) --> RP-X (MIDI-In)
     
  19. T-A-M

    T-A-M Registrierter Benutzer

    Im Board seit:
    01.07.07
    Zuletzt hier:
    10.01.15
    Beiträge:
    4
    Zustimmungen:
    1
    Kekse:
    10
    Erstellt: 24.04.08   #19
    Hallo zusammen,

    ich habe das Problem, dass ich mein RP-X über den USB-Anschluss mit meinem I-MAC verbinden möchte um MIDI-Daten auszutauschen. Leider erkennt der Computer kein angeschlossenes Gerät und auf der mitgelieferten CD sind ausschließlich WINDOWS-Treiber enthalten. Wer kann mir bei meinem Problem helfen?
    Vielen Dank!
     
Die Seite wird geladen...

mapping