Dual Core Prozessor einstellen ?

von workstour, 02.11.07.

  1. workstour

    workstour Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 02.11.07   #1
    Hallo!

    Ich habe mir ein Mainboard zugelegt mit 1024 MB Ram und nen Dual Core Prozessor
    2,8 GHz.

    Allerdings stelle ich jetzt nicht so einen grossen Unterschied zu meine vorherigen Prozessor (kein Dual Core) fest.
    In Cubase geht der CPU bei dem einen oder anderen plugin genauso schnell in die Knie. Und schneller ist er auch nicht wirklich.

    Muss man da was einsetellen? Ich habe mal gehört, dass man den CPU so einstellen kann, dass z.b. ein Kern nur Windows benutzt und der 2. Kern den Rest.
    Im Task Manager sind auch immer beide Kerne gleichzeitig ausgelastet laut der Anzeige.

    Vielen Dank im Voraus.
     
  2. Kubi

    Kubi Registrierter Benutzer

    Im Board seit:
    17.10.05
    Zuletzt hier:
    22.04.12
    Beiträge:
    569
    Ort:
    Salzgitter
    Zustimmungen:
    0
    Kekse:
    473
    Erstellt: 02.11.07   #2
    Vielleicht brauchste noch neuere Treiber?
    Oder braucht man dafür nicht 64 Bit??
     
  3. workstour

    workstour Threadersteller Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 02.11.07   #3
    Die Treiber waren als original CD mit bei. Und ob es der neuste Treiber ist, denke ich mal, ist egal, da man es doch so oder so irgendwie (im Bios???) einstellen muss.
     
  4. BowlingX

    BowlingX Registrierter Benutzer

    Im Board seit:
    24.08.05
    Zuletzt hier:
    8.08.16
    Beiträge:
    170
    Zustimmungen:
    0
    Kekse:
    63
    Erstellt: 02.11.07   #4
    Hi,
    in Cubase gibt es eine Option für den Mehrprozessor (Kern) betrieb (Bei den ASIO Geräteeinstellungen). Das solltest du aktivieren. Was für einen Dual Core hast du denn?
    David
     
  5. workstour

    workstour Threadersteller Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 02.11.07   #5
    Oh, wusste ich gar nicht.
    Habe einen P4 Dual Core mit 2,8 GHz
     
  6. BangingRaccoon

    BangingRaccoon Registrierter Benutzer

    Im Board seit:
    09.03.05
    Zuletzt hier:
    8.08.16
    Beiträge:
    266
    Ort:
    Pfalz
    Zustimmungen:
    0
    Kekse:
    127
    Erstellt: 02.11.07   #6
    Wenn die Software keine Dualcore oder 2 Prozessoren unterstützt, bringts auch nichts.
    Und Treiber sind nicht egal, da sie ja die entscheidende Schnittstelle zwischen Hardware und Betriebssystem. bzw Applikation sind !
    Die Treiber auf mitgelieferten CDs sind oft nicht die aktuellsten.
    Allgemein gesagt, immer aktuelle Treiber nutzen wenn möglich und drauf achten ob die gewünschte Software die CPUs überhaupt nutzen kann.
     
  7. workstour

    workstour Threadersteller Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 02.11.07   #7
    Okay, dann werde ich mal schauen nach nem neueren Treiber.

    Vielen Dank!
     
  8. workstour

    workstour Threadersteller Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 03.11.07   #8
    Der Multicore-Modus in Cubase ist sogar schon eingeschalten. Scheint wohl doch am Treiber zu liegen.

    Aber gibt es nicht irgendein Programm, wo man einstellen kann, welcher Kern was benutzen soll? Also Kern 1 meinetwegen nur XP, der 2. Kern den Rest?
     
  9. ars ultima

    ars ultima HCA Recording HCA

    Im Board seit:
    19.03.05
    Zuletzt hier:
    21.11.14
    Beiträge:
    16.702
    Ort:
    Düsseldorf
    Zustimmungen:
    867
    Kekse:
    36.410
    Erstellt: 03.11.07   #9
    Im windows Taskmanager kann man zu jedem Prozess sagen, auf welchen CPUs er laufen soll. Aber ich glaube kaum, dass das für dich was bringt.
    Wobei du könntest damit mal testen, wie gut die Multicore-Unterstützung von Cubase ist. Standardmäßig nutzen alle Prozesse beide CPU Kerne. Wenn du da nur einen Kern anwählst, müsste die CPU Auslastung von Cubase ja theoretisch steigen.
     
  10. sunracer

    sunracer Registrierter Benutzer

    Im Board seit:
    22.12.06
    Zuletzt hier:
    4.12.16
    Beiträge:
    1.192
    Ort:
    Heidelberg
    Zustimmungen:
    26
    Kekse:
    3.648
    Erstellt: 03.11.07   #10
    Hi,
    wenn du im Taskmanager bei "Verlauf der CPU-Auslastung" identische Kurven
    hast stimmt in der Tat etwas nicht.
    Sind die Kurven allerdings unterschiedlich ist alles in Ordung und du erwartest wohl
    etwas zuviel von deinem neuen System.

    Ein P4D Prozessor ist halt doch schon etwas älter und man sollte keine Wunder erwarten.
    Ein Unterschied zwischen einem AMD XP2600+/Singlecore und einem P42800/Dualcore
    ist zwar vorhanden.Der Performanceunterschied ist allerdings kleiner als man vermuten möchte :(

    Außerdem ist nicht nur der Prozessor allein für die Performance verantwortlich,
    sondern resultiert vielmehr aus den unterschiedlichen Komponenten (Chipsatz,Speicher...)
     
  11. workstour

    workstour Threadersteller Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 04.11.07   #11
    Der Verlauf im Taskmanager ist bei beiden CPU-Anzeigen stets gleich.
    Die Komponenten waren alles in einem Bundle: das Mainboard, der CPU incl Kühler und der
    1 GHZ DDR 2 RAM Speicher. Auch schon alles montiert gewesen.
     
  12. ars ultima

    ars ultima HCA Recording HCA

    Im Board seit:
    19.03.05
    Zuletzt hier:
    21.11.14
    Beiträge:
    16.702
    Ort:
    Düsseldorf
    Zustimmungen:
    867
    Kekse:
    36.410
    Erstellt: 04.11.07   #12
    Hast du denn mal - wie von mir oben vorgeschlagen - getestet, ob es einen deutlichen Unterschied gibt, wenn du Cubase einmal auf zwei , und einmal nur auf einer CPU laufen lässt?
     
  13. sunracer

    sunracer Registrierter Benutzer

    Im Board seit:
    22.12.06
    Zuletzt hier:
    4.12.16
    Beiträge:
    1.192
    Ort:
    Heidelberg
    Zustimmungen:
    26
    Kekse:
    3.648
    Erstellt: 04.11.07   #13
    Das ist seltsam.

    Schau mal im Taskmanager unter Prozesse.
    Klicke auf einen Prozess den du gestartest hast(den erkennst du am Benutzernamen), dann rechte Maustaste.In dem erscheinenden Menü solltest du die Funktion "Zugehörigkeit festlegen" sehen.
    Wenn du das anklickst sollte ein Fenster aufgehen das dir anzeigt auf welcher CPU der Prozess ausgeführt wird.Standardmäßig sollten beide CPU´s angewählt sein.

    Sollte diese Funktion bei dir nicht vorhanden sein stimmt in der Tat etwas nicht.
    Dann müsste man mal in der Systemsteuerung/Hardware nachsehen ob auf deinem System die richtige HAL installiert ist.Unter Computer sollte da ACPI-Multiprozessor-PC stehen.Außerdem sollte unter Prozessoren 2x Intel(R) Pentium(R) D CPU 2.80 GHz stehen.
     
  14. workstour

    workstour Threadersteller Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 05.11.07   #14
    @ ars ultima:
    Habe es mit Cubase mal ausprobiert. Beim ausschalten der Multicore-Funktion ändert sich die CPU Anzeige in Cubase, aber nur minimal steigt diese.

    @Sunracer:
    Ja, das Fenster öffnet sich im Taskmanager. Ich kann wählen zwischen Core 0 und Core 1
    Wenn ich da jetzt was auswähle, bleibt es dann so auch bei Neustart von Windows? Und kann ich da nur die Prozesse wählen, die "unter meinem Namen" laufen?
     
  15. sunracer

    sunracer Registrierter Benutzer

    Im Board seit:
    22.12.06
    Zuletzt hier:
    4.12.16
    Beiträge:
    1.192
    Ort:
    Heidelberg
    Zustimmungen:
    26
    Kekse:
    3.648
    Erstellt: 06.11.07   #15
    Windows merkt sich die Zuweisung der Kerne nicht,also musst du nach einem Neustart
    wieder neu auswählen.
    Es lassen sich teilweise auch Prozesse die vom System gestartet wurden gezielt auf
    die Kerne verteilen,aber nicht alle.


    Ich glaube den Vorschlag von ars ultima hast du falsch verstanden.

    Ich denke er meinte:
    1.Cubase starten
    2.In den Taskmanager wechseln
    3.Auf Anwendungen gehen>Cubase wählen>rechte Maustaste>Zu Prozess wechseln
    4.Rechte Maustaste>Zugehörigkeit festlegen
    5.Hier nur bei CPU1 einen Haken setzen.
    6.Mit Cubase einen Song laufen lassen
    7.Jetzt im Taskmanager bei Systemleistung den Verlauf der CPU-Auslastung beobachten.

    Eigentlich müsste nun die Auslastung der zugewiesenen CPU1 höher sein als bei 2
    zugewiesenen Kernen.
     
  16. workstour

    workstour Threadersteller Registrierter Benutzer

    Im Board seit:
    09.09.05
    Zuletzt hier:
    4.03.15
    Beiträge:
    451
    Ort:
    Bremen
    Zustimmungen:
    0
    Kekse:
    32
    Erstellt: 07.11.07   #16
    Habe ich jetzt mal ausprobiert. Cubase ist im Taskmanager von Anfang an auf Core 0 und 1 eingestellt (also ein Häkchen vor beiden Kernen).
    Habe einen ausgeschalten, da ging die CPU-Auslastung natürlich hoch.
     
  17. ars ultima

    ars ultima HCA Recording HCA

    Im Board seit:
    19.03.05
    Zuletzt hier:
    21.11.14
    Beiträge:
    16.702
    Ort:
    Düsseldorf
    Zustimmungen:
    867
    Kekse:
    36.410
    Erstellt: 07.11.07   #17
    Ich meinte eigentlich nicht die CPU-Belastungs-Anzeige im Windows-Taskmanager, sondern in Cubase (Findet man unter "VST-Leistung"). Weil es geht ja darum, inwiefern Cubase wirklich von den zwei CPUs profitiert.
     
  18. der nico

    der nico Registrierter Benutzer

    Im Board seit:
    16.01.05
    Zuletzt hier:
    29.11.16
    Beiträge:
    129
    Zustimmungen:
    0
    Kekse:
    476
    Erstellt: 07.11.07   #18
    welches cubase hast du denn?
    ich hab noch 5.1 da hat es sogar geholfen einen proz auszuschalten da z.b. wenn 2 battery instanzen offen waren gab es auf 2 kernen(intel core2duo 6400,2x2,13ghz) laufend sound aussetzer seit ich einen immer ausschalte und den rest computer auf den andern leg läuft es ohne probleme.und cubase kann wesentlich mehr als mit dem alten athlon 1800+.(ok der ist auch wirklich alt..:rolleyes:)

    es gibt auch programme die das dauerhaft regeln können,leider habe ich keinen link...
     
  19. sunracer

    sunracer Registrierter Benutzer

    Im Board seit:
    22.12.06
    Zuletzt hier:
    4.12.16
    Beiträge:
    1.192
    Ort:
    Heidelberg
    Zustimmungen:
    26
    Kekse:
    3.648
    Erstellt: 07.11.07   #19
    Und das zeigt meiner Meinung nach, daß dein System richtig konfiguriert ist.
    Außer der Multiprozessor-Option gibt es in Cubase Studio 4 keine Möglichkeit, Einfluß
    auf die Prozessorverteilung zu nehmen.

    Meinen Multimedia/Internet-Rechner kann man ganz gut mit deinem System vergleichen.
    Intel P4D/3GHz,1 GB Ram DDR400 ,M-audio Audiophile24/96.

    Ich habe nun mal folgenden Test mit Cubase 4 gemacht:

    Audioprojekt mit 22 Audiospuren (max 16 gleichzeitig),keinerlei Effekte,VSTi´s oder Automation.Zuweisung beider Kerne im Taskmanager für Cubase.
    Ergebnis:
    Cubase Multiprozessorunterstützung an>
    VST-LEISTUNG: zwischen 10 und 15% mit Peaks bis zu 20%
    TASKMANAGER/SYSTEMLEISTUNG/VERLAUF DER CPU-AUSLASTUNG:man sieht schön daß die Rechenleistung auf beide CPU´s verteilt wird.
    Cubase Multiprozessorunterstützung aus>
    VST-LEISTUNG: zwischen 10 und 15% mit Peaks bis zu 20%
    TASKMANAGER/SYSTEMLEISTUNG/VERLAUF DER CPU-AUSLASTUNG::man erkennt deutlich, daß CPU0 die ganze Rechenarbeit macht,während CPU1 träge vor sich hinpennt.

    >Was sagt uns das nun:
    Erstens: die Multiprozessorunterstützung funktioniert.
    Zweitens: anhand der VST-Leistungsanzeige läßt sich, bei diesem Projekt, nicht feststellen ob nun eine CPU oder zwei CPU´s rechnen.


    Etwas anders sieht es mit einem anderen Projekt aus:
    Midiprojekt.10 Halion One Instanzen.Zuweisung beider Kerne im Taskmanager für Cubase.
    Ergebnis:
    Cubase Multiprozessorunterstützung an>
    VST-LEISTUNG: zwischen 35 und 40% mit Peaks bis zu 45%
    TASKMANAGER/SYSTEMLEISTUNG/VERLAUF DER CPU-AUSLASTUNG:man sieht schön daß die Rechenleistung auf beide CPU´s verteilt wird.
    Cubase Multiprozessorunterstützung aus>
    VST-LEISTUNG: zwischen 45 und 50% mit Peaks bis zu 60%
    TASKMANAGER/SYSTEMLEISTUNG/VERLAUF DER CPU-AUSLASTUNG::man erkennt deutlich, daß CPU0 die ganze Rechenarbeit macht,während CPU1 träge vor sich hinpennt.

    >Bei diesem Projekt lässt sich, anhand der VST-Leistungsanzeige, durchaus der Vorteil der zweiten CPU erkennen.Der Performancegewinn ist aber geringer als man eigentlich glauben möchte.


    @workstour:
    Nach deinen bisherigen Schilderungen denke ich mittlerweile, daß dein System ganz normal funktioniert.Einzig das du im Taskmanager, bei Verlauf der CPU-Auslastung, keinen
    Unterschied sehen kannst verunsichert mich ein wenig.
    Ich würde dir vorschlagen noch einmal genauer hinzusehen und gegebenenfalls noch mal zu testen ;)

    edit:was ich noch fragen wollte.
    Was für eine CPU/Mainboard hatte denn dein altes System?
    Hast du eigentlich Komponenten aus dem alten PC im Neuen?
     
  20. Pfeife

    Pfeife Registrierter Benutzer

    Im Board seit:
    30.11.05
    Zuletzt hier:
    3.12.16
    Beiträge:
    5.274
    Ort:
    Erfurt
    Zustimmungen:
    456
    Kekse:
    6.675
    Erstellt: 07.11.07   #20
    KLeiner Tipp, man kann den Taskmanager auch auf Bildschirmgröße aufziehen, dann kann man die kleinsten Abweichungen zwischen beiden Kernen sehen.
     
Die Seite wird geladen...

mapping