GarageBand (MacBook) erkennt E-Piano nicht

von pedram3344, 07.04.17.

  1. pedram3344

    pedram3344 Registrierter Benutzer

    Im Board seit:
    07.04.17
    Zuletzt hier:
    6.05.17
    Beiträge:
    5
    Zustimmungen:
    0
    Kekse:
    0
    Erstellt: 07.04.17   #1
    Hallo liebe Leute,

    Ich habe ein Digital Piano (Classic Cantabile DP-88) und ein MacBook Pro.
    Außerdem hab ich mir letztes Jahr ein Midi zu USB Kabel gekauft, es hat sowohl ein Midi-In als auch ein Midi-Out Stecker, also so ein Dreier-Kabel.
    Link zu einem Foto des Kabels: https://images-na.ssl-images-amazon.com/images/I/81eugKX0foL._SL1500_.jpg

    Dieses hab ich also an mein MacBook angeschlossen und an mein Klavier. An meinem Klavier hab ich hinten nur ein Midi-Out Steckplatz.
    So, wie ich es im Internet gelesen habe, muss wohl das Midi-In vom Kabel in den Midi-Out Steckplatz des Klaviers. So hab ich das auch angeschlossen.

    Dann habe ich GarageBand geöffnet und ab dem Zeitpunkt hatte und habe ich keine Ahnung, wie ich weitermachen muss. Es wurde nämlich kein Gerät oder sonstiges erkannt!

    Was kann ich also machen? Kann es sein, dass der Midi-Stecker meines Klaviers kaputt ist? Wobei es auch an einem anderen Klavier nicht ging (glaub ich, lange her)...


    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Warum will ich überhaupt mein Klavier an mein MacBook anschließen?
    Ich würde den Sound gerne über GarageBand abspielen lassen, damit ich die eingespeicherten Klaviertöne benutzen kann. Die sind bestimmt besser als die des Klaviers.
    Ein Youtuber hat dazu mal ein sehr gutes Video gemacht.
    Link zum Video:
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    Danke für alle Antworten!
     
  2. adrachin

    adrachin Registrierter Benutzer

    Im Board seit:
    06.05.14
    Zuletzt hier:
    19.06.18
    Beiträge:
    6.188
    Ort:
    Blauen
    Zustimmungen:
    1.954
    Kekse:
    13.253
  3. Vinterland

    Vinterland Registrierter Benutzer

    Im Board seit:
    06.04.12
    Beiträge:
    4.510
    Ort:
    Köln
    Zustimmungen:
    1.125
    Kekse:
    16.891
    Erstellt: 07.04.17   #3
    Hallo pedram3344
    Herzlich Willkommen im Forum :hat:
    Richtig :great: :)
    Wenn du das USB/Midi Interface mit dem Piano verbunden hast und anschließend mit dem MacBook, müsstest du eigentlich zuerst einmal einen Hinweis erhalten haben, das ein neues
    Midi Gerät erkannt wurde. Ist das der Fall gewesen, dann kann es auch sein, das du manuell in GarageBand das USB/Midi Interface noch angeben musst.

    Geh mal in die "Audio/Midi" Einstellungen ( GarageBand - Preference) und schau dort mal, ob das USB/Midi Interface dort als Ausgangs- und Eingangsgerät angegeben ist.

    upload_2017-4-7_22-42-43.png
     
  4. pedram3344

    pedram3344 Threadersteller Registrierter Benutzer

    Im Board seit:
    07.04.17
    Zuletzt hier:
    6.05.17
    Beiträge:
    5
    Zustimmungen:
    0
    Kekse:
    0
    Erstellt: 08.04.17   #4
    Hallo Vinterland,
    danke fürs freundliche Willkommenheißen :-).

    Es passiert nichts, wenn ich das Kabel/Interface an das MacBook anschließe..ich denke, das Klavier bzw. das Midi Interface wird nicht erkannt.

    Ich bin auch auf die Stelle gekommen, die man bei dem Foto sieht. Es sieht exakt 1:1 genauso aus wie auf dem Foto, es wird kein Midi Gerät erkannt! :(

    Was kann ich denn dann noch tun?
     
  5. Vinterland

    Vinterland Registrierter Benutzer

    Im Board seit:
    06.04.12
    Beiträge:
    4.510
    Ort:
    Köln
    Zustimmungen:
    1.125
    Kekse:
    16.891
    Erstellt: 08.04.17   #5
    Hast du mal einen anderen USB-Anschluß ausprobiert ?
    Du hast am USB/Midi Kabel Kontrollleuchten. Leuchtet eine dieser Dioden auf, wenn du das Kabel
    mit dem MAC verbindest ?.

    upload_2017-4-8_17-30-11.png

    Das Problem ist, das ich nicht mit MAC arbeite. Ich habe hier aber eine Seite gefunden, die dir
    vielleicht weiterhelfen könnte.

    "Mein USB MIDI-Controller funktioniert nicht am Mac"
     
  6. pedram3344

    pedram3344 Threadersteller Registrierter Benutzer

    Im Board seit:
    07.04.17
    Zuletzt hier:
    6.05.17
    Beiträge:
    5
    Zustimmungen:
    0
    Kekse:
    0
    Erstellt: 08.04.17   #6
    So sieht das aus, wenn ich es anschließe, die grüne Diode leuchtet auf.
    Wenn ich das USB Kabel aus dem MacBook ziehe, leuchtet keine Diode.
    Wenn ich das Midi-Teil aus dem Klavier ziehe, bleibt die Diode aber auf grün.

    Ich schau mir mal den Link an.

    Ps: Ich bedanke mich schonmal für Deine Hilfe!
    --- Beiträge zusammengefasst, 08.04.17 ---
    Ok, ich hab es auch nochmal so getestet, wie es die Seite will.

    Gerät wird nicht vom MacBook erkannt, das ist jetzt klar.

    Dann muss ich wohl ein anderes von Thomann oder so kaufen, weil dieses hier offensichtlich nichts taugt
     

    Anhänge:

  7. Vinterland

    Vinterland Registrierter Benutzer

    Im Board seit:
    06.04.12
    Beiträge:
    4.510
    Ort:
    Köln
    Zustimmungen:
    1.125
    Kekse:
    16.891
    Erstellt: 08.04.17   #7
    Das ist auch korrekt so.
    Die grüne Diode zeigt nur den korrekten Betrieb des Interface an. Wird es vom MacBook getrennt,
    erlischt auch die Anzeige. Nicht aber, wenn der Midi-Anschluß getrennt wird.

    Blinkt denn die rote oder transparente Diode auf, wenn du eine Taste auf dem Key drückst ?.
    Falls ja, wird dadurch angezeigt, das ein Signal vom Key gesendet wird.
    Somit sollte das Interface eigentlich korrekt funktionieren.

    Wie gehst du eigentlich vor, wenn du das Key und das Interface in Betrieb nimmst ?
    Schließt du zuerst alles an und startest dann GarageBand oder wie gehst du vor ?.
    Das wäre vielleicht noch eine Variante....Also zuerst alles anschließen und in Betrieb nehmen
    und dann erst die DAW starten....nicht umgekehrt.
     
  8. pedram3344

    pedram3344 Threadersteller Registrierter Benutzer

    Im Board seit:
    07.04.17
    Zuletzt hier:
    6.05.17
    Beiträge:
    5
    Zustimmungen:
    0
    Kekse:
    0
    Erstellt: 08.04.17   #8
    Nein, die bleibt ausgeschaltet.
    Ich kann es mal probieren, was bedeutet DAW? :D
     
  9. Vinterland

    Vinterland Registrierter Benutzer

    Im Board seit:
    06.04.12
    Beiträge:
    4.510
    Ort:
    Köln
    Zustimmungen:
    1.125
    Kekse:
    16.891
    Erstellt: 08.04.17   #9
    DAW ist die Abkürzung für "Digitale Audio Workstation"....Genaueres kannst du hier auch nochmal darüber nachlesen.

    Normalerweise sollte eine der beiden Lampen blinken, wenn ein Signal vom Piano herausgeht.
    Bevor du das machst, würde ich erst einmal schauen, ob´s auch richtig angeschlossen ist.
     
  10. pedram3344

    pedram3344 Threadersteller Registrierter Benutzer

    Im Board seit:
    07.04.17
    Zuletzt hier:
    6.05.17
    Beiträge:
    5
    Zustimmungen:
    0
    Kekse:
    0
    Erstellt: 08.04.17   #10
    Naja, ich hab wirklich alles richtig gemacht eigentlich...

    Hinten die Midi-In Seite ins Klavier und die Midi-Out Seite halt lose hängen lassen (also nirgendwo anschließen).
    Dann ans MacBook.

    Du hast es eig schon gesagt: Es wird nicht im Geräte Manager erkannt, also ist das Gerät kaputt!

    Lohnt sich eigentlich dieses ganze Setup?

    Ich würde halt über GarageBand den Ton umwandeln (live, während des Spielens) in den Steinway Sound und ihn dann durch On-Ear Kopfhörer hören während ich Klavier spiele...

    Danke nochmals!
     
  11. Vinterland

    Vinterland Registrierter Benutzer

    Im Board seit:
    06.04.12
    Beiträge:
    4.510
    Ort:
    Köln
    Zustimmungen:
    1.125
    Kekse:
    16.891
    Erstellt: 08.04.17   #11
    Naja, kann ich so nicht beantworten.
    Ist der Klang des Pianos denn so schlecht, das du den durch ein PlugIn ersetzen möchtest ?.
    Was für ein PlugIn ist das denn ?.
    Wenn das jetzt ein PlugIn ist, welches in GarageBand schon integriert ist, kann ich mir kaum vorstellen, das es besser sein soll als der Sound des DP-88.
    Wenn man im Bereich Virtueller Instrumente schon einen richtig guten und authentischen Sound haben möchte, legt auch auch einiges an Kohle für sowas auf den Tisch.
    Ausserdem habe ich die Befürchtung, das du mit dieser Variante auch mit Latenzen zu kämpfen hast.
    Keine Ahnung, ob sich das lohnt. So ein USB/Midi Interface kostet bei Thomann um die 15.- €.
    Ausserdem hast du 30 Tage MoneyBack. Da kann ich nur sagen, ausprobieren und wenns nix ist, zurück damit.
     
  12. adrachin

    adrachin Registrierter Benutzer

    Im Board seit:
    06.05.14
    Zuletzt hier:
    19.06.18
    Beiträge:
    6.188
    Ort:
    Blauen
    Zustimmungen:
    1.954
    Kekse:
    13.253
    Erstellt: 09.04.17   #12
    Wir es denn im OS erkannt? Das muss zu finden sein in Audio-Midi-Setup. Da Unterpunkt "Fenster / MIDI-Studio einblenden". Und da muss das Device sein:

    Bildschirmfoto 2017-04-09 um 10.40.21.png
    In dem Fall ist ein physikalisches Device aktiv. Das MPKmini2. Da muss das Interface auftauchen. Wenn nicht, dann muss dafür gesorgt werden, dass es da auftaucht.......
     
Die Seite wird geladen...

mapping