Reaper Midi Learn Problem

von midnight, 24.05.16.

  1. midnight

    midnight Registrierter Benutzer

    Im Board seit:
    20.11.05
    Zuletzt hier:
    2.08.16
    Beiträge:
    173
    Zustimmungen:
    0
    Kekse:
    17
    Erstellt: 24.05.16   #1
    Hi,

    ich nutze Reaper 5.20 mit einem Akai MPK 249 das über ein Presonus Firestudio Mobile mittels Midi angeschlossen ist. Also Firewire. Alles soweit gut.
    Dann hab ich also ein paar Regler und Fader des Keyboards mittels MidiLearm belegt. Fader 1 für Lautstärke Track 1, Fader 2 für Lautstärke Track 2 und Fader 8 für Lautstärke Master
    Track 1 hat ein VSTi belegt, den Oatmetal Synth. (Ist aber egal, mit anderen Synths tritt das folgende Problem auch auf) Ich hab Drehknopf 1 auf den Filter Cutoff gelegt, Drehknopf 2 auf Filter Resonance.
    An sich funktioniert das Setup auch sehr gut, nur tritt das Phänomen auf, dass die Belegung manchmal nicht erkannt wird. Gerade am Anfang, wenn das Projekt neu geladen ist. Aber es kann auch zwischendrin mal sein, dass Reaper
    einfach nicht auf die Eingabe der Knöpfe oder Regler des Keyboard reagiert. Es ist keine Latenz, denn die Eingabe passiert nicht verzögert, sondern gar nicht. Erst wenn ich sekundenlang den Fader oder Knopf bewegt habe, "greift" Reaper wieder und dann gehts.
    Midi kommt stets an, ich hab den MidiSniffer laufen und da sieht man sehr schön wie die Signale ankommen. Mapping passt auch, denn es geht ja an sich, nur eben manchmal nicht.
    Es ist auch egal ob das Keyboard direkt über USB angeschlossen ist oder über das Firestudio. Immer das Gleiche.
    Die Kontrollen sind im "Absolute" Mode gemapped, mit Soft Takeover. Schalte ich in dem Mapping-Dialog das Soft Takeover ab, funktioniert alles deutlich besser. Hier scheint alles normal zu laufen. Aber ohne Soft Takeover macht die Bedienung nur den halben Spaß.
    Was könnte man noch tun, probieren? Oder jemand ne Idee noch?

    thx
     
  2. adissu

    adissu Registrierter Benutzer

    Im Board seit:
    08.11.13
    Zuletzt hier:
    16.02.18
    Beiträge:
    162
    Ort:
    Großraum Stuttgart
    Zustimmungen:
    45
    Kekse:
    415
    Erstellt: 15.07.16   #2
    Hi,

    welchen Midi Modus hast du denn ausgewählt. Soweit ich das weiß, funktioniert das nur mit Latch, Touch und Write. Gerade ist die Version 5.22 rausgekommen, die noch zusätzlich den Latch Preview Modus hat. Damit geht es vermutlich auch.

    Das Problem, dass beim Laden des Projekts die Werte nicht am Controller ankommen habe ich ganz aktuell auch. Habe dazu einen Thread im Reaper Forum gestartet. Bislang hat aber noch keiner darauf geantwortet. Das Problem ist, dass die Midiwerte nicht an den Controller zurückgeschickt werden.
    Ich habe auch noch keine Idee, wie das funktioniert in Reaper. Ich hoffe nicht, dass man dafür irgendeine selbergebastelte Lösung braucht. Im Prinzip müsste die Regel bzgl. dem Senden der Werte an den Controller so lauten: Wenn Quelle für Werteänderungen != (ungleich) Controller, dann sende die Werte an den Controller.

    Ist das auch der Anwendungsfall bei dir?
     
  3. adissu

    adissu Registrierter Benutzer

    Im Board seit:
    08.11.13
    Zuletzt hier:
    16.02.18
    Beiträge:
    162
    Ort:
    Großraum Stuttgart
    Zustimmungen:
    45
    Kekse:
    415
    Erstellt: 18.07.16   #3
    Also, ich habe inzwischen rausgefunden, dass Reaper kein Midi-Feedback kann - für frei programmierte Controller. Es geht wohl für Control Surfaces, die auch als solche mit fest vordefinierten Funktionen eingebunden sind aber nicht wenn man über Midi-Learn. Deshalb werden keine Werte, die in Reaper eingestellt werden, an einen Controller zurückgegeben. Es gibt eine Feature Request im Forum. Je mehr Leute dafür voten, umso schneller wird das hoffentlich umgesetzt. Es gibt derzeit wohl einen Workaround mit dem OSC Protokoll, da bin ich aber noch nicht ein-/durchgestiegen.
     
  4. midnight

    midnight Threadersteller Registrierter Benutzer

    Im Board seit:
    20.11.05
    Zuletzt hier:
    2.08.16
    Beiträge:
    173
    Zustimmungen:
    0
    Kekse:
    17
    Erstellt: 22.07.16   #4
    Hey, Danek für die Antwort! Ich war im Urlaub, daher antworte ich erst heute :D
    Is ja sehr ärgerlich das Ganze. Im Grunde habe ich das gleiche Szenario, das Du auch beschreibst. Verstehe aber nicht ganz, wie da Latch/Touch und Write ins Spiel kommt, denn das sind ja die Editieroptionen vom Envelope, die haben doch eigtl mit den eigtl Mapping erstmal nix zu tun, oder?

    Schade dass der controller auch ein Feedback von Reaper braucht, um korrekt mit Soft Takeover arbeiten zu können. Ohne Soft Takeover geht es ja. Na mal schaun, ob der Feature Request was bringt. Ich geh gleich mal voten :)

    bis dann
    midnight
     
  5. adissu

    adissu Registrierter Benutzer

    Im Board seit:
    08.11.13
    Zuletzt hier:
    16.02.18
    Beiträge:
    162
    Ort:
    Großraum Stuttgart
    Zustimmungen:
    45
    Kekse:
    415
    Erstellt: 22.07.16   #5
    Ja, das wird wohl ein Langläufer...

    Ich habe mir unabhängig davon inzwischen das iConnectivity MIDI4+L gekauft. Da ich für jeden Song die Werte über das iPad (OnSong) rausschicke, habe ich das jetzt so geroutet, dass sowohl Reaper als auch mein MIDI Controller die Werte bekommen. Damit ist meine ganz akute Situation fürs erste gelöst. Wenn ich aber in Reaper oder dem VSTi was ändere, bleibt meinem MIDI Controller verborgen...

    Danke fürs mitvoten!

    Latch, Touch, Write ist - soweit ich das verstanden habe - notwendig, weil man ja im Prinzip im Recording Modus unterwegs ist und nur in diesen Modi etwas live anpassen kann. Vielleicht liest das aber auch jemand, der mehr Ahnung hat als ich und kann Licht ins Dunkel bringen!
     
Die Seite wird geladen...

mapping