Töne hängen in Mainstage

von chris93329, 19.01.20.

Sponsored by
Casio
  1. chris93329

    chris93329 Registrierter Benutzer

    Im Board seit:
    19.01.20
    Zuletzt hier:
    21.01.20
    Beiträge:
    2
    Zustimmungen:
    0
    Kekse:
    0
    Erstellt: 19.01.20   #1
    Hallo,
    ich hab viele Foren schon nach meinem Problem durchstöbert. Hab auch schon manche Dinge probiert, aber aktuell funktioniert mein Mainstage nicht 100-%ig.
    Vielleicht hätte ja jemand die ultimative Lösung. Ich würde mich freuen, wenn mir jemand noch ein paar Ratschläge geben könnte. Bin wirklich über jeden Tipp dankbar.

    zu meinem System:
    Macbook Pro 2012, 750 GB SSD, 16GB Ram
    Mainstage 3 (aktuelles Update)

    Ich habe in meinem Concert ca. 20 Patches. Ich habe Komplete 8 von NI mit allen Plugins und Inhalten installiert. Ein paar weitere Libraries sind auch nich drauf. Aus diesem Grund ist meine SSD gut belegt. Ich hab von den 750 GB noch ca. 100 GB frei.
    In den Patches verwende ich meistens die Bibliothek aus Mainstage/ Logic, Inhalte der Kontakt 5 Library, Inhalte aus OP-X Pro. Teilweise sind die Patches ziemlich klein (ein paar MB), teilweise aber gut groß (1 GB, wenn der Gentleman ins Spiel kommt).
    Meine CPU-Auslastung liegt aber absolut im grünen Bereich, meistens einstellig. Die Speicherauslastung bei max 50%, meistens aber im unteren Drittel).
    Hab schon einiges probiert: Buffer im Mainstage und Kontakt auf 128 bzw 256 gestellt. Multicore im Kontakt deaktiviert, verschiedenste USB-Kabel ausprobiert, Mainstage an 2 verschiedenen Masterkeyboards getestet.
    Nun hab ich einige GB auf der SAD frei gemacht.
    Ich bilde mir ein, dass es bissl besser geworden ist. Jedoch hab ich immer noch das Problem, dass während des Gigs manche Töne einfach hängen bleiben, nicht im Sinne wie Sustain, sondern Mainstage stockt kurz. Backing Samples laufen aber ohne Unterbrechung weiter.
    Hilft es was, wenn ich die kompletten Bibliotheken auf eine externe SSD mit Thunderbolt auslagere. Oder was könnte ich sonst noch tun?

    LG und vielen, vielen Dank für eure Hilfe!
    Christian
     
  2. FantomXR

    FantomXR Keyboardmanufaktur Berlin

    Im Board seit:
    27.01.07
    Zuletzt hier:
    26.02.20
    Beiträge:
    3.762
    Ort:
    Berlin
    Zustimmungen:
    922
    Kekse:
    6.534
    Erstellt: 19.01.20   #2
    Lieber Christian,

    so ganz konkret fassen kann ich es noch nicht, was bei dir passiert. Also es bleiben keine Töne liegen, die du per PANIC-Befehl abschalten musst sondern es sind eher Dropouts?

    Welches Interface verwendest du?

    LG,
    Christian
     
  3. chris93329

    chris93329 Threadersteller Registrierter Benutzer

    Im Board seit:
    19.01.20
    Zuletzt hier:
    21.01.20
    Beiträge:
    2
    Zustimmungen:
    0
    Kekse:
    0
    Erstellt: 19.01.20   #3
    Hallo Christian,
    es ist so, dass sich der Ton quasi kurz einfriert, wie auch Mainstage. Nach ca 2s läuft wieder alles flüssig.

    LG
    Christian
     
  4. drevi

    drevi Registrierter Benutzer

    Im Board seit:
    12.11.14
    Beiträge:
    129
    Ort:
    Pforzheim
    Zustimmungen:
    30
    Kekse:
    390
    Erstellt: 21.01.20   #4
    Welche OS genau?
     
  5. dr_rollo

    dr_rollo Mod Musik-Praxis Moderator HFU

    Im Board seit:
    26.07.04
    Zuletzt hier:
    26.02.20
    Beiträge:
    11.530
    Ort:
    Celle, Germany
    Zustimmungen:
    3.812
    Kekse:
    53.123
    Erstellt: 11.02.20   #5
    Ich hab ähnliche Symptome kürzlich bei einem Macbook festgestellt, etwas was ich auf meinem bisherigen noch nie hatte.

    Mein bisheriges: Macbook Pro, 2012, i5, 16GB und 512SSD - keinerlei Probleme, keine Hänger, keine Abstürze.
    Das andere: Macbook Pro Retina, mid 2012, i7, 8GB und 256SSD - beim ersten Test gleich Hänger, sobald etwas speicherintensivere Patches, z.B. Session Horns von NI zum Einsatz kamen

    Diese 'Hänger' hab ich mal auf den mit 8GB kleineren Arbeitsspeicher geschoben habe, weniger auf den Prozessor, der ja als i7 perfomanter sein sollte als mein bisheriges mit i5. Auf der Platte war noch mehr als ausreichend Platz. Das würde ich als Ursache ausschließen. Und das Auslagern auf eine externe würde die Sache sicherlich nicht verbessern.
     
Die Seite wird geladen...

mapping