Vst Instrumente und Midi Controller

von ReiRo, 16.05.16.

  1. ReiRo

    ReiRo Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 16.05.16   #1
    Hallo zusammen.

    Ich habe mir letztens ein Akai MPK mini zugelegt, um ihn als Controller in Reaper zu nutzen, sowie um Midi Instrumente damit leichter aufzunehmen.
    Letzteres gestaltet sich leider schwieriger als Gedacht, da die aufgenommen Instrumente wie, z.B. der EZ Drummer nie on Spot sind. Ich könnte damit leben,
    wenn es mal ein zwei "Beats" sind aber gleich alle, so das ich ein aufgenommene Drumspur in mühseliger Kleinstarbeit her richten muss, kann es doch auch nicht sein?!

    Ich bin neu auf dem Gebiet und habe so meine Einsteigerschwierigkeiten aber ich hoffe ich stelle mich einfach zu blöd an und es gibt eine einfache Lösung für das Problem.

    Kann mich da bitte Jemand erleuchten?
    LG
     
  2. The_Dark_Lord

    The_Dark_Lord HCA Recording HCA

    Im Board seit:
    24.03.09
    Zuletzt hier:
    14.11.18
    Beiträge:
    5.879
    Ort:
    Wien
    Zustimmungen:
    1.855
    Kekse:
    19.192
    Erstellt: 16.05.16   #2
    Bist du dir denn sicher, dass du die jeweiligen Tasten auch exakt zum richtigen Zeitpunkt gedrückt hast? Hier geht's um Millisekunden.

    Recording ist halt immer ehrlich - und die eigenen Fehler treten hier dann deutlich zutage.
     
    gefällt mir nicht mehr 1 Person(en) gefällt das
  3. exoslime

    exoslime Helpful & Friendly User HFU

    Im Board seit:
    29.08.06
    Zuletzt hier:
    15.11.18
    Beiträge:
    4.561
    Zustimmungen:
    7.659
    Kekse:
    122.567
    Erstellt: 16.05.16   #3
    hi

    kann es sein das deine Systemlatenz, sprich, Verzögerung des Signals einfach zu hoch ist, und es deshalb mit dem timing nicht so klappt wie du gerne möchtest?
    gerade wenn man wie du VST Instrumente live via Controller einspielen möchte, ist es ratsam die Latenz über die Buffergrösse in deinem Asio Treiber auf einen niedrigen Wert wie zb 32, 64 oder 128 samples runterzuschrauben, damit die Verzögerung nur sehr gering ist..
    (Wenn du dann deinen Song im Anschluss nach mischst, kannst du gerne die Buffergrösse auf 512 oder 1024 hochdrehen damit du genügend Systemleistung für viele Plugins zur Verfügung hast)

    lg
    Chris
     
  4. ReiRo

    ReiRo Threadersteller Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 16.05.16   #4
    @The Darklord
    Hmm - denke schon. Zumindest wäre ich zufrieden wenn es sich nach dem aufnehmen in etwa so anhören würde, wie wenn ich es einfingere. Klar ist nicht alles mega tight und kann ggfs nachgerückt werden...
    Ich spreche hier aber schon eher von einem merklichen und kontinuierlichen Offbeat zwischen dem aufgenommen Drumming z.B. und dem Rest des Tracks/Metronom

    @exoslime
    Danke, das habe ich versucht. Asiotreiber war bisher immer mit einer Buffergröße von 512 am werkeln. Habe es bei 128 versucht und alle anderen Vsts deaktiviert. Das Resultat war leider das selbe.
    Probiert habe ich das sowohl mit dem Focusrite Scarlet 2i4, als auch meinem Pod GX.

    Besten
     
  5. Telefunky

    Telefunky Registrierter Benutzer

    Im Board seit:
    25.08.11
    Zuletzt hier:
    15.11.18
    Beiträge:
    14.673
    Zustimmungen:
    4.972
    Kekse:
    38.297
    Erstellt: 17.05.16   #5
    ich gehe mal davon aus, dass Quantisierung, Swing und ähnliches nicht aktiviert ist...
    dann einfach das Metronom (Click) mitlaufen lassen und auf eine Spur aufzeichnen
    zu dem Metronom exakt das gleiche 'einklopfen'
    dann sieht man ob eine Abweichung vorliegt, wie weit sie reicht und ob sie konstant ist
    falls es abweicht, trägt man das an entsprechender Stelle in die Latenzkompensation ein

    cheers, Tom
     
  6. ReiRo

    ReiRo Threadersteller Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 17.05.16   #6
    Swing sagt mir gerade nix aber Quantisierung ist nicht aktiv.
    Stumpf viertel auf das Metronom gespielt ergeben die Abweichung von der ich spreche.

    Wie, was an welcher Steller eintragen um zu kompensieren?

    Besten
     
  7. The_Dark_Lord

    The_Dark_Lord HCA Recording HCA

    Im Board seit:
    24.03.09
    Zuletzt hier:
    14.11.18
    Beiträge:
    5.879
    Ort:
    Wien
    Zustimmungen:
    1.855
    Kekse:
    19.192
    Erstellt: 17.05.16   #7
    Manuelle Latenzkompensation.
    Wie das in deiner DAW funktioniert, steht sicherlich im Handbuch ;)
     
    gefällt mir nicht mehr 2 Person(en) gefällt das
  8. ReiRo

    ReiRo Threadersteller Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 18.05.16   #8
    Danke aber das Manual hat mir nicht weiter geholfen leider.
    Keinen plan, es ist ja auch nicht unbedingt nur Latenz. Sprich das eingespielte geht dem generellen Tempo auch voraus.
    Live die Drums per Ez Drummer und nem Gitarristen zocken läuft übrigens ohne merkliche Latenz.
    Wenn beides zusammen aufgenommen wird ist der Beat off...

    Seis drum, ich werd mich mal anderweitig umhören, andere Vsts oder sogar DAWs Probieren oder halt damit leben müssen :/

    Danke euch
     
  9. hairmetal81

    hairmetal81 Registrierter Benutzer

    Im Board seit:
    20.08.12
    Beiträge:
    12.544
    Zustimmungen:
    9.957
    Kekse:
    33.696
    Erstellt: 18.05.16   #9
    Auf welcher Seite hast du nachgelesen?


    Da es auch bei blossem Durchspielen lt. Aussage zu keinen nennenswerten Latenzen kommt, kann es eigentlich nur an der Spielweise liegen - nicht am Interface!


    Was erhoffst du dir davon?
    Genauer wird das eingespielte dadurch auch nicht!



    PS. Man "zockt" keine Instrumente, man spielt Instrumente!



    :hat:
     
  10. The_Dark_Lord

    The_Dark_Lord HCA Recording HCA

    Im Board seit:
    24.03.09
    Zuletzt hier:
    14.11.18
    Beiträge:
    5.879
    Ort:
    Wien
    Zustimmungen:
    1.855
    Kekse:
    19.192
    Erstellt: 18.05.16   #10
    Beides sind Symptome die auf fehlenden Latenzausgleich schließen lassen.

    -> Zwischen Tastendruck und dem "Abspeichern" der Note vergeht eine gewisse Zeit.
    Dies fällt natürlich nicht auf, wenn du mit EZDrummer "zockst" und gleichzeitig ein Gitarrist dazu spielt - denn hier wird ja nichts abgespeichert, sondern nur wiedergegeben.

    Das Aufnehmen der Gitarre (per Mikrofon oder DI...) erfolgt quasi latenzfrei, das Abspeichern der MIDI-Noten offenbar nicht.

    Beim Einspielen wäre dies nicht zu bemerken, bei der anschließenden Wiedergabe der aufgenommenen Dateien müsste das Schlagzeug (also die MIDI Noten) permanent um einen Sekundenbruchteil zu spät kommen.

    Trifft das zu?
    ja?

    Dann fehlt der Latenzausgleich bei der MIDI-Aufnahme.
     
  11. ReiRo

    ReiRo Threadersteller Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 18.05.16   #11
    Nun gut, ich ignoriere Haarmetal jetzt einfach mal und gebe euch mal ein Beispiel wie sich das aufnemen der Vst Drums bei mir gestaltet.

    Hier kann man sich das eingespielte anhören und das Beispielbild ist passend dazu:
    http://www34.zippyshare.com/v/Q4vMtwI2/file.html

    Bsp.png

    Alle weiteren Plugins etc. deaktiviert, gefühlt latenzfrei und unter Berücksichtigung den hier erhaltenen Tipps .
    Wie zu sehen und hören, ist der Beat immer etwas im Voraus und ich habe mir echt Mühe gegeben auf dem Punkt zu sein.
    Schlagzeug und Gitarre kann ich spielen und auch bei Freunden, die hier teilweise aufnehme, erhalten wir die selben Resultate.
    Deswegen schließe ich menschliches versagen aus ;)
     

    Anhänge:

    • Bsp.png
      Dateigröße:
      20,8 KB
      Aufrufe:
      43
  12. hairmetal81

    hairmetal81 Registrierter Benutzer

    Im Board seit:
    20.08.12
    Beiträge:
    12.544
    Zustimmungen:
    9.957
    Kekse:
    33.696
    Erstellt: 18.05.16   #12
    MIDI hat ja so gesehen keine Latenzen... (höchstens das verwendete Drummodul oder TMI - was sich aber so gut wie ausschliessen lässt...)

    Wenn das Gitarrensignal via DI unverzögert aufgezeichnet wird, kann es eigentlich auch nicht am Interface liegen...

    Bliebe noch die Frage, wie es mit den eigentlichen VSTs aussieht... theoretisch müsste dann nicht nur EZD, sondern eben auch das eingesetzte Gitarren-VST eine Verzögerung generieren.
    --- Beiträge zusammengefasst, 18.05.16 ---

    Ganz ehrlich? Ich höre da jetzt nichts auffälliges...

    (...abgesehen davon, dass ich mir gewünscht hätte, du hättest das mp3 über die boardinterne Funktion hochgeladen oder via Soundcloud angehängt...)


    Quantisier' die MIDI-Spur nachträglich, wenn dich nur die Optik stört.
     
  13. Telefunky

    Telefunky Registrierter Benutzer

    Im Board seit:
    25.08.11
    Zuletzt hier:
    15.11.18
    Beiträge:
    14.673
    Zustimmungen:
    4.972
    Kekse:
    38.297
    Erstellt: 18.05.16   #13
    wieso ignorierst du ihn, wenn du dass was er schreibst mit dem Screenshot bestätigst ? :gruebel:
    die Midi Events sind vorgezogen, weil das Programm bereits die Latenz des Tonerzeugers berücksichtigt
    kein VST ist latenzfrei - kein einziges - das ist im Prinzip begründet
    und Reaper geht davon aus, dass du mit den Events ein VST triggern willst, ergo... vorgezogen
    ob die default Einstellung bei dir passt, musst du selbst ermitteln (und ggf korrigieren)
    deswegen der entsprechende Hinweis von Hairmetal

    cheers, Tom
     
  14. ReiRo

    ReiRo Threadersteller Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 18.05.16   #14
    Naja, das ist ein simpler und kurzer Beat und für mich ist es dort schon deutlich wahrnehmbar und störend.
    Wenn der Beat komplexer und länger wird fällt es weit mehr auf.
    Ich nehme es so auf das es Spot on ist, warum es sich bei der Aufnahme dieses kleine bisschen nach vorne verrückt ist mir nicht schlüssig, nervig und kostet mich unnötig Zeit.
    Dachte dafür würde es evtl eine relativ einfache Erklärung geben, da ich mich wie gesagt mit Midicontrollern (noch) nicht gut auskenne?!
     
  15. Telefunky

    Telefunky Registrierter Benutzer

    Im Board seit:
    25.08.11
    Zuletzt hier:
    15.11.18
    Beiträge:
    14.673
    Zustimmungen:
    4.972
    Kekse:
    38.297
    Erstellt: 18.05.16   #15
    gibt es... und sie steht genau darüber in meinem vorigen Beitrag
    Midi ist Midi - das kannst du (und auch sonst niemand) hören - es ist ein Steuersignal
    das zugehörige (geplante) Audio-Ereignis (Drum VST) findet immer um den einfachen Latenzbetrag später statt
    deswegen ist der 'Trigger' auf der Zeitachse vorgezogen
    würdest du stattdessen (wie vorgeschlagen) das Audio Drumsignal aufzeichnen, liegt es höchstwahrscheinlich exakt im Raster

    cheers, Tom
     
  16. ReiRo

    ReiRo Threadersteller Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 18.05.16   #16
    Danke sehr!

    Sorry aber ich stehe noch ein wenig auf dem Schlauch....
    Wie nehme ich den das Audio Drumsignal auf anstelle des Steuersignals?
     
  17. exoslime

    exoslime Helpful & Friendly User HFU

    Im Board seit:
    29.08.06
    Zuletzt hier:
    15.11.18
    Beiträge:
    4.561
    Zustimmungen:
    7.659
    Kekse:
    122.567
    Erstellt: 18.05.16   #17
    @ReiRo
    schau mal bitte in deine Einstellung was dort unter Aufnahme Versatz eingestellt ist (unter Cubase heisst diese Funktion zumindest so, ich denke mir Reaper hat bestimmt das auch an Board, vielleicht nur unter anderem Namen)

    der Aufnahme Versatz ist eine Funktion zur manuellen Zeitkorrektur bei der Aufnahme und kann dafür verwendet werden solche Zeitunterschiede zu erzeugen, bzw auch zu verhindern.

    das hat nichts mit der automatischen Latenzkorretkur zu tun, sondern rein um einen Offset bei der Aufnahme.

    Spiele hier etwas mit den Werten rum bis du ein für dich zufriedenstellendes Ergebniss erziehlt hast und die Midi Spuren dann an der Position stehen wo du sie gerne hättest und wo sie sich auch in Time anhört.

    :great:
     
    gefällt mir nicht mehr 1 Person(en) gefällt das
  18. hairmetal81

    hairmetal81 Registrierter Benutzer

    Im Board seit:
    20.08.12
    Beiträge:
    12.544
    Zustimmungen:
    9.957
    Kekse:
    33.696
    Erstellt: 18.05.16   #18

    Diesen Hinweis kann man im Selbstversuch ganz einfach nachprüfen, übrigens... ;)
    --- Beiträge zusammengefasst, 18.05.16 ---
    Drummodul Audio-Ausgänge mit den Line-Eingängen des Intefaces verbinden,
    Audiospur erstellen,
    Line-Eingänge des Interfaces dieser Spur zuweisen.
     
  19. ReiRo

    ReiRo Threadersteller Registrierter Benutzer

    Im Board seit:
    05.05.09
    Zuletzt hier:
    23.10.18
    Beiträge:
    978
    Zustimmungen:
    173
    Kekse:
    3.710
    Erstellt: 18.05.16   #19
    @exoslime
    Danke sehr, das habe ich verstanden und das hat mir geholfen! ;)
    In den Reaper Preferences unter Audio/Recording/ "use audio driver reported latency" bin ich fündig geworden und nu ist es so wie es sein sollte!

    Besten Dank euch allen für die Hilfe.
    LG
     
    gefällt mir nicht mehr 1 Person(en) gefällt das
Die Seite wird geladen...

mapping