Gitarre spielen in Echtzeit über PC

von synthesist, 13.08.08.

  1. synthesist

    synthesist Registrierter Benutzer

    Im Board seit:
    13.08.08
    Zuletzt hier:
    26.08.08
    Beiträge:
    7
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 13.08.08   #1
    Hallo,

    nachdem ich 4 Jahre mit meinem Hobby pausiert habe, habe ich nun wieder Spaß daran gefunden und wollte auch mal den PC dafür einsetzen. Ich habe mir in dem Musikladen um die Ecke ein "M-Audio Fast Track USB" USB Gerät, und eine Creative X-Fi Xtreme Audio Soundkarte gekauft. Beim dem Gerät war die Software "GT Player" dabei. Bei den Einstellungen habe ich als Eingang das usb Gerät und als Ausgang natürlich die Soundkarte gewählt. Das funktioniert auch alles wunderbar und die Sounds sind für meine Verhältnisse auch wirklich gut, allerdings bekomme ich dieses Problem mit der Verzögerung nicht los.

    Wenn ich ohne diesen GT Player spiele, gibt es keine Verzögerung, alles bestens. Sobald aber das Programm aktiviert ist, habe ich eine deutliche Latenz. Auch habe ich den Asio Treiber und hab ein wenig damit rumgespielt. Nichts jedoch brachte irgendeine Verbesserung. Wenn ich bei GT Player die als output "asio creative" auswähle, meckert das programm und sagt in-und output müssen beide asio sein.

    Na ja, jedenfalls bin ich bald am verzweifeln da ich schon 3 Tage hier mit ausprobieren verbracht habe.
    Ganz Allgemein: Hat irgendjemand einen Tip woran das liegen könnte. Gibt es vielleicht irgendwas banales das ich nicht berücksichtigt habe ?
    Danke im voraus, Gruß Steve
     
  2. cx01

    cx01 Registrierter Benutzer

    Im Board seit:
    11.05.08
    Zuletzt hier:
    31.01.16
    Beiträge:
    669
    Zustimmungen:
    3
    Kekse:
    2.891
    Erstellt: 13.08.08   #2
    Du hast dir den Fast Track UND eine X-Fi gekauft? Soweit ich das sehe, hat der Fast Track selbst einen Ausgang, den du benutzen könntest. Das würde ich auch tun, denn da dürfte die Latenz deutlich geringer sein als bei der X-Fi.
     
  3. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    7.12.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 14.08.08   #3
    welcher Wahnsinnige Verkäufer hat Dir denn 2 Soundkarten angedreht !?
    nimm das Fast-Track - schlies da die Gitarre an und die Boxen - dann stellst Du in dem Fasttrack Controlpanel die Buffer bzw. Latenz klein ein und dann sollte das gehen.

    Und die Creativ bringst Du zurück :)
     
  4. synthesist

    synthesist Threadersteller Registrierter Benutzer

    Im Board seit:
    13.08.08
    Zuletzt hier:
    26.08.08
    Beiträge:
    7
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 14.08.08   #4
    Hallo
    Tschuldigung wenn ich so dumm fragen muss, aber das ist ziemliches Neuland für mich... Wie soll ich den als Ausgang benutzen. Hier ist die Rückseite des Gerätes:

    http://de.m-audio.com/images/global/media_hqpics/FastTrack_back_RGB.jpg

    Momentan gehe ich mit der großen Klinke in den rechten Eingang und per USB eben in den Rechner..?

    Die Latenz war vorher mit der alten onboard Karte genau die gleiche, die x-fi hat keinerlei verbesserung des problems gebracht, das verstehe ich einfach nicht.
     
  5. synthesist

    synthesist Threadersteller Registrierter Benutzer

    Im Board seit:
    13.08.08
    Zuletzt hier:
    26.08.08
    Beiträge:
    7
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 14.08.08   #5
    Ah Danke mal,
    jetzt versteh ich das glaub ich...ich bäruchte so gesehen die pc soundkarte gar nicht ...
    ich kann ja die Boxen direkt hinten anschließen... <ausprobier> :)
     
  6. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    7.12.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 14.08.08   #6
    ja - das ist ein vollständiges Audio-Interface bzw. eine externe Soundkarte! mit Eingängen und Ausgängen.
    an die 2 Cinchbuchsen schliest Du die Boxen an - fertig
     
  7. synthesist

    synthesist Threadersteller Registrierter Benutzer

    Im Board seit:
    13.08.08
    Zuletzt hier:
    26.08.08
    Beiträge:
    7
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 14.08.08   #7
    Mensch danke für die Info mit der Soundkarte. Da wäre ich glaub ich nie drauf gekommen. Der Verkäufer hat mir natürlich keine 2 Soundkarten angedreht, allerdings konnte er mir "Media Markt like" auch nur vorlesen was auf der Verpackung stand. Ich bin da nichtsahnend hin mit dem Anliegen "will Gitarre an den PC anschließen.."
    Ich hatte mir die Soundkarte geholt, weil ich eben gelesen habe, dass man ne anständige Karte für Musik am PC braucht. War mehr eine Verzweiflungstat, weil ich der Meinung war, die onboard Karte packt das eben nicht.

    Also wenn ich nun als Ein-und Ausgang das USB Gerät verwende und die Boxen vom PC direkt am Kopfhörerausgang des Gerätes einstecke, funktioniert es auch mit der Software latenzfrei. An dem Gerät kann ich eine minimale Latenz von 128ms einstellen. Was ist eigentlich so eine Grenze für das Spielen in Echtzeit ?

    Nur verstehe ich nicht: Diese Karte soll ja theoretisch Latenzen bis 2ms schaffen, trotzdem steig ich da nicht durch. Wenn ich als Ausgang die X-Fi Karte nehme, habe ich die gleiche Riesenlatenz wie bei der onboard Karte :confused: (Und die Karte hat ja sogar einen Musikaufnahmemodus, auf den ich auch geschaltet hatte) Dennoch, was den "normalen" Betrieb der Karte angeht, kann man schon von einem deutlich beseren Klang gegenüber des onboard sounds sprechen.
     
  8. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    7.12.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 14.08.08   #8
    ich kenne das M-Audio Fast Track USB nicht, daher kann ich über die Einstellungen nicht viel sagen - aber 128ms sind extrem viel - wobei angezeigte und reale Latenz weit auseinander liegen können, so 10ms sind ein guter Wert, bei dem man die Verzögerung noch nicht wahrnimmt.

    2ms halte ich für Utopisch, da selbst die teuren und mit die besten RME-Interface so um die 4ms haben.

    Letztlich ist aber auch die Rechenleistung des PCs ein Faktor
    das Signal geht in das Interface, wird von Analog nach Digital gewandelt - ca. 1ms - dann werden die Daten übers USB geschickt nochmal 1ms, dann müssen im Rechner die Effekte dazu gerechnet werden ??ms - und dann das ganze wieder zurück über USB und in den Digital-Analog-Wandler wieder 2ms ...

    Für Deine Anwendung wird hier gerne das
    http://www.musik-service.de/line-toneport-ux-1-prx395752634de.aspx
    genommen und wenn noch Gesang oder so dazu kommen soll das
    http://www.musik-service.de/Line6ToneportUX-2-prx395752635de.aspx
     
  9. Kfir

    Kfir HCA Recording Ex-Moderator HCA

    Im Board seit:
    24.10.04
    Zuletzt hier:
    4.03.14
    Beiträge:
    3.174
    Ort:
    Plochingen (Stuttgart/Esslingen)
    Zustimmungen:
    1
    Kekse:
    5.730
    Erstellt: 14.08.08   #9
    Die 128 sind sicherlich SAMPLES, also Buffersize. Und nicht die direkte Latenz.
     
  10. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    7.12.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 14.08.08   #10
    ja - das würde Sinn ergeben - hab ich nicht dran gedacht.
     
  11. synthesist

    synthesist Threadersteller Registrierter Benutzer

    Im Board seit:
    13.08.08
    Zuletzt hier:
    26.08.08
    Beiträge:
    7
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 14.08.08   #11
    einleuchtende Erklärung ;)
    Also der Rechner hat genügend Ghz und 2GB RAM, das muss mehr als reichen.

    eine Frage hätte ich noch: Da ich derzeit nur ein Lautsprechersytem habe, und nicht jedesmal zwischen Gerät und Soundkarte umstöpseln möchte (wenn ich bei dieser GT Player Software auf Aufnahme schalte, Live einspiele und dann wieder anhören möchte ,muss ich zuerst wieder umstöpseln da die Boxen ja am Kopfhörerausgang des Gerätes hängen=. Wie kann ich das am besten machen ?

    Gruß aus Hamburg
     
  12. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    7.12.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 14.08.08   #12
    hol Dir einen Adapter Klinkenbuchse 3,5mm Stereo auf 2x Cinch-Stecker - und dann an die 2 Cinch-Anschlüsse des M-Audio (Output L/R)

    oder was sind denn an den Boxen für Anschlüsse ? evtl. dann ein Kabel was in die Boxen passt und am anderen Ende Cinch hat.
     
  13. synthesist

    synthesist Threadersteller Registrierter Benutzer

    Im Board seit:
    13.08.08
    Zuletzt hier:
    26.08.08
    Beiträge:
    7
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 14.08.08   #13
    Es handelt sich um das Logitech z2100 2.1 System meine ich. Also die beiden Lautsprecher sind am Subwoofer mit einem cinch angeschlossen und vom Subwoofer dann eine kleine Klinke in den Line-Out der Soundkarte.

    Du meinst also ein cinch-klinke Adapter und dann vom M-Audio (cinch) in den Line-In (kleine klinke) der Soundkarte ?
     
  14. pico

    pico HCA-Recording Ex-Moderator HCA

    Im Board seit:
    30.06.07
    Zuletzt hier:
    7.12.16
    Beiträge:
    15.036
    Ort:
    Maintal near Frankfurt/M
    Zustimmungen:
    884
    Kekse:
    69.049
    Erstellt: 14.08.08   #14
    nö -

    Boxen --------- (Klinke) -- Adapter auf Cinch -- M-Audio
     
  15. Dr.Berst

    Dr.Berst Registrierter Benutzer

    Im Board seit:
    26.03.08
    Zuletzt hier:
    27.08.14
    Beiträge:
    122
    Ort:
    Berlin
    Zustimmungen:
    0
    Kekse:
    261
    Erstellt: 18.08.08   #15
    hi.

    ich hatte auch etwas trouble mit meinem interface (toneport gx) und der kabelstöpselei. am ende ist es jetzt so:

    gitarre -> toneport -> line in von on-board(!)-soundkarte.
    boxen normal an soundkarte. und natürlich die usb-verbindung.

    dann muss man gegebenenfalls noch im rechner am mixer den line-eingang hochziehen und zack hat man wieder alles aus den boxen über die soundkarte ohne merkbare Latenz.

    Alternativ: Du kannst auch unter Windows(?) als Wiedergabequelle das Interface wählen, dann geht alles über die quasi externe Soundkarte. Aber da bei mir midis nicht gingen, hab ichs wie oben gemacht.

    grüße.
     
  16. synthesist

    synthesist Threadersteller Registrierter Benutzer

    Im Board seit:
    13.08.08
    Zuletzt hier:
    26.08.08
    Beiträge:
    7
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 23.08.08   #16
    Jo, also bei mir funktioniert es jetzt auch (Windows) allerdings nur mit dem m-audio als output. mit der soundkarte als output bekomme ich das nicht hin, hab das auch nicht mehr weiter ausprobiert .. zu nervig. Ich habe herausgefunden, dass der Treiber, sowohl der alte auf der CD als auch der aktuelle von der m-audio website nicht 100%ig stabil ist. Diese waren auch mit schuld, dass das so lange gedauert hat. zB. kann es sein, dass wenn ich die usb Verbindung kappe den Treiber des Gerätes neu installieren muss, weil ich ums Verrecken das Gerät nicht mehr ansprechen kann.
    Na ja, jetzt bin ich jedenfalls zufrieden und habe wieder voll den Spaß dran - Sehr zum Leidwesen der Nachbarn ;)
     
  17. Superignorant

    Superignorant Registrierter Benutzer

    Im Board seit:
    24.08.08
    Zuletzt hier:
    21.02.09
    Beiträge:
    44
    Zustimmungen:
    0
    Kekse:
    10
    Erstellt: 24.08.08   #17
    Griasdi,
    Warum ist es besser die Gitarre über ein Interface wie Toneport
    laufen zu lassen, anstatt dirket in Line?

    Ein bisschen weniger Rauschen bei Ampsimulationen?

    By the way die RevalverMK3 Demo rauscht bei mir Null
    Guitar Rig ect. schon.
     
  18. Dr.Berst

    Dr.Berst Registrierter Benutzer

    Im Board seit:
    26.03.08
    Zuletzt hier:
    27.08.14
    Beiträge:
    122
    Ort:
    Berlin
    Zustimmungen:
    0
    Kekse:
    261
    Erstellt: 25.08.08   #18
    Weil im Allgemeinen dann weniger Latenzen auftreten. Die A/D-Wandler im Interface sind meist besser (schneller und leistungsfähiger) als die auf der (Onboard-)Soundkarte. Aufgrund von qualitativ hochwertigerer Signal-Wandlung wird auch der Klang weniger in Mitleidenschaft gezogen. Teure Karten natürlich ausgeschlossen...

    Ich behaupte mal, das in Guitar Rig selbst das Rauschen so nachempfunden ist, wie es ein echter Verstärker von sich geben würde... Du kannst ja auch einen "Brumm-Unterdrücker" einschalten. Dann rauscht nix mehr. ;)

    @thread-ersteller:
    meinen Glückwunsch (an die Nachbarn...)

    grüße.
     
Die Seite wird geladen...

mapping